๐Ÿš€ go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: alt.sys.amiga
Article #74

Re: 8-bit on mail (was: Re: Open Letter To Amigan's! - message1.wps (1/1))

#74
From: Philip Stokes
Date: Mon, 09 Dec 1996 00:00
93 lines
5031 bytes
Rask Ingemann Lambertsen (rask@kampsax.dtu.dk) wrote:
> Den 20-Nov-96 20:48:16 skrev Keith Blakemore-Noble f๏ฟฝlgende om "Re: 8-bit on
> mail (was: Re: Open Letter To Amigan's! - message1.wps (1/1))":
> 
> > Look, whether you personally like it or not, the STANDARD for news transfer
> > IS 7-BIT.  Fact.
> 
> If it is a fact that it is a standard, please say which RFC this is in and quote
> the appropriate section.

RFC-1036 (Standard for Interchange of USENET Messages)

    2.  Message Format

    [...]
                                   Therefore, the rule is adopted that
    all USENET news messages must be formatted as valid Internet mail
    messages, according to the Internet standard RFC-822.  The USENET
    News standard is more restrictive than the Internet standard,
    placing additional requirements on each message and forbidding use
    of certain Internet features.  However, it should always be possible
    to use a tool expecting an Internet message to process a news
    message.  In any situation where this standard conflicts with the
    Internet standard, RFC-822 should be considered correct and this
    standard in error.

RFC-822 (Standard for the Format of ARPA Internet Text Messages)

                                                ; (  Octal, Decimal.)
    CHAR        =  <any ASCII character>        ; (  0-177,  0.-127.)

RFC-821 (Simple Mail Transfer Protocol)

    4.5.2.  TRANSPARENCY

    The mail data may contain any of the 128 ASCII characters.  All
    characters are to be delivered to the recipient's mailbox
    including format effectors and other control characters.  If
    the transmission channel provides an 8-bit byte (octets) data
    stream, the 7-bit ASCII codes are transmitted right justified
    in the octets with the high order bits cleared to zero.

    APPENDIX A

    Data Transfer

    The TCP connection supports the transmission of 8-bit bytes.
    The SMTP data is 7-bit ASCII characters.  Each character is
    transmitted as an 8-bit byte with the high-order bit cleared to
    zero.

soRFC-1036 (News Article Format and Transmission - Internet Draft
            to be)

    4.4. Characters And Character Sets

    Articles  MUST  not  contain  any octet with value exceeding
    127, i.e. any octet that is not an ASCII character.

         NOTE: This rule, like others, may  be  relaxed  by
         unanimous  consent of the members of a cooperating
         subnet, provided suitable precautions are taken to
         ensure  that  rule-violating  articles do not leak
         out of the subnet.  (This has already been done in
         many  areas  where  ASCII  is not adequate for the
         local language(s).)  Beware that articles contain-
         ing non-ASCII octets in headers are a violation of
         the MAIL specifications and  are  not  valid  MAIL
         messages.   MIME  offers a way to encode non-ASCII
         characters in ASCII for use in headers;  see  sec-
         tion 4.5.

         [...]

         NOTE:  8-bit  enthusiasts  are warned that not all
         software conforms to  these  recommendations  yet.
         In particular, standard NNTP [rrr] is a 7-bit pro-
         tocol, and  there  may  be  implementations  which
         enforce  this rule.  Be warned, also, that it will
         never be safe to send raw binary data in the  body
         of news articles, because changes of EOL represen-
         tation may (will!) corrupt it.

Now if Rask would just confine himself to 7-bit ASCII in his postings
to the AWeb mailing list, they wouldn't be auto-converted to Base-64
by the mail gateway of the ISP on which the list runs, which
apparently enforces the above rules!

Phil
-- 
Philip Stokes      phil@stokes.demon.co.uk
PGP 2.6.3i Public Key available on request
Technical Details
Message-ID: <96120950172.phil@stokes.demon.co.uk>
Path: arc1-ca.pugleaf.net!unknown!not-for-mail
References: <1996111180777keith@amiga.u-net.com> <peterk.0v36@combo.ganesha.com> <1379.6894T630T933@icenet.no> <1996111747890keith@amiga.u-net.com> <peterk.0v7d@combo.ganesha.com> <1996112071294keith@amiga.u-net.com> <732.6915T1172T2314@kampsax.dtu.dk>

Show Full Headers
Complete Article Headers
X-Google-Language: ENGLISH,ASCII
X-Google-Thread: 106ac0,d7089fad98aa94b9
X-Google-Attributes: gid106ac0,public
X-Google-Thread: 11015b,d7089fad98aa94b9
X-Google-Attributes: gid11015b,public
X-Google-Thread: 102591,d7089fad98aa94b9
X-Google-Attributes: gid102591,public
X-Google-Thread: 10e72b,d7089fad98aa94b9
X-Google-Attributes: gid10e72b,public
From: news@stokes.demon.co.uk (Philip Stokes)
Subject: Re: 8-bit on mail (was: Re: Open Letter To Amigan's! - message1.wps (1/1))
Date: 1996/12/09
Message-ID: <96120950172.phil@stokes.demon.co.uk>
X-Deja-AN: 203139552
x-nntp-posting-host: stokes.demon.co.uk
references: <1996111180777keith@amiga.u-net.com> <peterk.0v36@combo.ganesha.com> <1379.6894T630T933@icenet.no> <1996111747890keith@amiga.u-net.com> <peterk.0v7d@combo.ganesha.com> <1996112071294keith@amiga.u-net.com> <732.6915T1172T2314@kampsax.dtu.dk>
followup-to: alt.sys.amiga,comp.sys.amiga.advocacy,comp.sys.amiga.misc,demon.ip.support.amiga
x-files: The truth is out there
reply-to: phil@stokes.demon.co.uk
newsgroups: alt.sys.amiga,comp.sys.amiga.advocacy,comp.sys.amiga.misc,demon.ip.support.amiga