🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: aus.computers.linux
Article #993

Re: Tftp server problem

#993
From: Andrew Kenna
Date: Sun, 03 Aug 2008 07:11
89 lines
4571 bytes
why the heck would you want to use tftp on a large file, if your 
transferring a cisco ios upgrade to your router  i'd imagine the image 
wouldn't be anymore than 15mb.

FTP is used to transfer files, TFTP is trivial ftp meaning trivial file 
sizes not files going into the double digit MB

Have you tried to ping the tftp server from your cisco router to make sure 
there is connectivity happening and also have you looked at your firewall to 
see if it could be blocking the tftp transfer.

Its possible your router might be allowing large files, your server might 
allow them but if the firewall is not then nothing you do is going to work 
until you solve that problem

Andrew


"bulli" <surendra.anne@gmail.com> wrote in message 
news:c0004f58-9400-4109-95db-0e2431188865@l28g2000prd.googlegroups.com...
> hi Experts,
> I am facing some problem with tftp-server in Redhat linux
> Actually we used this tftp server for IOS image coping in to routers
> the problem is
> actually we installed tftp-server-0.40-1 package on my Redhat linux
> server
> and edited /etc/xinetd.d/tftp as below
>
> service tftp
> {
>        socket_type             = dgram
>        protocol                = udp
>        wait                    = yes
>        user                    = root
>        server                  = /usr/sbin/in.tftpd
>        server_args             = -u root -c -U 111 -s /tftp/
>        disable                 = no
>        per_source              = 11
>        cps                     = 100 2
>        flags                   = IPv4
> }
>
> so our tftp server uses /tftp/ as default/public folder for our TFTP
> server
> and we kept our images in that /tfpt server and started the xinetd
> service
> then i loged in to router and when we started copying the image middle
> its stoping the coping
>
> R7348-PRE4#copy tftp: disk0:
> Address or name of remote host []? 73.48.0.1
> Source filename []? /tftp/images/test
> Destination filename [test]?
> Accessing tftp://73.48.0.1//tftp/images/test...
> Loading /tftp/images/test from 73.48.0.1 (via
> FastEthernet0/0/0): 
> !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!...
> [timed out]
>
> %Error reading tftp://73.48.0.1//tftp/images/test (Timed out)
>
> This is the problem we are facing
> actually i tried for different images
> the files/images which are less than 32MB is coping properly with out
> any problem
> the files/images which are more than 32MB are not able to copy and
> giving timed out error
> so i did some googling and found that some older version TFTP servers
> will not support with a file size more than 32MB
>
> "The original protocol has a file size limit of 32 MB,
> although this was extended when RFC 2347 introduced option
> negotiation,
> which was used in RFC 2348 to introduce block-size negotiation in
> 1998
> (allowing a maximum of 4 GB and potentially higher throughput).
> If the server and client support block number wraparound, file size is
> essentially unlimited."
>
> but what the software we use, it will support up to 192MB
> here we got strucked :(
>
> here my question is.. Is there any file to see what is the tftp limit
> in my server
> or can any one give a solution for this one how to copy files which
> are more then 32MB?
>
> Thanks in advance
> Surendra 
Technical Details
Message-ID: <48955a26$1@dnews.tpgi.com.au>
Path: arc1-ca.pugleaf.net!g2news1.google.com!news1.google.com!news2.google.com!border1.nntp.dca.giganews.com!nntp.giganews.com!nx02.iad01.newshosting.com!newshosting.com!newsfeed.icl.net!newsfeed.fjserv.net!newsfeed.freenet.de!solnet.ch!solnet.ch!nntp.gblx.net!nntp3.phx1!dnews.tpgi.com.au!tpg.com.au!not-for-mail
References: <c0004f58-9400-4109-95db-0e2431188865@l28g2000prd.googlegroups.com>

Show Full Headers
Complete Article Headers
X-Google-Thread: 102983,8c0fe8d754bb834f
X-Google-Attributes: gid102983,domainid0,public,usenet
X-Google-Language: ENGLISH,ASCII-7-bit
Reply-To: "Andrew Kenna" <abuse@tpg.com.au>
From: "Andrew Kenna" <abuse@tpg.com.au>
Newsgroups: aus.computers.linux
References: <c0004f58-9400-4109-95db-0e2431188865@l28g2000prd.googlegroups.com>
Subject: Re: Tftp server problem
Date: Sun, 3 Aug 2008 17:11:23 +1000
Lines: 91
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: 60.240.158.98
X-Original-NNTP-Posting-Host: 60.240.158.98
Message-ID: <48955a26$1@dnews.tpgi.com.au>
X-Trace: dnews.tpgi.com.au!tpg.com.au 1217747494 60.240.158.98 (3 Aug 2008 17:11:34 +1000)
Path: arc1-ca.pugleaf.net!g2news1.google.com!news1.google.com!news2.google.com!border1.nntp.dca.giganews.com!nntp.giganews.com!nx02.iad01.newshosting.com!newshosting.com!newsfeed.icl.net!newsfeed.fjserv.net!newsfeed.freenet.de!solnet.ch!solnet.ch!nntp.gblx.net!nntp3.phx1!dnews.tpgi.com.au!tpg.com.au!not-for-mail