🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: borland.public.cppbuilder.internet.web
Article #977

Re: A basic question

#977
From: mike
Date: Fri, 03 Mar 2006 13:01
38 lines
2343 bytes
Thank you Hans and Remy for responding, I appreciate it very much.

So my understanding of your response is that the data positioned after the 
port identity is just sent to the application listening on the port. It 
would be the same as if an application using sockets to talk to a module 
running on the server sent data on the socket port.

Am I correct on this interpretation.

Mike

"Remy Lebeau (TeamB)" <no.spam@no.spam.com> wrote in message 
news:440801d4@newsgroups.borland.com...
>
> "mike" <mfbrowne@earthlink.nnet> wrote in message
> news:4407c261$1@newsgroups.borland.com...
>
>> I have a basic question that I am trying to understand.
>
> Have a look at RFC 1945 (http://www.ietf.org/rfc/rfc1945.txt) and RFC 2616
> (http://www.ietf.org/rfc/rfc2616.txt).  They describe the semantics of the
> HTTP protocol at the TCP/IP level.
>
> As for what happens on the server, when it receives the request you
> showedrequest, it parses the string "/help/12345/full", decides what to do
> with it, and then returns the appropriate data back to the browser.  The
> string is just a string, so the server can process it any way it wishes. 
> It
> does not have to be a physical file or folder.  All the server has to do 
> is
> receive requests and send responses.  How it decides what data to send is 
> at
> the server's descretion.
>
>
> Gambit
>
> 
Technical Details
Message-ID: <44083e2c$2@newsgroups.borland.com>
Path: arc1-ca.pugleaf.net!g2news1.google.com!news2.google.com!news4.google.com!border1.nntp.dca.giganews.com!nntp.giganews.com!newsfeed00.sul.t-online.de!newsfeed01.sul.t-online.de!t-online.de!newsgroups.borland.com!not-for-mail
References: <4407c261$1@newsgroups.borland.com> <440801d4@newsgroups.borland.com>

Show Full Headers
Complete Article Headers
X-Google-Thread: feeec,36fc6a33640b8660
X-Google-Attributes: gidfeeec,public
X-Google-Language: ENGLISH,ASCII-7-bit
From: "mike" <mfbrowne@earthlink.nnet>
Newsgroups: borland.public.cppbuilder.internet.web
References: <4407c261$1@newsgroups.borland.com> <440801d4@newsgroups.borland.com>
Subject: Re: A basic question 
Date: Fri, 3 Mar 2006 08:01:28 -0500
Lines: 40
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: 70.121.252.179
Message-ID: <44083e2c$2@newsgroups.borland.com>
X-Trace: newsgroups.borland.com 1141390892 70.121.252.179 (3 Mar 2006 05:01:32 -0700)
Path: arc1-ca.pugleaf.net!g2news1.google.com!news2.google.com!news4.google.com!border1.nntp.dca.giganews.com!nntp.giganews.com!newsfeed00.sul.t-online.de!newsfeed01.sul.t-online.de!t-online.de!newsgroups.borland.com!not-for-mail