Article View: ch.network
Article #516Re: Realtime Networks
From: Daniel G. Kluge
Date: Fri, 15 May 1998 00:00
Date: Fri, 15 May 1998 00:00
235 lines
10571 bytes
10571 bytes
On Sat, 09 May 1998 12:04:14 GMT, Guy <gsil@cyberdude.com> wrote: >Hello, > >I am a second degree student in the Tel-Aviv University, >and I am searching for information on the theory behind >building networks (or communication in general) in >Real-Time systems: protocols, drivers, hardware ... >What are the special guidelines and aspects special to >realtime systems, how realtime systems' theory is >implemented in networks etc. This is the Literature list for my Diploma Thesis on a Quality of Service Archtitecture, most of it relates to Real-Time Problems, and the guaranteed quality of service. The text is extracted from the Postscript file, using a simple Perl-Script, I hope it is readable enough. -daniel -- Daniel G. Kluge - CS-Student / http://www.vis.inf.ethz.ch/~daniel/ E-Mail: daniel@vis.inf.ethz.ch (NeXT-Mail welcome) PGP-Key ID: 847D5C6D Semantik von Quality of Service Attributen 9.0 Literatur /Bebo96/Be Inc, The Be Book http://www.be.com/documentation/be_book/Ker- nelKit/misc.html#Thread Priority Constants /BDFi94/I.Barth, G.Dermler, W.Fiederer:Levels of Quality of Service in CINEMA; Institute of Parallel and Distributed High-Performance Systems \050IPVR\051, University of Stuttgart /BCSh94/R.Braden, D.Clark, S.Shenker:RFC 1633: Integrated Services in the Internet Architecture: an Overview: IETF Request for Comments 1633 /BZBH96/R. Braden, L.Zhang, S.Berson, S.Herzog S.Jamin:Resource ReSerVation Protocol \050RSVP\051; IETF, Internet Draft /Burk94/T.Burkow:Operating System Support for Distributed Multimedia Appli- cations; A Survey of Current Research; Pegasus paper 94-8 June, 1994 University of Cambrdige Computer Laboratory /CCGH93/A.Campbell, G.Coulson, F.Garcia, D.Hutchison, H.Leopold: Integrated quality of Service for Multimedia Communications; IEEE Infocom 1993 Vol. 2, pp 732-739 /ChWi89/D.R. Cheriton, C.L. Williamson:VMTP as the Transport Layer for High- Performance Distributed Systems; IEEE Communications Magazine 1989, vol. 27, nr 6, pp. 37-44 /Ches89/G. Chesson:XTP/PE Design Considerations; Protocols for High-Speed Networks, Zurich 1989 pp. 27-33 /CiGu95/I.Cidon, R.Gu\217rin:An Investigation of Application Level Perfomrance in ATM Networks; IEEE Infocom 1995, pp 845 - 852 /CLZh87/D.D. Clark, M.L. Lambert, L. Zhank:NETBELT: a Bulk Data Transfer Protocol; Network Working Group RFC 998, March 1987 /CBRo94/G. Coulson, G. Blair, P.Robin:Micro-kernel support for continuous media in distributed systems; Computer Networks and ISDN Systems 26 \0501994\051 pp. 1223-1341 /DBLL93/A. Danthine, Y. Baguette, G. Leduc, L.L\216onard:The OSI 95 Connection- Mode Transport Service - The Enhanced QoS; IFIP High Performance Networking IV, 1993, pp 235-252 /DHHS92/L. Delgrossi, C.Halstrick, R.Herrtwich, H.St\237ttgen:HeiTP - A Transport Protocol for ST-II; IEEE Globecom 1992, pp. 1369-1373 /DHHH93/L. Delgrossi, C. Halstrick, D.Hehmann, R.Herrtwich, O.Krone, J. Sand- voss, C. Vogt:Media Scaling for Audiovisual Communication with the Heidelberg Transport System; ACM Mutlimedia 93 \0506\051 /DHVW94/L. Delgrossi, R. Herrtwich, C. Vogt, L. Wolf:Reservation Protocols for Internetworks: A Comparison of ST-II and RSVP; Lecutre Notes in Com- puter Science, Vol. 846, pp. 195 - 204, 1994 /DDKW90/W. D\232ringer, D. Dykeman, M. Kaiserswerth, B. Meister, H. Rudin, R. Williamson:A Survey of Light-Weight Transport Protocols for High- Speed Networks; IEEE/ACM Transactions on Communications, Vol. 38, No. 11 November 1990, pp 2025 - 2039 /Drus96/P.Druschel:Operating System Support for High-Speed Communication; Communications of the ACM September 1996/Vol. 39, No. 9, pp 41 - 51 /Elli93/C.Elliott:High-Quality Multimedia Conferencing Through a Long-Haul Packet Network; ACM Multimedia 93 \0506\051, pp. 91 - 98 /FrSc95/O.Frick, C.Schmidt:Service Support for Multiuser Mulitmedia Applica- tions; University of Karlsruhe, Institute of Telematics, Technical Report 56Literatur /GoAn91/R. Govindan, D. Anderson:Scheduling and IPC machanisms for continu- ous Media; Proceedings of the 13th ACM Symposium on Operating Sys- tems Principles, 1991, pp. 68 - 80 /HaPi94/O. Hagsand, S. Pink:ATM as a Link in an ST-2 Internet; Lecture Notes in Computer Science, Vol. 846, pp. 185 -194 /HoSc96/ M.Hofmann, C.Schmidt:A Flexible Protocol Architecture for Multime- dia Communication in ATM-Based Networks; Institute of Telematics, University of Karlsruhe, Germany /HCCB94/D.Hutchison, G.Coulson, A.Campbell G.Blair:Quality of Service Man- agement in Distributed Systems; Lancaster University Report Number MPG-94-02, Chapter 11 /I356/ITU-T:Recommendation I.356 B-ISDN ATM layer cell transfer perfor- mance; ITU Geneva 1993 /I371/ITU-T:Recommendation I.371 Traf\336c control and congestion control in B-ISDN; ITU Geneva 1993 /Jeff92/K. Jeffay:On Kernel Support for Real-Time Multimedia Applications; 3rd Workshop on Workstation Operating Systems, IEEE CompSoc 1992, pp. 39 - 46 /JKML94/ J.Jung, J.Kim, K.Min, S.Lee:Quality of Service Aspects in Multi-media Applications; 5th IEEE COMSOC International Workshop on Multime- dia Communication 1994 /Jung96/Jae-Il Jung:Quality of Service in Telecommunications Part I: Proposi- tions of a QoS Framework and Its Applications to B-ISDN; IEEE Com- munications Magazine August 1996, pp. 108 - 111 /Jun296/ Jae-Il Jung;Quality of Service in Telecommunications Part II: Transla- tion of QoS Parameters into ATM Performance Parameters in B-ISDN; IEEE Communications Magazine August 1996, pp 112 - 117 /LoVa93/S.Low, P. Varaiya:A New Approach to Service Provisioning in ATM Net- works; IEEE/ACM Transactions on Networking, Vol. 1, No. 5, October 1993, pp 547 -553 /LCHS93/H.Leopold, A.Campbell, D.Hutchison, N.Singer:Towards an Integrated Quality of Service Architecture \050QOS-A\051 for Distributed Mutlie Media Communications; IFIP High Performance Networking IV 1993 /HaNe91/S. Hardt-Kornacki, L. Ness: Optimization Model for the deliviery of interactive Multimedia Documents; IEEE Globecom 1991, pp. 669-673 /MeMi96/B.Metzler, I.Miloucheva:Design and implementation of \337exible user Protocol Interface; Journal of High Speed Networks 5 \0501996\051 pp 145 - 158 /NaSm93/K. Nahrstedt, J. Smith:An Application-Driver Approach to Networked Multimedia Systems; Conference on Local Computer Networks Vol. 18 1993, pp 361-368 /NaSt95/K.Nahrstedt, R.Steinmetz:Resource Management in Networked Multime- dia Systems; IEEE Computer May 1995, pp 52 - 63 /NRSa90/A. Netravali, W.Roome, K. Sabani:Design and Implementation of a High-Speed Transport Protocol: IEEE Transactions on Communications, Vol 38, No. 11 November 1990 /PrEn92/Protocol Engines, Inc.:XTP Protocol De\336nition - Revision 3.6, January 1992 /PPVW93/ T.Plagemann, B.Plattner, M. Vogt, T. Walter:A Model for Dynamic Con- \336guration of Light-Weight Protocols; IEEE 3rd Workshop on Future Trends of Distributed Systems, Taipeh, Taiwan, April 199 /Schap96/R. Schaphorst:Videoconferencing and Videotelephony; Artech House Publishers, Boston 1996 Semantik von Quality of Service Attributen57 /SMHW95/A.Schill, C.Mittasch, T. Hutschenreuther, F.Wildenhain:A Quality of Ser- vice Abstraction Tool for Advanced Distributed Applications; IFIP Inter- national Conferenc on ODP, Brisbane Australia, 1995 pp 359 -371 /SCFJ96/H.Schulzrinne, S.Casner, R.Frederick, V.Jacobson:RTP: A Transport Protocol for Real-Time Applications, RFC 1889, IETF /SCZh93/S.Shenker, D.Clark, L.Zhang:A Service Model for an integrated Serv- erices Internet; Internet Draft draft-shenker-realtime-model-00.ps /SPGu97/S.Shenker, C.Partridge, R.Guerin: Speci\336cation of Guaranteed Quality of Service, internet-draft, expires 8/3/98 /SiZn93/N. Simoni, S. Znaty:QoS: From De\336nition to Management IFIP High Performance Networking IV, 1993, pp 253 - 264 /Stei95/R.Steinmetz:Analyzing the Multimedia Operating System; IEEE Multi- media Spring 1995 pp 68 - 84 /SUN94/SUN Microsystems Inc.: Sun Video User\325s Guide; SUN Microsystems Inc. Part Number 802-1318-10 Rev. A August 1994 /Topo90/C. Topolcic:Experimental Internet Stream Protocol, Version 2 \050ST-II\051, RFC 1190, IETF /ToKi93/H.Tokuda, T.Kitayama:Dynamic QoS Control based on Real-Time Threads; Network and operating system support for digital audio and video, 4th International Workshop, NOSSDAV 1993 /USEN97/USENET: MPEG-FAQ; relevant Sections are from the ISO-Standard ISO 13818-2 /WcSc96/L. Wall, T.Christiansen, R.L.Schwartz:Programming Perl; O\325Reilly & Associates, Inc., Sebastopol 1996 /WaCr94/Z.Wang, J.Crowcroft:QoS Routing for Supporting Resource Reservation; Departement of Computer Sciene, University College London /Wha89/A.D. Whaley:The XPRESS Transfer Protocol; 14th Conference on Local Computer Networks, 1989, pp. 408 - 414 /Wroc96/J.Wroclawski:The Use of RSVP with IETF Integrated Services, Internet Draft, expires 3/97 /VKBG95/A.Vogel, B.Kerherv\217, G. von Bochmann, J.Gecsei:Distributed Mutilme- dia and QoS: A Survey;IEEE Multimedia Summer 1995, pp 10 - 19 /Vrom96/Johan Vromans: Perl Reference Guide Revision 5.001.2; Squirrel Design 1996 http://www.xs4all.nl/~jvromans/perlref.html /X903/Reference Model of Open Distributed Processing-Part 3: Prescritive Model,International Standard 10746-3, ITU-T Recommendation X.903, ITU-ISO, Geneva, 1995 /ZDES93/L. Zhang, S.Deering, D.Estrin, S.Shenker, D.Zappala: RSVP: A New Resource ReSerVation Protocol; IEEE Network September 1993, pp 8-17 /ZBSc95/ J.Zinky D.Bakken, R.Schantz:Overview of Quality of Service for Dis- tributed Objects; Distributed Systems Departement, BBN Systems and Technologies, to appear in IEEE \322Dual Use Technologies Conference\323, Utica, NY 1995 /ZSTa93/M. Zitterbart, B. Stiller, A. Tanawy: A Model for Flexible High-Perfor- mance Communication Subsystems; IEEE Journal on Selected Areas in Communications, Vol. 11, No. 4, May 1993, pp 507-518.
Technical Details
Message-ID:
<slrn6lo81d.v5.daniel@neelix.iiic.ethz.ch>Path:
arc1-ca.pugleaf.net!unknown!not-for-mailReferences:
<6j1h30$d02$2@news.netvision.net.il>Show Full Headers
Complete Article Headers
X-Google-Language: ENGLISH,ASCII-7-bit X-Google-Thread: f8cd8,2154d6e7d72f3bb5 X-Google-Attributes: gidf8cd8,public From: daniel@vis.inf.ethz.ch (Daniel G. Kluge) Subject: Re: Realtime Networks Date: 1998/05/15 Message-ID: <slrn6lo81d.v5.daniel@neelix.iiic.ethz.ch> X-Deja-AN: 353478492 References: <6j1h30$d02$2@news.netvision.net.il> Organization: Verein der Informatikstuierenden an der ETH Reply-To: daniel@vis.inf.ethz.ch Newsgroups: ch.network