🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: cn.comp.www
Article #60

���������������������ڹȸ���ҳ�������ȸ� Chrome �е�����

#60
From: ����99.Run-Feed2News
Date: Sat, 08 Nov 2008 10:15
274 lines
21030 bytes
=-=-{����} =-=-=-=-=-=-=-=-=-=-=-=-=-=-
�����ߣ��ȸ������ʦ ̷���� Frank Yung-Fong Tang 

���죬��������ҽ���һ�����õĹ��ܡ����������������������������ã�������Ĺ�
�ܿ�����������������������������Ҳ��һ��, �ȽϹȸ�����������������������
����Ĺ��ܲ��졣


�ȸ���������������

�ȸ�Ӻ���Ϳ�ʼ֧�֡�ָ����վ�� (site restrict) ��������������������Ҳ�׷�Ч
��������֧�֡�ָ����վ�����������磬�������������� site:cnnic.cn������������ site:cnnic.cn
�� ����ָ���ڡ�cnnic.cn����վ�������йء����������ҳ�档����һЩ�������������
��Ҳ��������ûʲôϡ�档����������������ǡ��������� site:�й���������Ϣ����.cn
������������ site:�й���������Ϣ����.cn����Ҳ����ָ��Ҫ�ڡ��й���������Ϣ����.cn
����һ�������������վ�������йء������������ҳʱ(ͼһ) ����ͻᷢ�֣��󲿷���
��ĵ����������û���κν���ˡ�   
    

ͼһ���ȸ�������ʾ�������������� site:�й���������Ϣ����.cn���Ľ��

�ٿ���һ�����Ӱɣ������ڹȸ����� ��site:������ѧ.cn �ػ͡���site:������ѧ.cn ��
�͡� �����ҵ����ͼ��)���������������������ʲô���Ҳ�Ҳ����� 
    

ͼ��:�ȸ�������ʾ������site:������ѧ.cn �ػ͡��Ľ��

�ڹȸ����������У�����֧�����ɡ��й���������Ϣ���ġ�������Ĺ�ʻ������絥λ
��ͬ�ƹ�ġ���������Ҳ����˵���ǵ����������У���������������������治Ը����
���ǵ�����������վ�����������(��ͼ��)�У����ǿɿ������������й����������г�����
������Ҫ��ݡ����й����������г����鱨����Ҫ��ݡ��Ľ���������ԡ�www.�й�����
����Ϣ����.cn����վΪ��ַ�Ľ����������һЩ�����������ǿ������ġ���Ϊ��Щ������
�沢��֧���������� 
    

ͼ��: �ȸ�������������С�www.�й���������Ϣ����.cn���Ľ�� 

�ȸ� Chrome Ҳ����������  

������ˣ��ȸ� Chome ������ڹȸ蹤��ʦ��Ŭ��֮��Ҳ����֧�����������ڵ�ַ����
���� http://������ѧ.cn/ academic/zggds/005/003/001.htm (����ͼ����ʾ)��Ҳ�ܷ���
����ҳ���� FireFox ���������һ���ܵ���Ҳ���ɹȸ蹤��ʦ�������ڼ���ȸ�֮ǰ��ְ��
��˾����������ġ���һ������ IE7 ��Ҳ�С������ڹȸ� Chrome ������� IE7 ��
��Ϊ�˰����û��ֱ���ʵ���������������Ƶļ���������ҳ����������������֮��
������������趨������֮�ڣ�����Բ��׶��� Punycode ��ʾ (���磺 "http://������ѧ.cn/"
 ����ʾ�� "http://xn--1lq90ic7fzpc.cn/" )�� ����ֻ�����û�ʹ�����İ�������ʱ��
����������ȸ�Chrome ������� IE7 ������������Ĺ��ܡ���������ʹ��Ӣ�Ļ���������
�����������������"�����趨"һ���м���"����"����������������ģ������Բ��׶�
�� Punycode ����ʾ��������

    

ͼ��:�ȸ� Chrome �� FireFox ���ɿ��� http://������ѧ.cn/academic/zggds/005/003/001.htm
 �Ľ�� 

���й������������ĵ��ӱ��� 

��ʵ�����������׼�ƶ��������з�����ʮ��ǰ���Ѿ���Ȼ��ʼ��������һ�����漰ȫ��
���� DNS ����������·Э���ļ����������Լ���ͬ����������������������ϣ���ʱ��
�������С��й���������Ϣ���ġ�(CNNIC)�����������ǻ���������������ⷽ�档����ǰ
��ʼ����վ������ .cn ��ע��ʹ������������"http ://������ѧ.cn"�����գ��й�һЩ
�������ű������ܴ� 2009 �꿪ʼ".�й�"ҲҪ���ã�����"http://������ѧ.�й�" (���ڻ�
������)��Ŀǰ���й������õ� http://����.���� �׼�������ڻ������в���ʹ�á����߲�
���ڹȸ���Ƶ�����п�һ�� CCTV ����ر�������ر����� 

�ȸ蹤���Ŷ��г�������������������Ĺ���ʦ 

�����ǵĹȸ蹤���Ŷ��У��������곤������������������/�������Ĺ���ʦ��������
�ĺܶ������ڼ���ȸ�֮ǰ���ڹ��������繤��Э�ἰҵ������������������ġ����¾�
�򵥽���һ����Щ����֪����������Щ���ȸ��ˡ� ��Googlers)���������ڼ���ȸ�ǰΪ��
���������Ŭ����

��������׼�ı�׼�ƶ� 

��ά��Э��(W3C)�� Martin Duerst �� Richard Ishida �����ϸ�����ĩ�ͻ��˺ܶ�ʱ��
����������ĸ�������������Ҫ�������֮һ�����й����˹������Ĺ�ʱ�׼��
�п��ܹ㷺��ʵʩ��������ʱ����������֪������ Martin ������ĺ� DNS �ֿ����ϣ�
̫����ʵ�ʣ��������룬ʵ�ں��գ�����Martinһֱ���������룬Ϊ�˶෽���ߣ������� 1999
 �� 11 �£�������������� (IETF) ��ʼ�˹�������׼�Ķ���������


�������������׼�ƶ��Ĺȸ蹤��ʦ 

�� 2002-2003 �꣬��������Ļ��������IDNA����׼����ҵ��ܶ��˵�Ŭ������ʼ
���Ρ���ʱ�ڼ��ݴ�ѧ�ؿ�����У����ʿ�� Adam M. Costello �����ж��ݱ�׼��RFC 3490 
�� RFC3492�������ߣ�Adam �� 2004 �����ȸ衣��ʱ�� IBM ��˾����ʦ�� Mark Davis 
Ҳ�ڱ�׼������Ͷ���˲����������� 2003 ���ϰ��꣬���������ķ���Ҫ��׼������

 RFC 3454: �Ʊ���ʻ��ִ���stringprep�� (2002 ��ʮ����) 
 RFC 3490: ��ʻ������е�Ӧ�ã�IDNA�� (2003 ������) 
 RFC 3491: Nameprep�� һ��Ϊ��ʻ���������Ƶ� Stringprep (2003 ������) 
 RFC 3492: Punycode�� һ��Ϊ��ʻ�����ϵͳ��Ӧ�õ� Bootstring �� Unicode ����
 (2003 ������)

�����ķ������׼����֮��½����ҵ�����ʵʩ��������һЩ��ȫ�Ե����ѣ��������
������ͳһ�������һЩ���ͽ��Ƶ����⣬Ϊ�ˣ�Mark Davis ���������¶��ݡ�ͳһ�뼼��
���桱 (UTR: Unicode Technical Report)���������ļ�Ҳ��Ϊ��ʵʩ�������Ļ�ʯ֮һ
��

 UTR 36: ͳһ�밲ȫ���� (2008 ������) 
 UTR 39: ͳһ�밲ȫ���� (2006 �����)  

��������м������������ܵĹȸ蹤��ʦ 

2003 �꣬���ߣ�̷����/Frank Yung-Fong Tang����ʱ��ְ��˾��Netscape Communication
����������?Sr. Technical Manager�������ܡ��ͻ��������ʻ�������������ּ���
�����顱��Client Internationalization and Multilingual Text Engineering Group����
�����ڿ���ʽ��� Mozilla/Gecko (Ҳ�������ڵ� FireFox ����)�еı��뼰����������ʾ
�Ⱥ��Ĺ��̿��������ιȸ��ܲ��������ܵ���ʤ����Bob Jung�����ҵ�ʱ����Ĺ��̲���
�Ρ����Ƽ�(Shanjian Li)��Brian Stell �����ιȸ蹤��ʦ��ʱҲ���ҵ����ڡ�����������
��׼�ƶ�����У����Ǿ������˽⵽��һ�����Եı�׼��δ�����������������ʹ���м�
��Ĺ��ס���˹�������׼���κ�����(����һЩ����Ŀǰ���ڹȸ���ְ�Ĺ���ʦ)�Ͱ� IDNA
 �Ľ������ܼ����˵�ʱ�� Mozilla/Gecko Ϊ��� FireFox �����С�Ҳ����˵������ 2003
 �����������ʹ�á������������վ�ˡ���Ȼ����ʱ�������dz���������֮�󾭹���
���˵ĸ��������� FireFox ����������������ܼ���ʾҲ�ȵ�ʱ����걸�����к�������ǰ
����ʦ Erik van der Poel ����ʱ��Ү³����ʿ�ĺ��� Jungshik Shin (������) Ҳ��
֮�������࣬����Ҳ�������ιȸ蹤��ʦ��


�˺�΢���� IE 7 ��Ҳ��������������������ܡ�


���ͬʱ����ʱ���� IBM �� Mark Davis �� Markus Scherer Ҳ��ʼ�ڿ�Դ����� ICU 
�м���������Ľ������ܡ�����λҲ�� 2006 �궼�����˹ȸ衣


���꣬Jungshik Shin �ڹȸ������ Chrome �м����˹������Ĺ��ܡ�

    

ͼ��: Chrome �� FireFox ����������������� 

�ȸ������������м�������������ҳ 

2005-2006 �꣬���������ڵ����ǰ���ʹ��̲�����ʦ�����ǰ IBM ���ͳһ�빤��
��Ĺ���ʦҲ����ȸ衣����������ͳһ��Э�����ϯ Mark Davis����Щͬ�ʶ��������߰�
��ǰ��������ʼ�滮��׼ʱ�͹�ע��������ģ���������һֱ��ע��������ķ�չ������
�Ǽ���ȸ�ʱ����ʱ�ȸ���������������ѱȽϳ��졣�������ȸ蹤��ʦ�����ļ�������
����������ʮ���������� Erik van der Poel (��Ҳ���ձ����ʱ����׼ RFC 1468 ISO-2022-JP
 ������) ���ⷽ�渶���˲���Ŭ��������������һЩͬ�ʵĺ����������ڹȸ���������
Ҳ���Կ�����������������������


�ȸ��ڹ�������׼���°汾�޶����������Ͷ�� 

Ϊ��ȷ����������ʵʩ���Է��ʵ�ʣ�ͬʱ�ܸ�õ���ԡ�����·��ֵ����⣬�ȸ���
��������׼���°汾�޶����������Ͷ�롣Ŀǰ��Ϊ�ȸ踱�ܲü���ϯ�������ߵĻ�
����֮�� Vint Cerf (���ڹ�ҵ�繫��Ϊ�ǡ�������֮����֮һ, ��Ϊ���� 1974 �� TCP ��
·Э������Ҫ����) Ŀǰ�� IDNAbis (��������׼���°�) ���������ϯ��2001-2005 ��
���λ������������ (IETF) ��ϯ�Ĺȸ�Ų�������о�Ժ���� Harald Alvestrand ĿǰҲ
�ǡ����������ʹ�����ҵ������ı�׼��(���ҵ������ġ����簢�����ģ�ϣ������)������
֮һ�� 

����

����ϣ����Ϊ�ȸ������������м�����������Ĺ��ܣ����Է����û�ʹ��ͬʱҲ��������
�����������������ⷽ�湦�ܵIJ�ȫ����δ��Ҳ�ܼ���֧��������������У��Ӷ��ȫ�й�
����·��չ�������湱�ס�ϣ�������տ�����ôһ�졣


��л 

׫���ڼ��� Erik van der Poel, William Farris, Jungshik Shin ��ͬ��ָ���ڴ���
����  

������� 

 RFC 3454: �Ʊ���ʻ��ִ���stringprep�� (2002��ʮ����)  RFC 3454: �Ʊ����
���ִ���stringprep�� (2002��ʮ����) 
 RFC 3490: ��ʻ������е�Ӧ�ã�IDNA�� (2003������)  RFC 3490: ��ʻ�������
��Ӧ�ã�IDNA�� (2003������) 
 RFC 3491: Nameprep�� һ��Ϊ��ʻ���������Ƶ� Stringprep (2003������)  RFC
 3491: Nameprep�� һ��Ϊ��ʻ���������Ƶ� Stringprep (2003������) 
 RFC 3492: Punycode�� һ��Ϊ��ʻ�����ϵͳ��Ӧ�õ� Bootstring �� Unicode ����
 (2003������)  RFC 3492: Punycode�� һ��Ϊ��ʻ�����ϵͳ��Ӧ�õ� Bootstring ��
 Unicode ���� (2003������) 
 UTR 36: ͳһ�밲ȫ���� (2008������)  UTR 36: ͳһ�밲ȫ���� (2008������) 
 UTR 39: ͳһ�밲ȫ���� (2006�����)  UTR 39: ͳһ�밲ȫ���� (2006�����) 

�����������������ҳ:  
 IDNwikiIDNwiki http://idn.icann.org/ 
 http://����.���� http://����.����
 IDN Test URLsIDN Test URLs http://blogs.msdn.com/shawnste/archive/2006/09/14/754882.aspx


-=--=-=-=-=-=-=-=-=-=-=-=-=-=-===---===-=--====-=

-=-{ =-= }-=-
�飺cn.comp.www,cn.finance,cn.comp.internet
=-={ -=- }=-=


**����**��

���������� site:cnnic.cn��

http://www.google.cn/search?hl=zh-CN&q=��������+site%3Acnnic.cn
----
���������� site:�й���������Ϣ����.cn��

http://www.google.cn/search?hl=zh-CN&q=��������+site%3A�й���������Ϣ����.cn
----
ͼƬ
http://googlechinablog.com/uploaded_images/image002-714768.jpg
----

http://googlechinablog.com/uploaded_images/image002-714823.jpg
----
��site:������ѧ.cn �ػ͡�

http://www.google.cn/search?source=igchina&hl=zh-CN&channel=&client=&q=site:��
����ѧ.cn+�ػ�&btnG=Google+����&aq=f
----
ͼƬ
http://googlechinablog.com/uploaded_images/image003-778816.jpg
----

http://googlechinablog.com/uploaded_images/image003-778822.jpg
----
���й����������г����鱨����Ҫ��ݡ�

http://www.google.cn/search?hl=zh-CN&q=2007+���й����������г����鱨����Ҫ���
----
ͼƬ
http://googlechinablog.com/uploaded_images/image006-709786.jpg
----

http://googlechinablog.com/uploaded_images/image006-709789.jpg
----
ͼƬ
http://googlechinablog.com/uploaded_images/image008-768420.jpg
----

http://googlechinablog.com/uploaded_images/image008-768425.jpg
----
����ر���
http://video.google.cn/videosearch?q=��������%20CCTV&emb=0
----
ͼƬ
http://googlechinablog.com/uploaded_images/image010-798076.jpg
----

http://googlechinablog.com/uploaded_images/image010-798079.jpg
----
 RFC 3454: �Ʊ���ʻ��ִ���stringprep�� (2002��ʮ����) 
http://www.faqs.org/rfcs/rfc3454.html
----
 RFC 3490: ��ʻ������е�Ӧ�ã�IDNA�� (2003������) 
http://www.faqs.org/rfcs/rfc3490.html
----
 RFC 3491: Nameprep�� һ��Ϊ��ʻ���������Ƶ� Stringprep (2003������) 
http://www.faqs.org/rfcs/rfc3491.html
----
 RFC 3492: Punycode�� һ��Ϊ��ʻ�����ϵͳ��Ӧ�õ� Bootstring �� Unicode ����
 (2003������) 
http://www.faqs.org/rfcs/rfc3492.html
----
 UTR 36: ͳһ�밲ȫ���� (2008������) 
http://www.unicode.org/reports/tr36/
----
 UTR 39: ͳһ�밲ȫ���� (2006�����) 
http://www.unicode.org/reports/tr39/
----
IDNwiki
http://idn.icann.org/
----
IDN Test URLs
http://blogs.msdn.com/shawnste/archive/2006/09/14/754882.aspx

--  
Feed2News����RSS��ATOM����ת�����ݵ�����������
���ߣ� NewBlue < beyooo (at) GMail (dot) COM >
����Ա������99 < liuxing99 (at) GMail (dot) COM >
Technical Details
Message-ID: <98caf3d07c913dbb94e5b05ba5bd184f@BOT4Feed2News.CN>
Path: arc1-ca.pugleaf.net!g2news2.google.com!news4.google.com!feeder.news-service.com!feeder.news-service.com!85.214.105.209.MISMATCH!news.eternal-september.org!news.motzarella.org!motzarella.org!not-for-mail

Show Full Headers
Complete Article Headers
X-Google-Thread: 103e6a,20ff425417b19e06,start
X-Google-Attributes: gid103e6a,domainid0,public,usenet
X-Google-Language: Chinese,GB
Path: arc1-ca.pugleaf.net!g2news2.google.com!news4.google.com!feeder.news-service.com!feeder.news-service.com!85.214.105.209.MISMATCH!news.eternal-september.org!news.motzarella.org!motzarella.org!not-for-mail
From: ����99.Run-Feed2News <lx99run@BOT4Feed2News.CN>
Newsgroups: cn.comp.www,cn.finance,cn.comp.internet
Subject: ���������������������ڹȸ���ҳ�������ȸ� Chrome �е�����
Date: Sat, 08 Nov 2008 18:15:57 +0800
Organization: news.liuxing99.3322.org
Lines: 274
Message-ID: <98caf3d07c913dbb94e5b05ba5bd184f@BOT4Feed2News.CN>
Mime-Version: 1.0
Content-Type: text/plain; charset="gb2312"
Content-Transfer-Encoding: 8bit
X-Trace: news.eternal-september.org U2FsdGVkX1+R2o4tZRlSsYy2JUMNkB+mdgrLuBkiVgfuc4jlItumoYjx2CleG1peAeFYtJFdazkwaJG2GSlV/mqNcF52Bi30dgAggvt2ftHMuG/MwmK59vYDymiIYqmC0XcqjdnffS1GbdHlQyJ3EA==
X-Complaints-To: Please send complaints to abuse@motzarella.org with full headers
NNTP-Posting-Date: Sat, 8 Nov 2008 10:19:20 +0000 (UTC)
X-Original-Trace: 8 Nov 2008 18:15:57 +0800, 192.168.1.3
X-Auth-Sender: U2FsdGVkX1/H3RqyyyeVGVX5oyJ2aHVDOpw6zl8wuFf5GSqxhdT1wg==
Cancel-Lock: sha1:upWqXGkFG4hU0Aar+tEyzhP6xfI=
User-Agent: Feed2News 0.314159300,
 author: newblue < beyooo (at) GMail (dot) CoM > admin: liuxing99
X-Original-NNTP-Posting-Host: 192.168.1.3
X-Authenticated-User: feed2news
X-Posted-On: news.liuxing99.3322.org