🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: comp.archives
Article #265

[su.computers] RFC1312 on Message Send Protocol 2

#265
From: jkrey
Date: Fri, 10 Apr 1992 05:55
70 lines
3252 bytes
Archive-name: auto/su.computers/RFC1312-on-Message-Send-Protocol-2



A new Request for Comments is now available in online RFC libraries.

	RFC 1312:

        Title:      Message Send Protocol 2
       	Author:     R. Nelson & G. Arnold
	Mailbox:    nelson@crynwr.com, geoff@east.sun.com
	Pages:      8
	Characters: 18,037
	Obsoletes:  RFC 1159


The Message Send Protocol is used to send a short message to a given
user on a given terminal on a given host.  Unix's write
command offers a limited form of this service through its host-local
write command.  This service is also known on some hosts as "SEND".

As the Internet grows, more and more people are using hosts that do
not run Internet protocols at all times.  These hosts may be able
to use a simple protocol that can be implemented using UDP and IP.
The Message Send Protocol is one such protocol.

Note that a message sending protocol is already defined using TCP.
The SMTP protocol includes a "SEND" command that will direct mail
to a user's terminal.  SMTP's SEND is not useful in this instance
because SMTP's SEND is not implemented by the majority of vendors
at this time, and is difficult to use by unskilled users.  For the
purposes of standardization, we will include a TCP based Message
Send Service.

This memo defines an Experimental Protocol for the Internet community.
Discussion and suggestions for improvement are requested.  Please
refer to the current edition of the "IAB Official Protocol Standards"
for the standardization state and status of this protocol.
Distribution of this memo is unlimited.

Requests to be added to or deleted from this RFC-DIST distribution
list should be sent to RFC-REQUEST@NIC.DDN.MIL.

RFCs can be obtained via FTP from FTP.NISC.SRI.COM, NIS.NSF.NET,
NISC.JVNC.NET, VENERA.ISI.EDU, WUARCHIVE.WUSTL.EDU, SRC.DOC.IC.AC.UK,
FTP.CONCERT.NET, or NIC.DDN.MIL.

Details on obtaining RFCs via FTP or EMAIL may be obtained by sending
an EMAIL message to "rfc-info@ISI.EDU" with the message body 
"help: ways_to_get_rfcs".  For example:

	To: rfc-info@ISI.EDU
	Subject: getting rfcs

	help: ways_to_get_rfcs

Requests for special distribution should be addressed to either the
author of the RFC in question, or to NIC@NIC.DDN.MIL.  Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.

Submissions for Requests for Comments should be sent to
RFC-EDITOR@ISI.EDU.  Please consult RFC 1111, "Instructions to RFC
Authors", for further information.


Joyce K. Reynolds
USC/Information Sciences Institute

======================================================================
Technical Details
Message-ID: <s3ajkINN8gr@agate.berkeley.edu>
Path: arc1-ca.pugleaf.net!sparky!uunet!elroy.jpl.nasa.gov!ames!agate!ISI.EDU!jkrey
References: <9204091741.AA02239@akamai.isi.edu>

Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!sparky!uunet!elroy.jpl.nasa.gov!ames!agate!ISI.EDU!jkrey
From: jkrey@ISI.EDU
Newsgroups: comp.archives
Subject: [su.computers] RFC1312 on Message Send Protocol 2
Followup-To: su.computers
Date: 10 Apr 1992 05:55:00 GMT
Organization: Stanford University, California, USA
Lines: 71
Approved: adam@soda.berkeley.edu
Distribution: world
Message-ID: <s3ajkINN8gr@agate.berkeley.edu>
References: <9204091741.AA02239@akamai.isi.edu>
NNTP-Posting-Host: soda.berkeley.edu
X-Original-Newsgroups: su.computers
X-Original-Date: Thu, 9 Apr 1992 17:41:04 GMT