Article View: comp.client-server
Article #169Sun RPC time-out question
From: Guido van Rossum
Date: Sat, 19 Dec 1992 11:29
Date: Sat, 19 Dec 1992 11:29
24 lines
1397 bytes
1397 bytes
Is there an expert on Sun RPC in this group? I am in the process of re-implementing Sun RPC. All the documentation I have are RFC1014 (XDR) and RFC1057 (RPC), and RFC1094 (NFS). I have a question that isn't answered by these documents: When using the UDP version, how does the client recover from lost packets? When the call packet is lost, a simple retransmission is enough, however, when a reply packet is lost, a retransmission can cause the request to be executed twice. How does e.g. an NFS client handle this if the request is not idempotent (like RENAME)? Is there a way for the client to tell from the failing reply from the second try that the first try must have succeeded even though the response got lost? Note that I need to know how the existing Sun RPC implementation handles this situation, not how it could be done in a hypothetical system (I know all about Amoeba's RPC, for instance). Pointers to sources or documents are welcome! --Guido van Rossum, CWI, Amsterdam <guido@cwi.nl> "That was never five minutes just now!" "I'm afraid it was."
Technical Details
Message-ID:
<8411@charon.cwi.nl>Path:
arc1-ca.pugleaf.net!sparky!uunet!mcsun!sun4nl!cwi.nl!guidoShow Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!sparky!uunet!mcsun!sun4nl!cwi.nl!guido From: guido@cwi.nl (Guido van Rossum) Newsgroups: comp.client-server,comp.sys.sun.misc Subject: Sun RPC time-out question Message-ID: <8411@charon.cwi.nl> Date: 19 Dec 92 11:29:21 GMT Sender: news@cwi.nl Followup-To: comp.client-server Lines: 24