Article View: comp.dcom.modems.cable
Article #434Re: cable guy "vapor"-izes DSL 3X cable TV troll!
From: John Navas
Date: Sat, 03 Feb 2001 21:37
Date: Sat, 03 Feb 2001 21:37
52 lines
3661 bytes
3661 bytes
[POSTED TO comp.dcom.modems.cable; PLEASE REPLY THERE]
In <3A7C6810.E737A367@home.com>, James Knott
<the.lights.are.on.but.no.one.is@home.com> wrote:
>Here's what it says in "Internetworking with TCP/IP vol 1,
>Douglas Commer (1991). pg 176.
>
>"Technically, the number of packets that can be
>unacknowledged at any given time is constrained by the
>window size and is limited to a small fixed number. For
>example, in a sliding widnow protocol with a window size 8,
>the sender is permitted to transmit 8 packets before it
>receives an acknowledgement.
Yikes! In TCP/IP, the Receive Window is always a matter of bytes
(octets in RFCspeak), not packets. See RFC 793 "Transmission Control
Protocol" (TCP):
Flow Control:
TCP provides a means for the receiver to govern the amount of data
sent by the sender. This is achieved by returning a "window" with
every ACK indicating a range of acceptable sequence numbers beyond
the last segment successfully received. The window indicates an
allowed number of octets that the sender may transmit before
receiving further permission.
...
To govern the flow of data between TCPs, a flow control mechanism is
employed. The receiving TCP reports a "window" to the sending TCP.
This window specifies the number of octets, starting with the
acknowledgment number, that the receiving TCP is currently prepared to
receive.
Note that the current window size in bytes/octets is reported on every
ACK.
See also RFC 1323 "TCP Extensions for High Performance"
p.s. To de-spam an email address, use ".invalid" as the TLD (top level
domain) rather than ".com"/".net"/".org" (or any other potentially valid
TLD) in order to avoid unauthorized use of a valid domain and to
minimize unnecessary load on Internet infrastructure. Examples:
"userid@myisp.invalid" or "no@spam.invalid" (Reference: RFC 2606)
--
Best regards,
John Navas <http://navasgrp.home.att.net/>
CABLE MODEM/DSL GUIDE: <http://Cable-DSL.home.att.net/>
Technical Details
Message-ID:
<xS_e6.225$Tf1.9507@typhoon.sonic.net>Path:
arc1-ca.pugleaf.net!supernews.google.com!sn-xit-02!supernews.com!nntp-relay.ihug.net!ihug.co.nz!news-spur1.maxwell.syr.edu!news.maxwell.syr.edu!newsfeed.skycache.com!Cidera!typhoon.sonic.net!not-for-mailReferences:
<3A76B6CA.73B36B26@mynetwatchman.com> <4OGd6.100$mW6.5202@typhoon.sonic.net> <3A776B57.C495242C@mynetwatchman.com> <R3Ld6.144$mW6.6010@typhoon.sonic.net> <3A782325.2538A5E2@mynetwatchman.com> <diEe6.142$Tf1.5347@typhoon.sonic.net> <3A7B357B.3C2C1C79@ufl.edu> <S4Ke6.163$Tf1.6485@typhoon.sonic.net> <3A7B76D4.AA1FFC9F@ufl.edu> <3A7C0C9E.446C8023@home.com> <3A7C1319.D83BA77B@ufl.edu> <3A7C171F.215BC33C@mynetwatchman.com> <3A7C39C0.AC977793@ufl.edu> <3A7C6810.E737A367@home.com>Show Full Headers
Complete Article Headers
X-Google-Language: ENGLISH,ASCII-7-bit X-Google-Thread: 1122a6,2145df83169cbbc6 X-Google-Attributes: gid1122a6,public X-Google-Thread: 113850,916316de6f72ceb X-Google-Attributes: gid113850,public X-Google-ArrivalTime: 2001-02-03 13:37:34 PST Path: arc1-ca.pugleaf.net!supernews.google.com!sn-xit-02!supernews.com!nntp-relay.ihug.net!ihug.co.nz!news-spur1.maxwell.syr.edu!news.maxwell.syr.edu!newsfeed.skycache.com!Cidera!typhoon.sonic.net!not-for-mail From: John Navas <spamfilter@navasgrp.dublin.ca.us> Newsgroups: comp.dcom.modems.cable,bellsouth.net.support.adsl Subject: Re: cable guy "vapor"-izes DSL 3X cable TV troll! Organization: The Navas Group, Dublin, CA, USA References: <3A76B6CA.73B36B26@mynetwatchman.com> <4OGd6.100$mW6.5202@typhoon.sonic.net> <3A776B57.C495242C@mynetwatchman.com> <R3Ld6.144$mW6.6010@typhoon.sonic.net> <3A782325.2538A5E2@mynetwatchman.com> <diEe6.142$Tf1.5347@typhoon.sonic.net> <3A7B357B.3C2C1C79@ufl.edu> <S4Ke6.163$Tf1.6485@typhoon.sonic.net> <3A7B76D4.AA1FFC9F@ufl.edu> <3A7C0C9E.446C8023@home.com> <3A7C1319.D83BA77B@ufl.edu> <3A7C171F.215BC33C@mynetwatchman.com> <3A7C39C0.AC977793@ufl.edu> <3A7C6810.E737A367@home.com> X-Newsreader: Forte Agent 1.8/32.548 MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Transfer-Encoding: 7bit Lines: 52 Message-ID: <xS_e6.225$Tf1.9507@typhoon.sonic.net> Date: Sat, 03 Feb 2001 21:37:33 GMT NNTP-Posting-Host: 209.204.185.87 X-Complaints-To: abuse@sonic.net X-Trace: typhoon.sonic.net 981236253 209.204.185.87 (Sat, 03 Feb 2001 13:37:33 PST) NNTP-Posting-Date: Sat, 03 Feb 2001 13:37:33 PST