🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: comp.mail.mime
Article #129

comp.mail.mime frequently asked questions list (FAQ) (2/3)

#129
From: MIME FAQ maintainer
Date: Sun, 09 Oct 1994 21:40
1605 lines
59550 bytes
Archive-Name: mail/mime-faq/part2
Version: $Id: mime2,v 3.9 1994/10/09 21:35:40 jsweet Rel $
Posting-Frequency: monthly


--
==========================================================
comp.mail.mime frequently asked questions list (FAQ) (2/3)
==========================================================
Part 2: MIME products
~~~~~~
--

Overview
--------
This is part 2 of a Frequently Asked Questions document about MIME, the
multipurpose and multi-media standard for Internet mail.

Part 1 covers frequently asked questions.

Part 2 is a listing of MIME products.

Part 3 covers advanced topics.
--

7) Freely available MIME software packages
------------------------------------------

This section lists MIME-capable or MIME-enabling libraries, conversion
tools, extension packages, mail user agents, and mail transport
systems.

Tools that are explicitly designed for handling MIME in USENET news
are discussed in section 9, although many of the packages in this
section also deal with USENET news.

--------------------------------

7.1) Libraries

Name:     c-client
Product:  MUA library code
Platform: Unix, Macintosh, MS-DOS, TOPS-20
Where:
Author:   Mark Crispin
Comments:

    [ comp.mail.misc FAQ ]

    Software writers only:

    c-client is a general library useful for creating MUA's.  It
    provides a Application Program Interface for retrieving and
    manipulating mail messages.  It supports the latest draft of
    MIME.  It is driver based, and easily ported to new platforms and
    MTAs.  The currently supported platforms include various versions
    of BSD and SysV Unix, MS-DOS, Macintosh and even TOPS-20(!).  It
    supports mailboxes in /usr/spool/mail, mbox, mail.txt, mh, carmel
    format, as well as remote mailbox access via the IMAP2 protocol
    described in RFC 1176 and extended by the IMAP2bis extensions.

    c-client does not contain any user interface.  Rather, it contains
    everything else that goes into an MUA.  c-client is called with
    such functions as mail_open(), mail_fetchheader(), mail_setflag(),
    etc.

    Just the thing if you want to write a new MUA.

    Contact the author (Mark Crispin <mrc@panda.com>) for more details.


Name:     mimelite
Product:  library
Platform: ANSI C
Where:    ftp://oslonett.no/Software/MsDos/Kommunikasjon/Offline/mimelt20.zip
Author:   Gisle Hannemyr <gisle@oslonett.no>
Comments:

    [ Gisle Hannemyr <gisle@oslonett.no> 20-May-1994 ]

    "mimelite" is a simple, lightweight library written in ANSI C that
    supports the parsing of MIME headers and encoding/decoding of body
    parts, suitable for inclusion in offline-readers.

    If you develop mail and newsreader software (user agents), you
    can link mimelite with your own program to make it support a
    significant subset of MIME (namely the Content-Transfer-Encodings
    7BIT, 8BIT, BASE64 and QUOTED-PRINTABLE).  mimelite also supports
    conversion between the ISO Latin 1 character set used for European
    character sets on USENET/Internet and PC-based character sets
    (e.g. Macintosh, IBM CP-437 and CP-850).

    The distribution archive also contains UNMIME, a standalone program
    to decode MIMEd messages encoded with BASE64 or QUOTED-PRINTABLE
    encoding.

    The mimelite library is general enough to work in a number of
    contexts, but it has been designed to work well on MS-DOS (where
    memory is a scarce resource).  Its main application is intended to
    help extend MS-DOS-based "offline-readers" for RFC-822 and RFC-1036
    conformant messages to also support RFC-1521 and RFC-1522.

--------------------------------

7.2) Conversion tools and extension packages

Name:     emil
Product:  tool
Platform: Unix
Where:    ftp://ftp.uu.se/pub/unix/networking/mail/emil/
Where:    ftp://ftp.sunet.se/pub/unix/mail/emil/
Author:   Martin Wendel <martin@alba.udac.uu.se>
Comments:

    [ Martin Wendel <martin@alba.udac.uu.se> 8-Apr-1994 ]

    Emil is a tool for converting between message formats used by
    MIME, Eudora, SUN mailtool, PC and Mac based clients, etc. It is
    easily extensible.  It can work either standalone, as an argument
    driven filter program, or, if linked with sendmail-5.67b+IDA-1.5
    or sendmail-8.6.8, as a mail gateway convertering messages sent
    between various types of Internet mail clients.  It will give
    a possibility to convert encoding formats of attachments and
    convert character sets of text.  It can make a heterogenous mail
    environment, consisting of various types of mail clients, act as
    a homogenous environment; for instance sending only MIME based
    messages to the outside world.


Name:     encdec
Product:  tool
Platform: ISO C
Where:    ftp://ftp.efd.lth.se/pub/mail/encdec.c.gz
Author:   Joergen Haegg <jh@efd.lth.se>
Comments: 

encdec is a simple standalone encoder/decoder for base64 and quoted
printable written in ISO C.


Name:     exmh
Product:  MUA
Platform: UNIX
Where:    ftp://parcftp.xerox.com/pub/exmh/exmh-1.4.1.tar.Z
Where:    ftp://harbor.ecn.purdue.edu/pub/tcl/code/exmh-1.4.1.tar.gz
Author:
Contact:  "Brent Welch" <welch@parc.xerox.com>
Comments: 

    [ "Larry W. Virden" <lwv26@cas.org> 13-Aug-1994 ]

    A Tk based UI to MH.  Supports nested folders, MIME/metamail.


Name:     metamail
Product:  MUA and tools
Platform: Unix Amiga MS-DOS
Where:    ftp://thumper.bellcore.com/pub/nsb/mm2.7.tar.Z
          The metamail distribution that Nathaniel Borenstein supports.
Where:    ftp://thumper.bellcore.com/pub/nsb/contrib2.7.tar.Z
          Contributed sources.
Where:    ftp://thumper.bellcore.com/pub/nsb/mm2.7.dos.zip
          MS-DOS binaries
Author:   Nathaniel Borenstein
Comments:

    [ Paul Eggert <eggert@bi.twinsun.com> ]

    Metamail is a software implementation of MIME, designed for easy
    integration with traditional mail-reading interfaces -- typically,
    users do not invoke metamail directly.  Ideally, extending the
    local e-mail or news system to handle a new media format is a
    simple matter of adding a line to a mailcap file.  Mailcap files
    are described in RFC 1343.


Name:	  MHonArc
Product:  HTML conversion tool
Platform: Unix
Where:    ftp://ftp.ics.uci.edu:/pub/dtd2html/MHonArc1.0.0.tar.gz
Author:   Earl Hood <ehood@convex.com>

    [ Earl Hood <ehood@convex.com> 2-Oct-1994 ]

    MHonArc is a Perl program for converting e-mail messages as specified
    in RFC 822 and RFC 1521 (MIME) to HTML. MHonArc can perform the
    following tasks:
    
      * Convert mh(1) mail folders or mail(1) style mailboxes into an HTML
	mail archive.
      * Add new e-mail messages to an existing HTML mail archive generated
	by MHonArc.
      * Convert a single message to HTML.
	
    An index page is created when an archive is generated. MHonArc allows
    complete customization over the appearance of the index page including
    the ability to insert user defined HTML markup and content-type
    sensitive icons for the mail messages processed.

For details refer to http://www.oac.uci.edu/indiv/ehood/mhonarc.doc.html
The x-types handled by MHonArc are listed in section 3 of this FAQ.


Name:     MIME for VM/CMS
Product:
Platform: VM/CMS
Where:    gopher://ricevm1.rice.edu
Author:
Comments:

    [ Rick Troth <TROTH@ricevm1.rice.edu> 21-Jul-1993 ]

    This MIME decoder is available via Gopher from ricevm1.rice.edu
    under "Other freely distributable CMS software", which is under
    "CMS Gopher Software".

    It correctly reads:

        o text/plain,
        o text/richtext, and
        o image/gif.

    GIFs require the VMGIF package from Belgium.  I need filters for
    PBM and PGM and then they'd work too.  Sounds are not useful on
    the standard 3270 terminal (dumb terminals just don't play sounds).

    It splits out multipart/[anything] into separate files.  CMS has a
    standard directory "browser" (FILELIST) that lets you view a bunch
    of related files and decide what, if anything, you want to do with
    them.

    Message/external-body doesn't work well, but probably will given
    more development time.  I could use some samples to help with the
    debugging of that part.

    It does NOT do applications, except for the one, octet-stream.
    (which is treated as a kind-of "sendfile" utility) There *is* a
    PostScript interpreter for CMS, but it is reported to be a dog (we
    don't have it).  But I do hope to put the extraction code in for
    these eventually.

    If a given content-type isn't understood, you just view the item
    as-is.

    For composition, there's no CHARSET= parameter on the
    Content-Type: text/plain line.  It's EBCDIC until it gets into
    SMTP, then it's ASCII, then it might be anything, so I've left off
    the CHARSET= parameter.

    An "attach" command is added to RiceMAIL when you run this, which
    would then change the message from text/plain to multipart/mixed
    and append the attachment after a boundary.  Attachments don't
    "close" properly; that is, the final boundary isn't correct, but is
    correctly processed by all of the MIME compliant readers I've
    checked.  (there's some feature of RiceMAIL that causes this)

    This thing is based on CMS Pipelines, so adding features is easy
    since we now have the base for MIME processing.


Name:     MIME tools for GNU Emacs
Product:  MUA
Platform: Unix
Where:    ftp://wnoc-fuk.wide.ad.jp/pub/GNU/etc/emacs-mime-tools.shar
Author:   Masanobu UMEDA
Comments:

    [ Masanobu UMEDA <umerin@mse.kyutech.ac.jp> 07-Aug-1993 ]

    MIME tools that consist of "mime.el", "rmailmime.el" and
    "metamail.el" are tools for reading and composition of MIME
    messages for GNU Emacs and its variants.  "mime.el" is a simple
    MIME message composer that works with mail mode, news mode, and
    mhe letter mode.  Messages of plain and richtext text, audio, and
    image, and multipart messages of them can be composed by using
    "mime.el".  "rmailmime.el" is for reading MIME messages within
    Rmail.  "metamail.el" is an interface to metamail.  The metamail
    package is required by these tools.


Name:     MIME tools for NeXT
Product:  editor
Platform: NeXT
Where:
Author:   Dave Lacey
Comments:

    [ Dave Lacey <dave@blackbox.isca.uiowa.edu> ]

    I'd like to keep you apprised of some MIME work I'm doing.  I'm
    interested in using MIME as a transport medium for multi-media
    gopher documents.  My particular use is for Radiology info, but it
    would work for just about anything.

    I've got a NeXT Gopher client almost working and I also have a
    NeXT based MIME file editor that reads/creates MIME documents.
    Both work, but need a bit more extension.  I will likely
    distribute the source to this, so the MIME reader (which is
    essentially an object) can be re-used in other apps.


Name:     mpack
Product:  MUA/utility
Platform: Unix, MS-DOS, Macintosh, Amiga
Where:    ftp://ftp.andrew.cmu.edu/pub/mpack/mpack-1.4-src.tar.Z
          Sources for all versions
Where:    ftp://ftp.andrew.cmu.edu/pub/mpack/mpack-1.4-pc.zip
          MS-DOS binaries
Where:    ftp://ftp.andrew.cmu.edu/pub/mpack/mpack-1.4-mac.hqx
          Macintosh binary
Where:    ftp://ftp.andrew.cmu.edu/pub/mpack/mpack-1.4-amiga.lha
          Amiga binaries
Author:   John Gardiner Myers, Chris Newman (Mac), Mike Meyer (Amiga)
Comments:

    [ John Gardiner Myers <jgm+@CMU.EDU> 1-Jun-1994 ]

    Mpack is a minimal implementation of MIME, designed for encoding and
    decoding binary files in MIME messages.  In short, it is the MIME
    equivalent of uuencode and uudecode.  For backwards compatibility,
    it can also decode messages in split-uuencoded format.  The Macintosh
    port can also handle AppleSingle, AppleDouble, and BinHex.


Name:     n2m
Product:  conversion tool
Platform: NeXT
Where:    ftp://nexus.yorku.ca/pub/n2m.shar
Author:   
Comments:

    [ Dave Collier-Brown <davecb@ccs.yorku.ca> 04-Jan-1993 ]

    Nn2m is a program that converts a file containing a NeXT-format
    multimedia message into a file containing a MIME-format multimedia
    message.

    It is usable on Berkeley-derived systems, or ones otherwise using
    /usr/lib/sendmail as a mail transfer agent. It is in use on SunOS
    4.1.1 and Ultrix 4.2, tested briefly on Aix 3.2 and NeXT.

    Description: it is used with non-NeXT mail user agents to convert
    NeXT mail to MIME, which is intelligible to more than just the NeXT
    mail program.  The resulting file will usually be more intelligible
    to non-multimedia mail user agents.

    The textual part of the mail is converted into text, as well as
    Microsoft RTF, and the attachments follow, as text/plain wherever
    possible, as base64 encoded binaries otherwise.  This suffices for
    messages with ASCII files pasted into them.

    Caveat:  This is a converter, not a translator: the conversion of
    sound and of the initial "index.rft" file is not correctness-
    preserving.


Name:     Safe-TCL (Enabled Mail)
Product:  extension package
Platform: UNIX
Where:    ftp://ftp.ics.uci.edu/mrose/safe-tcl/safe-tcl.tar.Z
Where:	  ftp://ftp.ics.uci.edu/mrose/safe-tcl/safe-tcl-contrib.tar.Z
Author:   Marshall T. Rose
Contact:  safe-tcl-request@uunet.uu.net
Comments:

    [ "Larry W. Virden" <lwv26@cas.org> 13-Aug-1994 ]

    Incoming email processing tool based on Tcl.  Software also available
    which can build MIME messages and send them.  Incoming email
    processing includes ability to execute encapsulated Tcl programs at
    delivery or upon viewing.

    [ Jerry Sweet <jsweet@irvine.com> 5-Sep-1994 ]

    Papers about Enabled Mail and Safe-TCL are available from these
    sources:

    ftp://thumper.bellcore.com/pub/nsb/st/em-model.txt
    ftp://thumper.bellcore.com/pub/nsb/st/safe-tcl.ps
    ftp://thumper.bellcore.com/pub/nsb/st/safe-tcl.txt


Name:     sun-to-mime
Product:  conversion tool
Platform: OpenWindows
Where:    ftp://cs.utk.edu/pub/MIME/sun-to-mime.perl
Where:    ftp://cs.utk.edu/pub/MIME/sun-to-mime.c
Author:   Keith Moore
Comments:

    [ Keith Moore <moore@cs.utk.edu> 27-Dec-1992 ]

    A perl script (and conversion to C of same) that converts
    OpenWindows mail to MIME.  Body parts currently supported are:
    text, gif, Sun rasterfile (converted to image/gif), postscript, and
    audio.  Other types default to application/octet-stream.  It's easy
    to extend the set of types supported and to add conversions, if
    necessary.

    The script requires uuencode, uudecode, zcat (aka uncompress),
    and the "convert" program from ImageMagick.  If you don't have
    ImageMagick you can probably substitute the pbm stuff with little
    fuss.


Name:     uu-to-mime
Product:  conversion tool
Platform: perl
Where:    ftp://cs.utk.edu/pub/MIME/uu-to-mime.perl
Author:   Keith Moore <moore@cs.utk.edu>
Comments: 

A perl script that translates an RFC 822 message containing a single
uuencoded file to a MIME message containing a base64-encoded file.

--------------------------------

7.3) Mail user agents and transport systems

Name:     Andrew
Product:  Multimedia system
Platform: Unix
Where:
Author:
Comments:

    [ Susan Straub <susan+@andrew.cmu.edu> 11-Jan-1993 ]

    Andrew is a very large and ambitious software system developed at
    Carnegie Mellon University.  It is installed at hundreds of sites
    throughout the world, and includes a multimedia document editor,
    help system, and various other utilities.  In particular, it
    includes a feature-rich program, "messages", which can read and
    send mail and news articles in MIME format, including images,
    audio, richtext, and more.  Andrew is available in binary release
    for several Unix system architectures, and also in source form.
    Be warned that the source distribution is itself about 50
    megabytes, but you really are getting a LOT of stuff.  For
    information on how to obtain a copy of Andrew, send mail to
    info-andrew-request@andrew.cmu.edu.


Name:     elm
Product:  MUA
Platform: Unix
Where:
Author:
Comments:

    [ Syd Weinstein <syd@dsinc.dsi.com> 21-Dec-1992 ]

    Elm support for MIME:
    2.3 - uses metamail supplied patch from Nathaniel Borenstein. 

    2.4:
        reading: detects MIME headers and calls metamail automatically
        if the message cannot be displayed on the current screen using
        the native capabilities of the display (recognizes some char
        sets as native)

        sending: detects [include ] markers and makes them MIME attachments.
        Still very 'crude', but its all we had time for, as to the
        release deadline of 'Elm' and MIME.

    3.x:
        reading: probably no change from 2.x, but will understand
        some 'file storage' types and allow for splitting off attachments
        on their own.

        sending: will allow defining attachments to be added and auto build
        the MIME stuff, in addition to the [include ] syntax.

    release status:
    2.3: obsolete
    2.4: Current PL is 23.
    3.x: not planned until some time in 1994.


Name:     Eudora 1.4.2
Product:  MUA
Platform: Macintosh MS-Windows
Where:    ftp://ftp.qualcomm.com/quest/eudora/windows/1.4/eudor142.exe
Where:	  ftp://ftp.qualcomm.com/quest/eudora/mac/1.4/eudora142.hqx
Where:    ftp://src.doc.ic.ac.uk/computing/systems/ibmpc/windows3/winsock/eudora14.exe
Author:   Steve Dorner <sdorner@qualcomm.com>
Author:   Jeff Beckley <beckley@qualcomm.com> (Windows Version)
Comments:

Eudora 1.4 is a MUA for Macs and PCs that uses POP3 and SMTP and
supports MIME.  A commercial version is also available: see the next
section.


Name:     HUyMail
Product:  MTA/MUA
Platform: VMS
Where:    ftp://ftp.technion.ac.il/pub/unsupported/vms/local/local/huymail*.bck
Author:   Yehavi Bourvine
Comments:

    [ Yehavi Bourvine <YEHAVI@vms.huji.ac.il> 22-Jul-1993 ] 

    HUyMailer is a store and forward mailer for VAX/VMS and AXP/VMS
    systems which supports as transports: DECnet, Multinet/TcpIp,
    HUJI-NJE and PMDF.  The software is available freely for
    non-commercial use as a C source code.

    The mailer supports two users' interfaces: VMS/MAIL (to which the
    connection is done via MAIL11 DECnet connection) or a locally
    written interface called BMAIL.  BMAIL is a menu oriented interface
    which supports MIME and Hebrew.


Name:     Iride
Product:  MUA
Platform: Macintosh
Where:    ftp://gnbts.univ.trieste.it/mime/Iride.sea.hqx
Author:   GNBTS
Comments:

    [ From the README ]

    Iride is (or will be -- it's currently in beta test) an
    implementation of a MIME user agent on the Apple Macintosh
    computer.  It was developed as part of a project of the GNBTS -
    Gruppo Nazionale Bioingegneria sezione di Trieste, for the
    integration of multimedia mail with hospital data storing
    facilities, in particular for the transfer of bioimages.
    
    This is a far from a complete MIME implementation, but I think 
    it is quite usable.

    To use it you need:
        o Macintosh with MacTCP 1.1 or better installed
        o 32 bit ColorQuickDraw if you want to use images
        o audio input device if you want to create audio messages
        o connection to a SMTP mail relay
        o connection to a POP3 server
    
    MIME types supported:
    
    text/plain              charset=US-ASCII only
    text/richtext           (no tool for composing richtext yet)
    
    audio/basic
    audio/X-macaudio        generated when a NOT sampled audio pasted in
    
    image/GIF
    image/X-macPICT         generated when color QuickDraw is missing only
    
    multipart/mixed         each part is shown in a different window
                            MUST change this
    multipart/parallel     
    multipart/alternative   handled as multipart/mixed
                            MUST change this

Name:     mercurius
Product:  MUA
Platform:
Where:    ftp://ftp.lii.unitn.it/pub/mercurius/mercurius.tar.Z
Author: 
Contact:  mercurius-bugs@lii.unitn.it
Comments:

    [ "Larry W. Virden" <lwv26@cas.org> 13-Aug-1994 ]

    Mercurius facilitates composing and reading multimedia electronic
    messages compliant with the Multipurpose Internet Mail Extensions
    (MIME).


Name:		MEUF [Mail Extended Using Faces]
Product:	MUA
Platform:	Unix/X
Where:	        ftp://ftp.inria.fr
Where:		ftp://ftp.enst.fr
Contact:	Daniel.Glazman@der.edf.fr
Author:		Daniel Glazman
Comments:

    [ Daniel Glazman <glazman@cli51ak.der.edf.fr> 23-Sep-1994 ]

    Meuf is a student project I developed at Ecole Nationale
    Superieure des Telecommunications de Paris with the System
    staff. It has grown A LOT to become a MIME-native MUA running
    under Xt/Xaw.

    Earlier non-MIME versions (1.3 and 1.4) are available by anonymous
    ftp from ftp.inria.fr and ftp.enst.fr.

    Currently developed version 3.0 will be released as a freely
    available product as soon as I'll get the authorization. Code has
    features:

    Pure MUA features:
    	* Faces (48x48 XBM bitmaps) display using the X-Faces
    	  header field and included logos distribution
    	* does not rely on "faces" package
    	* folders (also with Faces display)
    	* waste basket
    	* messages sort by date, subject, length, ...
    	* unlimited aliases
    	* .face, .signature, .prologue, /usr/games/fortune handling
    	* automagically deleted messages
    	* References, Priority, Bcc, Return-Receipt-To handling
    	* "Trusted Users" features
    	* ignored header fields
    	* online help
    	* drag and drop for messages/folders management
    	* interactive Face design
    	* "Properties" windows

    MIME features:		
    	* does not rely on "metamail" package
    	* full MIME composition and restitution for non-textual
    	  parts and text/plain
    	* multiparts composition and restitution
    	* basic text/richtext and text/enriched restitution
    	* mailcap mechanism
    	* Sun-Attachments parsing
    	* MIME incorporation
    	* MIME-clipboard (copy/paste of MIME parts between messages)
    	* extraction of forwarded MIME-messages for MIME restitution
    	* User's Guide (PS), Admin. Guide (PS)

    Successfully compiled and used with:
    	Sun		SunOs 4.1.x and Solaris 2.x
    	HP 9000/7xx	HP-UX > 9.01
    	DECstation	Ultrix
    	IBM RS6000	AIX > 3.2.4
    	Convex

    More information at http://lara0.exp.edf.fr/glazman/meuf.html
    Availability will be announced in comp.mail.mime newsgroup.



Name:     MH 6.8
Product:  MUA
Platform: Unix
Where:    ftp://ftp.ics.uci.edu/pub/mh/mh-6.8.tar.Z
Where:    ftp://louie.udel.edu/portal/mh-6.8.tar.Z
Author:
Comments:

MIME support is available for the MH message handling system; the
primary reader and generator is the program mhn(1) although other MH
programs are also changed.  The current release of MH is 6.8, the first
to include MIME support when appropriately installed.  mhn does not
use the mailcap mechanism described in RFC 1343.

A tutorial for mhn is available:

Where:    ftp://ftp.ics.uci.edu/mh/contrib/multimedia/mhn-tutorial.tex
	  ftp://ftp.ics.uci.edu/mh/contrib/multimedia/mhn-tutorial.sty
	  ftp://ftp.ics.uci.edu/mh/contrib/multimedia/mhn-tutorial.ps

See the newsgroup comp.mail.mh for further information.


Name:     MIXMH
Product:  MUA
Platform: Unix with X
Where:    ftp://aun.uninett.no/pub/mail/mixmh/mixmh-0.3.tar.Z
Author:
Comments:

    [ Harald Tveit Alvestrand <Harald.Alvestrand@delab.sintef.no> 10-Dec-1992 ]

    This version is based on XMH version 1.6 from SEI, Carnegie Mellon.
    It supports sending MIME with extended character sets in the headers
    (per RFC 1342) and the body (per RFC 1341 text/plain).  It has
    limited support for multipart messages.

    The source is freely redistributable and modifiable.

    As you can see from the version number, it is still not considered
    fully stable. Bugs may be reported to mixmh-bugs@uninett.no
    Information and discussion will take place on mixmh-info@uninett.no;
    mail to mixmh-info-request@uninett.no to join.


Name:     Pegasus mail
Product:  MUA
Platform: MS-DOS, MS-Windows, Macintosh
Where:    ftp://risc.ua.edu/pub/network/pegasus/*
Author:   David Harris <david@pmail.gen.nz>
Comments:

    [ James Ford <JFORD@ua1vm.ua.edu> 2-Nov-1993 ]

    Pegasus Mail is an E-Mail package for Novell network v2.15 and higher
    that supports MHS (natively) and SMTP.  The MS-DOS version (v3.01a)
    is MIME compliant; the MS-Windows version should be by mid-November.
    I do not know the timetable for the Mac version.  You can either
    get a PC-based SMTP gateway for it (Charon, by Brad Clements) or a
    (Netware v3.11) NLM-based version (Mercury, by David Harris) from
    risc.ua.edu.  I believe that the SMTP gateway Mercury supports 8-bit
    MIME encoding.


Name:     Pine
Product:  MUA
Platform: Unix
Where:    ftp://ftp.cac.washington.edu/pine/pine.tar.Z
Author:   Laurence Lundblade, Michael Seibel, Mark Crispin
Comments:

    [ From the release notes 21-Sep-1993 ]

    Pine(tm) --a Program for Internet News & E-Mail-- is a tool for
    reading, sending, and managing electronic messages.  It was designed
    specifically with novice computer users in mind, but can be tailored
    to accommodate the needs of "power users" as well.  Pine uses
    Internet message protocols (e.g. RFC-822, SMTP, MIME, IMAP, NNTP)
    and runs on Unix and MS-DOS.

    The guiding principles for Pine's user-interface were: careful
    limitation of features, one-character mnemonic commands,
    always-present command menus, immediate user feedback, and high
    tolerance for user mistakes. It is intended that Pine can be learned
    by exploration rather than reading manuals.  Feedback from the
    University of Washington community and a growing number of Internet
    sites has been encouraging.

    Pine's message composition editor, Pico, is also available as a
    separate stand-alone program.  Pico is a very simple and easy-to-use
    text editor offering paragraph justification, cut/paste, and a
    spelling checker.

    [ David L Miller <dlm@cac.washington.edu> 31-Aug-1994 ]

    For more information, see http://www.cac.washington.edu/pine/


Name:     Tkmailto
Product:  MUA
Platform: UNIX
Where:    ftp://harbor.ecn.purdue.edu/pub/tcl/code/tkmailto-1.0.tar.gz
Author: 
Contact:  "Johan Lindbladh" <tet90jl@tintin.hik.se>
Comments: 

    [ "Larry W. Virden" <lwv26@cas.org>, 13-Aug-1994 ]

    Alpha version Tk-based mail composer which supports MIME.  Requires
    Safe-Tcl 1.1.

--

8) Commercial MIME software packages
------------------------------------

Name:     Echelon
Product:  MUA
Platform: NEXTSTEP
Contact:  ak272@freenet.acsu.buffalo.edu
Author:   Doug Boyce <ak272@freenet.acsu.buffalo.edu>
Comments:

Echelon is a MUA for NEXTSTEP that can decode, display, and compose both
NeXTmail and MIME.  Most MIME types are supported.  A demo version is
available from

Where:    ftp://nova.cc.purdue.edu/pub/next/submissions/Echelon_1.12.tar.gz


Name:     ECSMail
Product:  MUA/MTA
Platform: Unix, NT, OS/2, OpenVMS, MS-DOS, MS-Windows, Mac System 7
Contact:  ECS Sales <ecs-sales@edm.isac.ca>
Phone:    +1 403 420 8081
Author:
Comments:

    [ Steve Hole <steve@edm.isac.ca> 24-Aug-1993 ]

    ECSMail is an electronic mail product for building enterprise mail
    systems.  It is designed from start to finish as a system for
    establishing mail services throughout an organization, with external
    organizations and the world information system in general.  It does
    this by using a completely standards based architecture.

    ECSMail is comprised of the following system components:

     ECSMail MUA Set      - a set of Mail User Agents (MUA) 
     ECSMail MTA Set      - a set of Message Transport Agents (MTA)
     ECSMail MS Set       - a set of Message Services (MS)

    All components support both MIME/822 and X.400, and run under
    Unix, Microsoft NT, OS/2, OpenVMS.  Additionally, the MUA Set runs
    under MS-DOS, Microsoft Windows, and Mac System 7.

    Pricing for the ECS products and ISA business information can be 
    obtained by contacting:

     ECS Sales 
     835 10040 - 104 Street
     Edmonton, Alberta, Canada
     T5J 0Z2

     Phone: 403-420-8081
     Fax:   403-420-8037

    or by sending a request through electronic mail to the address:

     ECS Sales <ecs-sales@edm.isac.ca>


Name:     Eudora 2.0.2
Product:  MUA
Platform: Macintosh
Contact:  eudora-sales@qualcomm.com
Author:   Steve Dorner <sdorner@qualcomm.com>
Author:   Jeff Beckley <beckley@qualcomm.com> (Windows Version)
Comments:

Commercial versions of Eudora with more features than the freely
available ones.

Information about the commercial versions of Eudora can be found at:

ftp://ftp.qualcomm.com:/quest/eudora/windows/Eudor2Info-*.exe
ftp://ftp.qualcomm.com:/quest/eudora/mac/Eudora2Info-*.sea.hqx


Name:     IBM multimedia mail
Product:
Platform: OS/2
Contact:  Jerry Cuomo <gcuomo@watson.ibm.com>
Author:   IBM
Comments:

    [ Larry Salomon Jr <os2man@panix.com> 10-Dec-1992 ]

    I'm not going to follow this group, but I wanted to state that IBM -
    at the T.J. Watson Research Center - is developing a multimedia mail
    application for OS/2 which is based on the Mime spec.  They demoed
    it at Interop.

    For more information, including (probably) how to become a test site
    (I haven't confirmed whether they're actually going to do this,
    but they've done it before), contact the department manager, Jerry
    Cuomo, at gcuomo@watson.ibm.com.


Name:     iGate
Product:  WordPerfect Office gateway
Platform:
Contact:  smart@actrix.gen.nz
Author:   Smart Systems
Comments:

    [ Quentin Smart <smart@acme.gen.nz> 25-Sep-1993 ]

    iGate provides seamless connectivity to SMTP mail from WordPerfect
    office.  Running as a native gateway under the Office Connection
    server and incorporting a TCP/IP stack iGate is a complete solution
    with no extras like MHS or TCP/IP stacks required.
    
    Further information from:

        Smart Systems
        PO Box 5017
        Wellington, New Zealand
        +64 6 3561484
        smart@actrix.gen.nz


Name:     Internet Exchange for cc:Mail
Product:  cc:Mail to SMTP/MIME Internet Mail Gateway
Platform: MS-Windows
Contact: 
Phone:    +1 415 871 4045
Author:   International Messaging Associates
Comments:

    [ Tim Kehres <kehres@ima.com> 08-Dec-1993 ]

    For cc:Mail users, Internet Exchange is the gateway of choice to
    provide standardized full multimedia connectivity between cc:Mail
    users and their Internet partners.  Internet Exchange for cc:Mail
    can be used to interconnect cc:Mail networks with external users on
    the Internet as well as connecting your own internal network to your
    cc:Mail community.

    Internet Exchange for cc:Mail is the first SMTP to cc:Mail gateway
    that suports the full MIME Internet standard for exchanging rich
    media multipart messages.  This means that your cc:Mail users can
    now exchange any attachment types with Internet based mail systems.
    By using the MIME standard, Internet Exchange for cc:Mail users
    will be assured future compatibility with other MIME compliant mail
    gateways.

    To simplify administration and management, the Internet Exchange
    System Manager runs under Windows 3.1.  On screen buttons provide
    administration access into the gateway operations.  Managers can
    easily view and modify all gateway activity.  Message routing is
    accomplished using any combination of host tables,Domain Name System
    (DNS) lookup, and default mail host routing.


Name:     Ishmail
Product:  MUA
Platform: SunOS, Solaris, AIX, HP-UX, and UnixWare
Contact:  info@hal.com
Phone:    +1 800 762 0253 or +1 512 834 9962
Where:    ftp://ftp.halsoft.com
Pricing:  $99 U.S. for single user. Multi-user/site license discounts.
Author:   HaL Software Systems
Comments:

    [ Frank Bieser <frankb@hal.com> 21-Jun-1994 ]

    Ishmail is a MIME-capable e-mail tool with a Motif graphical user
    interface. Ishmail includes the following features:

    - Full support of MIME data types: plain text, rich text, GIF,
      JPEG, U-LAW audio, MPEG, binary, PostScript, ODA, RFC822 mail
      message, plus user-defined extensions.

    - Message attachments supported via: local file, AFS, mail server,
      regular FTP, anonymous FTP, and TFTP.

    - Support for composing, viewing, and printing rich text messages.

    - Easily customized through GUI dialogs for fonts, definition and
      placement of custom buttons, message list sorting and format, etc.

    - Variety of user interaction methods, ranging from "drag and drop"
      and custom buttons to keyboard shortcuts.

    - Support for use of, modification, and addition of sendmail-style
      mail aliases.

    - User defined alert commands and icons, triggered by matching 
      patterns in incoming mail headers.

    - On-line help cards, including context sensitive help.

    - Full end-user manual provided in PostScript format.

    - Complete hypertext version of end-user manual available via World Wide
      Web at <http://www.hal.com/products/sw/ishmail/user-guide.html>

    HaL Software Systems
    3006 Longhorn Blvd #A-113
    Austin, TX 78758-7631


Name:     Mail*Hub
Product:
Platform: Control Data 4000 Series Mips-based Unix systems
Contact:  rrr@svl.cdc.com
Author:   Control Data Systems
Comments:

    [ <rrr@duck.svl.cdc.com> 23-Dec-1992 ]

    Mail*Hub includes support for X.400, X.500, SMTP, and creating,
    viewing, and sending MIME enclosures in mail. In addition, the Fax
    Gateway portion of Mail*Hub supports sending mail with MIME
    enclosures to a Fax machine.  Graphical MIME components
    (Postscript, GIF, TIFF,...)  are automatically recognized and
    imaged at the receiving Fax machine.


Name:		MAIL-IT 
Product:  	MUA 
Platform:	MS Windows 3.x 
Contact:	mail-it@unipalm.co.uk 
Phone:		1-800-368-0312 
		(+44) 223 250 100
Author:         Unipalm Ltd. 
Comments: 
 
    [ Maria Porto <maria@unipalm.co.uk>, 7-Jul-1994 ]

    MAIL-IT is a Winsock-compatible SMTP/POP mail client with MIME
    functionality.  By implementing Microsoft's Extended MAPI
    architecture, MAIL-IT allows mail to be sent from directly within
    MAPI-enabled applications such as Word for Windows, Excel,
    WordPerfect, Lotus 1-2-3 and Ami Pro, thus Internet-enabling the
    user's desktop.
     
    MAIL-IT benefits include: 
     
    -  support for MIME 
    -  implementation of Microsoft's MAPI architecture 
    -  full drag and drop 
    -  hierarchical foldering 
    -  uses SMTP for sending, and POP2 or POP3 for receiving mail 
    -  local address book 

    There is a 30-day demo copy available for anonymous ftp: 
    ftp://pipe.pipex.net/xtech/mail-it/mie202.zip
    Please contact us for the decrypting password.


Name:     Mail*Link SMTP for QuickMail, Microsoft Mail for AppleTalk, and
          PowerShare
Product:  Macintosh Mail systems to SMTP/MIME gateways
Platform: Macintosh
Contact:  info@starnine.com
Phone:    510-649-4949
Author:   StarNine Technologies, Inc.
Comments:

    [David Thompson <david@starnine.com> 19-Sept-1994 ]

    Mail*Link SMTP 3.0 is the industry-standard for connecting
    Macintosh mail systems to each other, as well as PC, UNIX and
    host-based mail systems on corporate LANs and the Internet.  The
    Mail*Link family of gateways now provides MIME support for all
    major Macintosh LAN messaging systems including QuickMail,
    Microsoft Mail for AppleTalk and PowerShare Collaboration servers.
    
    Per-destination processing of messages in version 3.0 allows
    gateway administrators to configure translation and enclosure
    handling methods for outgoing messages addressed to a specific
    SMTP address, domain, or host.  The gateway ships with three
    preprogrammed translation methods for sending messages to users on
    PCs, UNIX, and MIME-capable systems.
    
    Mail*Link SMTP uses the proposed MacMIME standard to allow more
    flexibility when receiving messages with MIME-encoded Macintosh
    files.  An option to encode an attachment's datafork only with
    MIME greatly increases compatibility with non-Macintosh MIME
    systems.  Other enclosure handling options include
    MacBinary-UUENCODE, AppleSingle-UUENCODE, BinHex 4.0, and
    Datafork-only-UUENCODE, and StuffIt compression.


Name:     Mail*Link Internet for PowerTalk
Product:  PowerTalk to SMTP/MIME Internet Mail Gateway
Platform: Macintosh System 7.5
Contact:  info@starnine.com
Phone:    510-649-4949
Author:   StarNine Technologies, Inc.
Comments:

    [David Thompson <david@starnine.com> 19-Sept-1994 ]

    Mail*Link Internet for PowerTalk is a personal gateway that allows
    System 7.5 users in SMTP/POP3 environments to exchange messages
    with Internet mail users.
    
    Version 1.0 supports System 7.5 and System 7 Pro Macintoshes with
    MacTCP (included) on a local area network.  It uses the standard
    Simple Mail Transfer Protocol (SMTP) and Post Office Protocol
    (POP3) for sending and reading mail within the LAN.  If the LAN is
    connected to the Internet, PowerTalk users can also exchange
    messages with external Internet users.  Version 1.5, due out in
    September, 1994 will support SLIP or PPP connections.
    
    Incoming Internet messages are placed in the PowerTalk universal
    mailbox on the desktop.  Users can send Internet messages from
    within their preferred PowerTalk-savvy application such as
    WordPerfect, ClarisWorks, or the Finder.  The gateway supports
    standard Macintosh file enclosure handling methods including
    AppleSingle-UUEncode, Datafork only-UUENCODE, MacBinary, and
    BinHex, as well as MIME.
    
    A 60-day trial version of the gateway is available on StarNine's
    anonymous FTP server (ftp://ftp.starnine.com/pub/evals/pt-inet)
    as well as on the CD-ROM version of Apple's System 7.5 product
    (look in the CD Extras folder).


Name:     MPOWER
Product:
Platform:
Contact:
Author:   HP
Comments:

    [ Harald Alvestrand <Harald.Alvestrand@delab.sintef.no> 22-Jan-1993 ]

    If anyone is interested, the new multimedia product from HP called
    MPOWER supports MIME format mail.

    You can drag and drop a picture onto the mail icon, and it will be
    sent as a MIME message.

    (Unfortunately, they forgot to quote the delimiter that had a dot in
    it, and PINE failed to parse that......well, it's a betatest.)


Name:	   NetMail/3000
Product:   SMTP/MIME compatible electronic mail system for HP3000s
Platform:  HP3000 MPE/V, HP3000 MPE/iX
Contact:   solcentr@netcom.com (Solution Centers International)
Telephone: (US) 800 Net-Mail (UK)+44 (0480) 301364 (Other) +1 916 622-0630
Fax:       (US) 916 622-0738 (UK) +44 (0480) 493109 (Other) +1 916 622-0738
Author:    3k Associates (support@3k.com)
Comments:

    [ Chris Bartram <rcb@3k.com> 3-Jun-1994 ]

    NetMail/3000 is a full featured electronic mail system for HP3000
    computer systems which was designed as an SMTP and MIME compatible
    network mail system.  NetMail/3000 provides a user interface
    compatible with "dumb" terminals, but also has hooks to identify and
    utilize features of HP terminals and PC or Mac based HP terminal
    emulator packages. Users can send messages (8-bit character sets are
    supported) and attach any number of files (host or pc based) to their
    messages (PC/Mac based files are automatically retrieved and loaded),
    and all messages (and attachments) are exported in MIME format, though
    users can specify that files be encoded via 'uuencode' or 'binhex' if
    necessary to be readable by non-MIME compatible mail systems).
    
    NetMail/3000's user interface is also unique in that Windows-based
    terminal emulator users can allow NetMail/3000 to automatically
    extract and pass any message parts (not displayable in the terminal
    emulator) directly to their PC and have the appropriate application
    launched to view the file. (NetMail/3000 interrogates the PC on
    startup to determine the file types "associated" with applications.)
    
    NetMail/3000 also includes directory synchronization capability
    (compatible with Lotus' cc:Mail ADE format), a POP2 server, a
    quote-of-the-day and daytime server, and will soon be offering a
    HP3000-based gopher server. NetMail/3000 is priced independent of cpu
    size/speed/number of users, and includes network capability in the
    base product. 3k Associates is also an HP Channel Partner.
    

Name:	   NetMail/3000 HPDesk FSC Gateway
Product:   SMTP/MIME compatible gateway for HPDesk users
Platform:  HP3000 MPE/V, HP3000 MPE/iX
Contact:   solcentr@netcom.com (Solution Centers International)
Telephone: (US) 800 Net-Mail (UK)+44 (0480) 301364 (Other) +1 916 622-0630
Fax:       (US) 916 622-0738 (UK) +44 (0480) 493109 (Other) +1 916 622-0738
Author:    3k Associates (support@3k.com)
Comments:

    [ Chris Bartram <rcb@3k.com> 3-Jun-1994 ]

    The NetMail/3000 HPDesk FSC Gateway provides a bi-directional gateway
    between HPDesk mail users and the SMTP/MIME world. Any number of
    message attachments per message are supported; incoming messages are
    broken down into files on the HP3000 for HPDesk users and appear as
    normal message attachments, outgoing attachments are encoded as
    MIME-compatible message attachments (or optionally just as UUENCODED
    binary attachments for compatibility with non-MIME compatible
    mailers).
    
    The gateway operates in real-time, is a background process on the
    HP3000 (which is interrupt driven and uses minimal system resources),
    and requires no special hardware or additional software. The product
    is priced independent of platform size or type or number of users.
    Free 45 day demos are available.


Name:     PC-MM (PC Mail Manager)
Product:  MUA
Platform: MS-Windows
Contact:  Lars_Hagberg@li.icl.se
Author:   ICL
Comments:

    [ Tomas Kullman <tomku@li.icl.se> 30-Sep-1993 ]

    PC-MM from ICL is a Mail User Agent for Windows 3.1 implemented on
    Windows Socket API and TCP/IP. PC-MM is currently working on PC-NFS
    but is designed to be network software independent (i.e. will work
    on most TCP/IP softwares supporting WinSocket API).

    PC-MM is a MIME conformant internet mailer supporting SMTP and IMAP2
    for sending and receiving. PC-MM requires a UNIX mail server (or
    similar supporting SMTP and IMAP2).
    
    PC-MM V1.0 supports a lot of nice features, such as:
         - user friendly interface
         - built-in and user-defined text editor
         - drag and drop between folders
         - local and server based folders
         - integrated address book
         - message sorting and tagging
         - "watch dog" for incoming messages
    
    PC Mail Manager is announced and volume shipping mid November 1993.

    For pricing and product packaging information please contact Lars
    Hagberg at ICL ProSystems AB; E-mail: Lars_Hagberg@li.icl.se or
    phone: + 46 (0)13 11 70 00.


Name:     PMDF
Product:  MTA
Platform: VMS
Contact:  sales@innosoft.com service@innosoft.com
Author:   Innosoft International
Comments:

The VMSNET newsgroup 'vmsnet.mail.pmdf' is available for discussion.

    [ Ned Freed <ned@innosoft.com> ]

    Send technical inquiries to service@innosoft.com. Product
    information, pricing, and literature can be obtained from
    sales@innosoft.com. The phone number is (909) 624-7907; FAX is
    (909) 621-5319. Street address is:

        Innosoft International, Inc.
        250 W. First St., Suite 240
        Claremont, CA 91711


Name:     PP
Product:  MTA
Platform: UNIX
Contact:  ic-info@isode.com (commercial version)
    
    [ "Harald T. Alvestrand" <Harald.T.Alvestrand@uninett.no> 22-Aug-94 ]

    PP is an X.400 and SMTP mailer, and a gateway between these, so
    you can communicate with "both worlds".
    
    The latest and greatest version is the ISODE Consortium release,
    IC-R1, but this is no longer free. However, it is not expensive,
    either.  The ISODE Consortium offers the source code to all
    Consortium members, and gives the right to sell products based on
    the code to commercial members.

    The PP included in Isode Consortium Release 1 (IC-R1) includes:
    
    - Conformance tested X.400/84, running over most stacks you care
      	to name
    - X.400/88
    - X.400 (84 and 88) to SMTP gateways (RFC 1327 compliant)
    - SMTP, DECNET and UUCP support
    - P3File (Retix-like) message submission and delivery
    - Routing using X.500 (experimental)
    - MIME gatewaying support (MIME-MHS/HARPOON compliant)
    - SNMP monitoring
    - X.500 and file based distribution lists
    - Fax gateway supporting Panasonic, Fujitsu and Class 2 fax modems
    

Name:     SMTPLINK 2.1
Product:
Platform:
Contact:
Author:
Comments:

    [ <support@ccmail.com> 16-Dec-1992 ]

    Because this version (2.1) is a 2-3 QTR-93 release you should be
    talking to your sales rep about the tentative features of this
    product. They can be reached at 800-448-2500.


Name:     STI Document Browser
Product:  MS-Windows 3.1 (shipping), NeXTstep/X11/VMS (in the pipeline)
Platform:
Contact:  info@sti.fi
Author:   Stream Technologies Inc
Comments:

    [ Ed Anselmo <anselmo@nic.near.net> 31-Dec-1992 ]

    Product name:   STI Document Browser
    Platforms:      

    How and where to get:
        Stream Technologies Inc.
        Valkjarventie 2
        SF-02130 Espoo
        FINLAND
        Tel: +358 0 43577340
        Fax: +358 0 43577348
        E-Mail: info@sti.fi


Name:     Super-TCP
Product:
Platform: MS-Windows
Contact:  TCP@FrontierTech.COM
Author:   Frontier Technologies
Comments:

    [ Ray C Langford <ray@isi.frontiertech.com> 28-Apr-1993 ]

    Frontier Technologies' Super-TCP for MS-Windows includes MIME
    support in their E-Mail mail system that is a part of the Super-TCP
    for Windows package.

    Super-TCP for Windows is a Windows Sockets compliant, 100% DLL
    implementation that can also operate in a TSR mode. Applications
    include: Network News Reader, Telnet, FTP Client/Server, NFS
    Client/Server, SMTP/POP2&3 MIME E-Mail, Telnet Redirector,
    Interactive Talk, and more. Options are also available for PPP,
    X.25, and OSI.

    With the MIME support in E-Mail, any type of binary file may be
    attached to your message, including Postscript files, spreadsheet
    files, database files, word processor files, graphic files, audio
    files, and digital video files.

    The packages in the Super-TCP product line that include the
    E-Mail (SMTP/POP2&3) with MIME support are:
        - Super-TCP for Windows   Version 3.0
                (Complete TCP/IP package)
        - Super-TCP/NFS for Windows   Version 3.0
                (Complete TCP/IP package with NFS client/server)
        - Super-TCP Applications for Windows   Version 3.0
                (Windows Sockets applications only)

    For further information, e-mail TCP@FrontierTech.COM or call
    +1 414 241-4555.


Name:     TCP/Connect II version 2.0
Product:  MUA, news reader
Platform: Macintosh
Contact:  sales@intercon.com
Author:   InterCon Systems Corporation
Comments:

    [ Amanda Walker <amanda@intercon.com>  6-Sep-1994 ]

    Full support for MIME in email, viewing support for MIME in news.
    Includes inline composition and display of the following MIME
    content types:

        text/plain      image/gif         video/quicktime
        text/richtext   image/jpeg        audio/basic
        text/enriched   image/x-macpict

        application/applefile
        application/x-macbinhex40

        multipart/mixed

        character sets: US-ASCII, ISO-8859-1        

    Provides drag & drop support for file enclosures, automatic
    encoding and decoding of AppleSingle/AppleDouble ("MacMIME") body
    parts, as well as BinHex & uuencode for backward compatibility.
    Runs native on Power Macintosh computers.

    For more information please contact:

        InterCon Systems Corporation
        950 Herndon Parkway
        Herndon, VA 22070  USA

        +1 703 709 5500   (voice)
        +1 703 709 5555   (fax)
        sales@intercon.com  (Internet email) 


Name:     Z-Mail
Product:  MUA
Platform: Unix
Contact:  info@z-code.com
Author:   Z-Code Software Corporation
Comments:

    [ Carlyn M. Lowery <lowery@zen.z-code.com> 29-May-1993 ]

    Z-Mail, a Unix World Magazine "Product of the Year" winner for 1991,
    is a complete electronic mail system for workstations.  Z-Mail
    provides Motif and Open Look graphical user interfaces, as well
    as two character modes.  The software has been ported to nearly
    every system that runs Unix, and it works with all standard Unix
    mail transport agents including sendmail, binmail, smail, MMDF and
    X.400 gateways.  Z-Mail can replace or coexist with standard mail
    user agents on the system, including BSD Mail, AT&T mailx, Sun Mail
    Tool, Elm, or Mush.  Most anyone can use Z-Mail "off the shelf" and
    immediately benefit from its simple interface and advanced features.
    
    Z-Mail also includes Z-Script, a powerful scripting language that
    enables users to customize and extend Z-Mail's capabilities.
    Z-Mail's multi-media capabilities allow easy integration with
    best-of-class products including spreadsheets, desk-top publishing,
    graphics, fax, voice, and video. For example, when users receive a
    spreadsheet file, Z-Mail can be configured to automatically launch
    the associated application and load the the attachment automatically
    and transparently to the user.  Z-Mail understands MIME-format
    documents and is also compatible with Sun's multimedia Mailtool.

    Mac, MS-DOS, and MS-Windows versions, as well as native MIME
    support, are planned for this summer.
    
    For more information on Z-Mail, contact:
        Z-Code Software Corp.
        4340 Redwood Hwy., Suite B-50
        San Rafael, CA 94903
        tel: (415) 499-8649
        fax: (415) 479-0448
        e-mail: info@z-code.com
    
    Also, you can anonymous-ftp a demo copy of Z-Mail from 
    ftp://ora.com/pub/z-code/zmail/2.1/
    (The file you want is named zm.XXX.tar.Z, where XXX is 
    your type of machine.)  You'll need to call us after you do so we
    can send you an activation key.

--

9) MIME and USENET news
-----------------------

9.1) Introduction

USENET articles are (by design) very similar to RFC 822 mail messages.
It is therefore reasonable to expect MIME software to be adopted for use
on USENET.

A number of the mail user agents and tools discussed in section 7 also
handle USENET news.

--------------------------------

9.2) News readers and transports with MIME support

Name:     GNUS
Product:  reader
Platform: GNU Emacs
Where:
Author:   Masanobu UMEDA
Comments:

    [ Masanobu UMEDA <umerin@mse.kyutech.ac.jp> 07-Aug-1993 ]

    GNUS is an NNTP-based newsreader for GNU Emacs.  GNUS versions
    3.14.4 and later directly support reading of articles written in
    MIME format.  It only requires the metamail package.  Compositions
    of articles written in MIME format requires "mime.el" that is a
    part of MIME tools for GNU Emacs (see section 7.2).


Name:     gnus-mime.el
Product:  reaJoe Ilacqua der
Platform: GNU Emacs
Where:    ftp://world.std.com/dist/gnus-mime.el.shar
          (also in the contrib tree of metamail)
Author:   Joe Ilacqua
Comments:

    [ Joe Ilacqua <spike@world.std.com> 24-Jun-1993 ]

    "gnus-mime.el" is an ELISP package that adds support for MIME to
    GNUS.  This is the second release: I consider it very beta, and I'm
    sure there are bugs, but it does work.  It provides support both to
    read and to post USENET articles in MIME format.  It's scarcest
    feature is support for multi-part multi-media ".signatures".

I believe that gnus-mime.el is for GNUS prior to version 3.14.4.


Name:     INN
Product:  transport
Platform:
Where:
Author:
Comments:

    [ Christopher Davis <ckd@eff.org> 03-Jun-1993 ]

    There is some minimal MIME support in the INN package.  Since INN
    is a transport system, not a newsreader, the support is for
    transferring MIME messages, not reading them.

    [ Christophe Wolfhugel <Christophe.Wolfhugel@grasp.insa-lyon.fr> 23-Jul-1993 ]

    INN's MIME support is today divided in two parts:

    1) the possibility to have nnrpd add default MIME headers to
    locally posted articles;

    2) transfer-encoding changes on transport with "innxmit", i.e. recode
    8bit to quoted-printable.


Name:     MH
Product:  reader
Platform:
Where:    See section 7 for MH's FTP sites.
Author:
Comments:

    [ John Romine <jromine@ics.uci.edu> 30-Jul-1993 ]

    If you compile MH to use NNTP, it can read news with its "bbc"
    command; MH supports MIME.


Name:	  mhunify (aka stacknews)
Product:  reader
Platform: UNIX
Where:	  ftp://ftp.ics.uci.edu/mh/contrib/multimedia/mhunify.shar.gz
Author:   Jerry Sweet <jsweet@irvine.com>
Comments:

    [ Jerry Sweet <jsweet@irvine.com> 11-Aug-1994 ]

    Mhunify is a set of perl scripts and templates that provides
    shell-level MH functionality with USENET news.  Since MH supports
    MIME, MIME-format news articles just work.  I've found that being
    able to handle news in the same way that I handle e-mail is very
    useful, although there are some tradeoffs: no kill files, no
    threads, at least for now.

    Mhunify also treats MH folders just like news groups.  If you
    subscribe to several mailing lists, and your e-mail is
    automatically delivered to separate folders, say, via procmail
    or via MMDF's .maildelivery, the mhunify package lets you progress
    automatically through your folders just as you would news groups.

    Requirements: 
          - csh or some shell with shell-level alias or procedure
            facilities;
          - perl 4.0 or later;
          - MH 6.8 or later;
          - direct file system access to the USENET news spool
            directory (typically /usr/spool/news - as a local or NFS
            mounted file system).

    Some of the goodies:

        stacknews     - read USENET news using shell-level MH.
        ncomp, nrepl, nforw
                      - compose, reply to, and forward to USENET
                              news groups (these use nwhatnow).
        nwhatnow      - post USENET articles & send e-mail from 
                              the same draft.
        consider      - creates a folder, +consider  by  default,
                              containing specified messages.
        bburst        - bursts digests into a writeable folder,
                              +consider by default.
        clearf        - clears the MH folder stack.
        mhpped        - utility composition template pre-processor.
        pscan         - scan messages from point of previous scan.
                              
        Plus man pages, templates, example configuration files, 
        other utility programs, and a Makefile to install everything.


Name:     nn
Product:  reader
Platform:
Where:
Author:
Comments:

    [ Luc Rooijakkers <lwj@cs.kun.nl> 26-Jul-1993 ]

    The current beta release of nn tags newly posted articles as
    text/plain; charset=xxx with transfer encoding 8bit if the message
    contains any 8 bit characters.

    Reading support needs further work.


Name:     SNews
Product:  reader
Platform: MS-DOS OS/2
Where:    ftp://ftp.wimsey.com/~ftp/pub/msdos/uupc/snews191.zip
          MS-DOS binaries
Where:    ftp://ftp.wimsey.com/~ftp/pub/msdos/uupc/snws191o.zip
          OS/2 binaries
Where:    ftp://ftp.wimsey.com/~ftp/pub/msdos/uupc/snws191s.zip
          Source
Author:
Comments:

    [ Daniel Fandrich <dan@fch.wimsey.bc.ca> 27-Aug-1993 ]

    Revision 1.91 of the SNews newsreader for MS-DOS systems
    fixes several bugs in version 1.90 (alpha), as well as adding
    some much-needed features, including built-in support for ISO
    8859/1/2/3/4/9 character sets (RFC 1521 and RFC 1522) and a single
    key interface to the metamail MIME decoder (or other user-specified
    program).  An additional bonus is the availability of an OS/2
    version.


Name:     strn
Product:  reader
Platform: UNIX
Where:    ftp://ftp.uu.net/networking/news/readers/trn/strn/strn092.tar.gz
Author:   Clifford A Adams <caadams@access.digex.net>
Comments:

Strn has support for reading and creating MIME articles.


Name:     trn
Product:  reader
Platform: UNIX
Where:    ftp://ftp.uu.net/networking/news/readers/trn/trn.tar.gz
Author:   Wayne Davison <davison@borland.com>
Comments:

trn 3.0 has support for reading MIME articles with metamail, and
creating them with mhn.

--
End of Part 2
*************
--
Technical Details
Message-ID: <mime-faq2_781738764@irvine.com>
Path: arc1-ca.pugleaf.net!bloom-beacon.mit.edu!hookup!yeshua.marcam.com!MathWorks.Com!news.alpha.net!mvb.saic.com!news.cerf.net!shrike.irvine.com!jsweet
References: <mime-faq1_781738764@irvine.com>

Show Full Headers
Complete Article Headers
Newsgroups: comp.mail.mime,comp.answers,news.answers
Path: arc1-ca.pugleaf.net!bloom-beacon.mit.edu!hookup!yeshua.marcam.com!MathWorks.Com!news.alpha.net!mvb.saic.com!news.cerf.net!shrike.irvine.com!jsweet
From: mime-faq@ics.uci.edu (MIME FAQ maintainer)
Subject: comp.mail.mime frequently asked questions list (FAQ) (2/3)
Content-Type: message/partial; number=2; total=3; id="<mime_781738764@irvine.com>"
References: <mime-faq1_781738764@irvine.com>
Followup-To: comp.mail.mime
Approved: news-answers-request@MIT.Edu
Originator: jsweet@fester.irvine.com
Sender: usenet@irvine.com (News Administration)
Mime-Version: 1.0
Organization: Irvine Compiler Corp., Irvine, California, USA
Date: Sun, 9 Oct 1994 21:40:11 GMT
Supersedes: <mime-faq2_778723067@irvine.com>
Message-ID: <mime-faq2_781738764@irvine.com>
Summary: This posting contains answers to some of the Frequently Asked
    Questions about MIME (Multipurpose Internet Mail Extensions).
    Please read it before posting a question to comp.mail.mime.
Content-Transfer-Encoding: 7bit
Reply-To: mime-faq@ics.uci.edu (MIME FAQ maintainer)
Lines: 1605