🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: comp.mail.mime
Article #24

Frequently asked questions about MIME

#24
From: Edward Vielmetti
Date: Wed, 16 Dec 1992 00:43
205 lines
6629 bytes
Archive-name: mime-faq

0.1 Introduction

This is a skeleton of a Frequently Asked Questions document about
MIME, the multipurpose and multi-media standard for Internet mail.  It
is intended to elicit responses and information so that it can be
filled out and turned into a "real" FAQ with frequent distribution.

0.2 Information wanted:

Anything that's missing here please add it in!  I have more or less
raided the PPP FAQ for structure, but there are large gaps as far as
content goes.  More to the point if someone else wants to take over
vigorous maintenance of the document I'd be more than pleased....


1. INDEX TO THE FAQ:

2. What is MIME?

2.1 Introduction
2.2 MIME features which may or may not be present
2.3 MIME glossary
2.4 MIME-relevant RFC's

3.  How to:
3.1 Register a new MIME type

4. Real MIME questions with answers

5. Free MIME software packages.

5.1 free MIME FOR SunOS 4.1.x:
5.2 free MIME FOR BSD
5.3 free MIME for SYSVR4:
5.4 FREE MIME FOR MSDOS:
5.5 free MIME for AmigaOS:
5.6 free MIME for NeXT:
5.7 free MIME for Macintosh:

6. ftp sites for MIME stuff, docs etc.

7. Commercial MIME software packages.

8.  MIME based mail relays for commercial mail services
8.1 Large national or international providers
8.2 Regional or local providers

!9. (incomplete) Acknowledgements


2.2 MIME features that may or may not be present.

Implementations of multi-media e-mail need not support the full spec;
it's possible to have a useful product that does not explore all of
the nooks and crannies of the standard.  

Here is a list of features that someone with a good, functional
mail user agent might include for MIME support.

2.3 MIME glossary

Every subculture needs its list of buzzwords, here's a start at a
collection for MIME.

MIME	Multipurpose Internet Mail Extensions
PEM	Privacy Enhanced Mail
SMTP	Simple Mail Transport Protocol

2.4 MIME-relevant RFCs and other standards

The following RFCs are relevant to people building MIME software.  Not
all of them are standards per se, but you'd be wise to at least have
looked at all of them.

Current MIME stuff.

(please help me out here -- this should at least also include basic
RFC 822 stuff plus digest formats and all)

1341  MIME (Multipurpose Internet Mail Extensions): Mechanisms for specifying 
      and describing the format of Internet message bodies. Borenstein, N.; 
      Freed, N.  1992 June; 69 p. (Format: TXT=211117, PS=347082 bytes)
1342  Representation of non-ASCII text in Internet message headers. Moore, K.
      1992 June; 7 p. (Format: TXT=15845 bytes)
1343  User agent configuration mechanism for multimedia mail format 
      information. Borenstein, N.  1992 June; 10 p. (Format: TXT=29295, 
      PS=59978 bytes)

Older pre-MIME efforts at internet multimedia e-mail

1197  Using ODA for translating multimedia information. Sherman, M.  1990 
      December; 2 p. (Format: TXT=3620 bytes)
807   Multimedia mail meeting notes. Postel, J.B.  1982 February 9; 6 p. 
      (Format: TXT=11633 bytes)

3.  How to.

3.1 Register a new MIME datatype

(description of IANA process)

4.  Real MIME questions with answers

5. Free MIME software packages.

(mention metamail)

- MIXMH 

From: hta@boheme.er.sintef.no (Harald Tveit Alvestrand)
Newsgroups: comp.mail.mime,comp.mail.mh
Subject: MIXMH: A version of XMH that supports MIME
Date: 10 Dec 92 14:52:39 GMT
Reply-To: harald.alvestrand@delab.sintef.no

MIXMH version 0.2, a version of XMH that supports some MIME features,
is available for anonymous FTP from aun.uninett.no

Host: aun.uninett.no
Directory: pub/unix
Filename: mixmh-0.2.tar.Z

This version is based on XMH version 1.6 from SEI, Carnegie Mellon.
It supports sending MIME with extended character sets in the headers
(per RFC-1342) and the body (per RFC-1341 text/plain).
It has limited support for multipart messages.

The source is freely redistributable and modifyable.

As you can see from the version number, it is still not considered
fully stable. Bugs may be reported to mixmh-bugs@uninett.no
Information and discussion will take place on mixmh-info@uninett.no;
mail to mixmh-info-request@uninett.no to join.

-- 
                   Harald Tveit Alvestrand
Harald.Alvestrand@delab.sintef.no
C=no;PRMD=uninett;O=sintef;OU=delab;S=alvestrand;G=harald
+47 7 59 70 94

(mention pine)
(mention MHN)
(cover Amiga, other micro versions of same)
(mention Eudora et al)

6.  FTP sites for MIME information

7. Commercial MIME software packages.

List of commercial products with released or announced support for
MIME.

- IBM multimedia mail for OS/2

From: os2man@panix.com (Larry Salomon Jr.)
Date: 10 Dec 92 13:55:50 GMT
Subject: IBM Developing Multimedia Mail
Newsgroups: comp.mail.mime

I'm not going to follow this group, but I wanted to state that IBM - at
the T.J. Watson Research Center - is developing a multimedia mail application
for OS/2 which is based on the Mime spec.  The demoed it at Interop.

For more information, including (probably) how to become a test site (I
haven't confirmed whether they're actually going to do this, but they've
done it before), contact the department manager, Jerry Cuomo, at 
gcuomo@watson.ibm.com

- CCMAIL (in version x.xx, due 93)
- Innosoft PMDF (ready now?)
- Z-Code Z-Mail (ready now?)
- MIME relays for MSMAIL, etc?
- others?

8. MIME based relays for commercial e-mail services

8.1 Large national or international providers

(send mail to postmasters at each system asking?)
- America On-line?
- ATTMAIL ?
- Compuserve ?
- Dialog ?
- Genie ?
- MCI Mail?
- Radiomail ?
- Sprintmail ?

(should coordinate this with the global e-mail list that is posted to
comp.mail.misc)

8.2 Local or regional providers

(should coordinate this with e.g. the PDIAL list)

9.  Acknowlegements

This is a very quick and dirty first pass at a list, I hope that it
gets filled in with great details as time passes, but you have to
start somewhere.

  Edward Vielmetti, vice president for research, Msen Inc. emv@Msen.com
        Msen Inc., 628 Brooks, Ann Arbor MI  48103 +1 313 998 GLOB
Technical Details
Message-ID: <1glu4rINNe3g@nigel.msen.com>
Path: arc1-ca.pugleaf.net!sparky!uunet!usc!sdd.hp.com!nigel.msen.com!emv

Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!sparky!uunet!usc!sdd.hp.com!nigel.msen.com!emv
From: emv@msen.com (Edward Vielmetti)
Newsgroups: comp.mail.mime
Subject: Frequently asked questions about MIME
Date: 16 Dec 1992 00:43:57 GMT
Organization: Msen, Inc. -- Ann Arbor, Michigan
Lines: 206
Message-ID: <1glu4rINNe3g@nigel.msen.com>
NNTP-Posting-Host: garnet.msen.com
X-Newsreader: TIN [version 1.1 PL8]