Article View: comp.mail.misc
Article #1037Re: Canonical list of mail headers?
From: Steven D. Majewski
Date: Tue, 01 Sep 1992 23:56
Date: Tue, 01 Sep 1992 23:56
118 lines
3079 bytes
3079 bytes
In article <1992Sep1.180842.4553@tfs.com> paigen@tfs.com (David Paigen) writes:
>I have read through RFC 822, but there are many headers that
>I see on occasion that are not listed in that document. Is
>there a list of the "official" mail headers? Or, does anyone
>have a good list of the headers that you see more than once in
>a lifetime?
>
>Things like: Precedence, X-Mailer, etc. (Yes, I know the later
>is not 'official').
>
Well, for a start here are the "official" ones I could find in various RFC's.
Please send your submissions to comp.mail.headers.
======== "If you have a hammer, find a nail" - George Bush,'91 =========
Steven D. Majewski University of Virginia Physiology Dept.
sdm7g@Virginia.EDU Box 449 Health Sciences Center
Voice: (804)-982-0831/32 1300 Jefferson Park Avenue
FAX: (804)-982-1616 Charlottesville, VA 22908
-----------------
RFC822: Standard for ARPA Internet Text Messages:
-Minimum Required:
Date:
From:
To: or Bcc:
-destination:
To:
Resent-To:
Cc:
Resent-cc:
Bcc:
Resent-bcc:
-optional field:
Message-ID:
Resent-Message-ID:
In-Reply-To:
References:
Keywords:
Subject:
Comments:
Encrypted:
Reply-To:
-Other ( appended ):
Resent-Reply-To:
Resent-From:
Resent-Sender:
Resent-Date:
Return-path:
Received:
RFC1036: Standard for the interchange of Usenet Messages (News):
[ "Certain Headers are required, and certains other headers are optional. Any
unrecognized headers are allowed, and will be passed through unchanged."]
-Required Headers:
From:
Date:
Newsgroups: group.1[,group.2,...]
Subject:
Message-ID: <unique@full_domain_name>
Path:
-Optional Headers:
Followup-To:
Expires:
Reply-To:
Sender:
References:
Control:
Distribution:
Keywords:
Summary:
Approved:
Lines:
Xref: (local info only, don't send)
Organization:
RFC1049: A Content-type header field for Internet Messages:
defines
Content-Type: { POSTSCRIPT | SCRIBE | SGML | TROFF | DVI | X-atom }
RFC1154: Encoding Header Field for Internet Messages:
defines
Encoding:
RFC1341: MIME:Multipurpose Internet Mail Extensions
MIME-Version:
Content-Type:
Content-Transfer-Encoding:
Content-ID:
Content-Description:
---------
Are "Status:" and "Precedence:" defined somewhere ?
What are the common ( and FUNCTIONAL, i.e. not just decorative ) X-extensions: ?
Technical Details
Message-ID:
<1992Sep1.235652.17536@murdoch.acc.Virginia.EDU>Path:
arc1-ca.pugleaf.net!sparky!uunet!zaphod.mps.ohio-state.edu!darwin.sura.net!uvaarpa!murdoch!aemsun.med.Virginia.EDU!sdm7gReferences:
<1992Sep1.180842.4553@tfs.com>Show Full Headers
Complete Article Headers
Newsgroups: comp.mail.misc,comp.mail.headers Path: arc1-ca.pugleaf.net!sparky!uunet!zaphod.mps.ohio-state.edu!darwin.sura.net!uvaarpa!murdoch!aemsun.med.Virginia.EDU!sdm7g From: sdm7g@aemsun.med.Virginia.EDU (Steven D. Majewski) Subject: Re: Canonical list of mail headers? Message-ID: <1992Sep1.235652.17536@murdoch.acc.Virginia.EDU> Followup-To: comp.mail.headers Summary: For starters, all of the rfc defined ones I could find. Sender: usenet@murdoch.acc.Virginia.EDU Organization: University of Virginia References: <1992Sep1.180842.4553@tfs.com> Date: Tue, 1 Sep 1992 23:56:52 GMT Lines: 121