Article View: comp.mail.misc
Article #3814LAN Mail Protocols Summary
From: John Wobus
Date: Thu, 04 Nov 1993 13:14
Date: Thu, 04 Nov 1993 13:14
301 lines
17122 bytes
17122 bytes
Archive-name: LANs/mail-protocols Serving PCs and Workstations Using a Central Mail Server on an Internet ------- --- --- ------------ ----- - ------- ---- ------ -- -- -------- (Note: this message is prepared by John Wobus of Syracuse University, jmwobus@mailbox.syr.edu who welcomes updates and corrections; this memo has not been checked very carefully and requires a lot of correction at this time. The last update was made 11/2/93). There are advantages to collecting mail destined to PCs and workstations on a central server, to be turned over to the PC or workstation on demand: - Your PC or workstation may be down quite a bit and less network bandwidth and less of the processing resouces of the sending computer are used if the computer receiving your mail is ready. - Some people use more than one PC or workstation to read mail. - A PC or workstation may not have the resources to store all the mail you receive. - It can make your e-mail address more like other users'. The easiest way to "implement" this is to run the central mail server like any multi-user system: let people sign on to it and use some mail utility. Then PC and workstation users can use "terminal sessions" to sign on to the central mail server and read their mail. This has the disadvantage of making the PC and workstation users learn and use the central mail server's procedures. SMTP, the "internet" mail protocol used to deliver mail between multi-user systems only supports mail transfer initiated by the sender. Other protocols have been devised to allow a workstation or PC to request transfer of mail, thus able to make use of a cnetral server. These include the published protocols POP (probably not used anymore), POP2, POP3, IMAP2, IMAP3 and DMSP. POP, POP2, POP3: These are rather minimal and are designed to be so. The three are similar but not enough alike to be interoperable. They are basically designed to identify the user by username and password, to transfer the mail from server to PC or workstation and to delete the mail transferred. It is assumed that SMTP will be used to send mail. Messages can be retrieved individually, but the only information you can get about a message without transferring it is its length in bytes-- useful for PCs with limited storage. POP2 and POP3 are still used a good deal. POP3 has a couple of optional extensions: one to avoid sending passwords, and one to aid in reading bulletin boards. IMAP2, IMAP3: The IMAP family is similar to the POP family, but also gives clients a way to do string searches through mail that still resides on the server. This is designed to allow the PC or workstation to be more selective as to which mail will be transferred. The POP protocols, on the other hand, are designed for simpler server software. IMAP2 is used quite a bit. IMAP3 is an incompatible offshoot that has not been implemented much. Recent work not yet documented in an RFC has extended IMAP2 to include support for multimedia mail. DMSP (aka PCMAIL): PCs and workstations can use this protocol to both send and receive mail. The system is designed around the idea that each user can own more than one workstation; however, the system doesn't seem to handle the idea of a "public workstation" very well. The PCs and workstations are assumed to hold state information about the mail, a directory so to speak, and when the PC or workstation is connected to the server, this directory is updated to "reality". Issue of Remote Access: Modern commercial e-mail packages typically have features designed to assist in remote access of ones e-mail. Features include: -ability to download mail through a modem -ability to synchronize two different systems which you are using to read your e-mail by plugging them together. Any method of reading e-mail using PCs or Macintoshes can be used remotely via the "PCanywhere(tm)" method, e.g. by dialing up your own office PC and using one of the several kinds of software that allow you to control your PC over the phone. Also, any LAN-based method can be used by using one of the several methods of providing the same protocol support over dialup lines as are on LANs (SLIP or PPP for the above-mentioned, TCP/IP-based protocols, ARA for Appletalk-based protocols, etc, and sometimes using two different protocols, one incapsulated in the other) under the constraint that any operations that use the network will be much slower. Also, POP3 is often used directly over modems (for example, Eudora can be used in this manner). The ideal protocol for remote access would not penalize the user for the much slower communications speed (usually slower by a factor of 100: note that a lot of LAN-based software was written without regard to minimizing the necessary communication, thus is really hurt by such slow speeds), yet would allow the same software to run both remotely and locally, with a wonderful user interface. It would also not be overly expensive in communications equipment or services. This is a difficult set of objectives and the above-three protocols can achieve some of them for some users, but what they actually achieve depends a lot on the user's pattern of e-mail usage. If a user reads just a small amount of mail, then we would not worry about the length of time necessary to download it remotely with POP3, but if the person receives a lot of mail, but just wants to read a small amount of it at home, then with IMAP2, they could pick and choose what to read, eliminating some download time. If someone is paying for the telephone line time (possibly the user if it is a long distance call; in any case, the institution pays a monthly fee for each line it offers, which is dependent upon how many users it is serving, how often they call, and how long their calls are) then IMAP2's natural method of usage which requires the phone call to remain while a user is reading, poking around, sending, and rearranging mail can be much more costly than using POP3 if one call is used to quickly download all the mail and another later call is used to send any replies. Thus with POP3 a user might have two 1 minute calls before and after a 30 minute e-mail session instead of keeping the call for 30 minutes with IMAP2, and each phone line the institution offers could be serving 15 times as many such users who would each pay a lot less in long-distance phone bills. More about the protocols: Name: Post Office Protocol, Version 2 Nickname: POP2 Document: RFC 937 (Butler et al, February 1985) TCP-port: 109 Sites: Name: Post Office Portocol, Version 3 Nickname: POP3 Document: RFC 1460 (Rose, May 1993) TCP-port: 110 (109 also often used) Sites: UC Irvine, MIT Name: Distributed Mail Service Protocol Nickname: DMSP, Pcmail Document: RFC 1056 (Lambert, June 1988) TCP-port: 158 Sites: MIT Name: Interactive Mail Access Protocol, Version 2 Nickname: IMAP2 Document: RFC 1176 (Crispin, August 1990) TCP-port: 143 Sites: Stanford, U Washington Name: Interactive Mail Access Protocol, Version 2 bis Nickname: IMAP2bis Document: ? TCP-port: 143 Sites: U Washington Name: Interactive Mail Access Protocol, Version 3 Nickname: IMAP3 Document: RFC 1203 (Rice, February 1991) TCP-port: 220 Sites: Stanford Implementations: Prot Computer Implementation End Source ------ ----------- ------------------- ------- -------------------------------- DMSP PC pc-epsilon (3.1) client allspice.lcs.mit.edu DMSP PC pc-netmail (3.1) client allspice.lcs.mit.edu DMSP PC pc-reader client allspice.lcs.mit.edu DMSP Unix Pcmail 3.1 reposit. server allspice.lcs.mit.edu DMSP Unix/EMACS Pcmail 4.2 client allspice.lcs.mit.edu DMSP PC PC/TCP client FTP Software DMSP OS/2 PC/TCP client FTP Software DMSP OS/2 TCP/2 client Essex Systems DMSP OS/2 TCP/2 SERVER PACK server Essex Systems DMSP OS/2 TCP/2 ADV CLIENT client Essex Systems IMAP2 Macintosh MacMS 2.2.1 client sumex-aim.stanford.edu 10/15/93 IMAP2B Macintosh Mailstrom 1.04 client sumex-aim.stanford.edu 10/19/93 IMAP2B Macintosh Mailstrom 2 (b?) client sumex-aim.stanford.edu 10/19/93 POP2 Macintosh MacPOP 1.5 client trident.arc.nasa.gov POP2 MS-DOS PC POP 2.1 client trident.arc.nasa.gov POP3 Macintosh TCP/Connect II client InterCon Systems Corporation IMAP2 NeXT EasyMail client ftp.cac.washington.edu IMAP2 NeXT MailManager server ftp.cac.washington.edu IMAP2 TOPS20 ? server ? IMAP2 Unix imap kit server ftp.cac.washington.edu POP23 Unix imap kit server ftp.cac.washington.edu IMAP2 Unix Pine 3.07 client ftp.cac.washington.edu POP3 Macintosh Eudora 1.3.1 client ftp.qualcomm.com 11/2/93 POP3 Macintosh Eudora 1.4 client ftp.qualcomm.com 11/2/93 POP3 Macintosh Eudora 1.4.1 (beta) client ftp.qualcomm.com 11/2/93 POP3m Macintosh Eudora 2.0 (in dev) client ? POP3 MS-WINwf Eudora 1.0.1 client ftp.qualcomm.com 9/21/93 POP3 MS-WINw Eudora 1.4b17 client ftp.qualcomm.com 11/2/93 POP3 MS-WINw Eudora 2.0a14 client ? 11/2/93 IMAP2 Unix ? client ftp.cac.washington.edu IMAP2 Unix imapd 3.1 server sumex-aim.stanford.edu* IMAP2 Unix/X ximap 0.7.2 client sumex-aim.stanford.edu IMAP2 MS-DOSl+ PC-Pine (beta) client pine@cac.washington.edu IMAP2 Xrx Lsp Mch ? client ? IMAP2 MS-WIN ECS (beta) client ISA, ftp.srv.ualberta.ca POP2 Macintosh POPMail II client boombox.micro.umn.edu POP Macintosh POPMail II 2.09 client boombox? 9/21/93 POP2 Macintosh POPMail II 2.09 client boombox? 9/21/93 POP3 Macintosh POPMail II 2.09 client boombox? 9/21/93 IMAP2 Macintosh POPMail II 2.09 client boombox? 9/21/93 POP2 Macintosh MailStop server boombox.micro.umn.edu POP2 MS-DOS LifeLine Mail client SunSelect POP2 MS-DOSk ? server ucsd.edu POP2 MS-DOSk ? server boombox.micro.umn.edu POP3 MS-DOSk pop3serv server biochemistry.crwu.edu POP2 MS-DOS MD/DOS-IP client U Maryland POP2 MS-DOS PC/TCP client FTP Software POP2 OS/2 PC/TCP for OS/2 client FTP Software 11/2/93 POP23 MS-DOSp POPmail/PC 3.0 client boombox.micro.umn.edu 11/2/93 POP3 MS-DOS? Minuet (beta) client boombox.micro.unm.edu 11/2/93 IMAP? MS-DOSp POPmail/PC 3.0 client boombox.micro.umn.edu POP? MS-WINls TCPMail client Pinesoft (pinesoft@net.com) POP2 Unix POPmail/unix server boombox.micro.umn.edu POP2 Unix popd (USC-ISI) server trident.arc.nasa.gov POP2 Unix imapd/ipop2d server ftp.cac.washington.edu POP23k Unix mh-6.7 (UCI RandMH) both ftp.cc.berkeley.edu POP? Unix zmail client Z-Code Software (info@z-code.com) POP23k UnixX xmh/mh client ? POP23k UnixX dxmail/mh client DEC POP2 VM FAL server IBM POP2 VM ? server Texas Tech University POP2 OS/2 TCP/2 SERVER PACK server Essex Systems POP2 VMS MULTINet server TGV, Inc. POP2 HP3000/MPE NetMail/3000 server 3K Associates POP3k Macintosh Eudora X client ftp.brown.edu POP3 Macintosh MacPOP (Berkeley) client ftp.cc.berkeley.edu POP3k Macintosh TechMail 2.0 client net-dist.mit.edu POP3 Macintosh MacMH client jessica.stanford.edu/info POP3 Macintosh POPMail II client boombox.micro.umn.edu POP3 Macintosh MailStop (soon) server UMinn POP3 Macintosh VersaTerm Link client Synergy Software 10/8/93 POP3 Macintosh LeeMail 2.0.2 (shw) client chs.cusd.claremont.edu 10/12/93 POP3t Unix popper-1.7 server ftp.cc.berkeley.edu 10/15/93 POP3k Unix popper-1.7k server ftp.brown.edu POP3 Unix popper-1.831 server ? POP3 Solaris2.X popper-1.831 mod server ftp.uoregon.edu 10/19/93 POP3k Unix mh-6.7 (UCI RandMH) both ics.uci.edu POP3 Unix imapd/ipop3d server ftp.cac.washington.edu POP3t MS-DOSnpo PC/TCP client FTP Software POP3 OS/2 PC/TCP for OS/2 client FTP Software 11/2/93 POP3 MS-DOS TechMail(future) client ? POP3 MS-DOS ? client logos.ucs.indiana.edu POP3 MS-DOSp NuPOP 1.03 client ftp.acns.nwu.edu 10/26/93 POP3 MS-DOSp NuPOP 2.00 (beta) client ftp.acns.nwu.edu 9/21/93 POP3 MS-WIN Pceudora client ftp.qualcomm.com 9/24/93 POP3 ? POPgate (Pmail gw) client risc.ua.edu 9/24/93 POP3 MS-DOSl PMPOP (Pmail gw) client risc.ua.edu 10/20/93 POP3x MS-WIN WinQVT (2.1) client QPC Software (shareware) POP3 MS-WINp wnqvtnet 3.0 client ftp.cica.indiana.edu POP3 MS-WIN Open Systems Mail client Pine Software POP3 VMS IUPOP3 (1.7) (1.6?) server logos.ucs.indiana.edu POP3 VMS MULTINet both TGV, Inc. POP? VMS PMDF 4.2 server Innosoft IMAP? VMS PMDF 4.2 server Innosoft POP3 OS/2 TCP/2 SERVER PACK server Essex Systems POP3 OS/2 TCP/2 ADV CLIENT client Essex Systems POP? MS-DOS UCDmail client ucdavis.ucdavis.edu POP? MS-DOS PC POP client ?Bill Schweickert/Sterling Fed POP? MS-WINnpo Super-TCP for Wndws client Frontier Technologies 10/26/93 POP? MS-WIN Windows ELM client lister.cc.ic.ac.uk 11/2/93 POP? MS-DOSni ChameleonNFS client NetManage POP? Macintosh MEWS client ? POP? Macintosh byupopmail client ? POP? VM ? server TTUVM1 ? Macintosh Hypermail ? ? ------ ----------- ------------------- ------- -------------------------------- Appendix: Some other packages for desktop systems ------ ----------- ------------------- ------- -------------------------------- uucp Macintosh uAccess peer Intecom [12/17/92] SMTP Macintosh LeeMail 1.2.4 peer Shareware, laf@mitre.org SMTP Macintosh LeeMail 2.0.2 (shw) peer chs.cusd.claremont.edu 10/12/93 SMTP MS-DOSni ChameleonNFS peel NetManage uucp Macintosh FernMail peer Shareware, dplatt@snulbug.mtview.ca.us prop Macintosh MacPost both ftp.lu.se 10/19/93 uucp Macintosh Eudora 1.3.1 peer ftp.qualcomm.com uucp Macintosh UUPC peer dplatt@snulbug.mtview.ca.us uucp Macintosh gnuucp peer jim@fpr.com uucp MS-DOS waffle peer ? uucp MS-DOS UUPC peer ? ? MS-Windows Pegasus/Win 1.02 client risc.ua.edu 10/5/93 ? MS-DOS Pegasus/DOS 3.01 client risc.ua.edu 10/5/93 ? Macintosh Pegasus/Mac 2.04 client risc.ua.edu 10/5/93 SMTP MS-DOS Charon gateway risc.ua.edu 10/15/93 ------ ----------- ------------------- ------- -------------------------------- Other issues: (1) What are the common extensions to POP3 and which clients/servers support them? POP3k - Kerberos POP3a - AFS Kerberos POP3x - ? POP3t - xtnd xmit facility--allows client to send mail through additional POP commands, thus allowing server to verify/log source of mail. (2) What DOS protocol stacks are supported? MS-DOSm - Lan Manager MS-DOSn - NDIS Drivers MS-DOSl - Lan Workplace for Dos MS-DOSs - Sun PCNFS MS-DOSp - Packet Drivers MS-DOSo - ODI Drivers MS-DOSi - IPXLink MS-DOSf - FTP Software PC/TCP MS-WIN? - similar MS-WINw - WinSock compliaint ------ ----------- ------------------- ------- --------------------------------
Technical Details
Message-ID:
<1993Nov4.081447.18969@newstand.syr.edu>Path:
arc1-ca.pugleaf.net!senator-bedfellow.mit.edu!bloom-beacon.mit.edu!usc!cs.utexas.edu!uunet!psinntp!newstand.syr.edu!arachnids.syr.edu!jmwobusShow Full Headers
Complete Article Headers
Newsgroups: comp.mail.misc,news.answers Path: arc1-ca.pugleaf.net!senator-bedfellow.mit.edu!bloom-beacon.mit.edu!usc!cs.utexas.edu!uunet!psinntp!newstand.syr.edu!arachnids.syr.edu!jmwobus From: jmwobus@mailbox.syr.edu (John Wobus) Subject: LAN Mail Protocols Summary Message-ID: <1993Nov4.081447.18969@newstand.syr.edu> Followup-To: poster Originator: jmwobus@arachnids.syr.edu Reply-To: jmwobus@mailbox.syr.edu Organization: Syracuse University, Syracuse, NY Date: Thu, 4 Nov 93 08:14:47 EST Approved: jmwobus@mailbox.syr.edu Lines: 301