Article View: comp.mail.misc
Article #4228Re: Precedence in network mail addresses
From: Lennart Lovstrand
Date: Tue, 19 May 1987 01:17
Date: Tue, 19 May 1987 01:17
42 lines
2507 bytes
2507 bytes
In article <2767@meccts.MECC.MN.ORG> ahby@meccts.UUCP (Shane P. McCarron)
writes:
> In article <559@smidefix.liu.se> lel@ida.liu.se (Lennart Lovstrand) writes:
> All sorts of excellent information about routing and routing
> symbols...
> > Now, since "%" is the natural routing operator on top of "@", an
> > address like:
> > node1!user@node2
> > that is autorouted through "node3" will probably end up looking as:
> > node1!user%node2@node3
> > meaning:
> > node3 ->node2 ->node1 ->user
>
> It seems to me that undef RFC 976, something autorouted through "node3"
> should be transmitted as:
> node2!node1!user@node3
Not if node2 is an ARPANET node, say, that doesn't subscribe to RFC976.
Remember that RFC976 means "UUCP Mail Interchange Format". Even though
neither "!" nor "%" is an official routing operator for RFC822 complying
nodes, I would say that the latter is much more frequent than the former.
> Also, since "node2" started life after an @, it must by definition have a
> domain suffix attached to it. So, if th initial address had been:
> [...]
Well, yes, I was thinking of both node2 and node3 as domains, thanks for
pointing it out. Still, that doesn't necessarily mean that they have a
dot in them. RFC920 explictly states that a multiorganization could
become a top level domain, which means that you might wind up with
addresses like "TheSecretaryGeneral@UN".
Cheers,
--Lennart
--
Dept of Computer and Information Science, University of Linkoping, Sweden
Internet: Lennart.Lovstrand@IDA.LiU.SE EAN/X.400: lel@ida.liu.sunet
UUCP: {mcvax,munnari,seismo}!enea!liuida!lel EARN/BITNET: LEL@SELIUI51
--
Dept of Computer and Information Science, University of Linkoping, Sweden
Internet: Lennart.Lovstrand@IDA.LiU.SE EAN/X.400: lel@ida.liu.sunet
UUCP: {mcvax,munnari,seismo}!enea!liuida!lel EARN/BITNET: LEL@SELIUI51
Technical Details
Message-ID:
<561@miraculix.liu.se>Path:
arc1-ca.pugleaf.net!utzoo!mnetor!seismo!mcvax!enea!liuida!lelReferences:
<588@bsu-cs.UUCP> <958@xanth.UUCP> <559@smidefix.liu.se> <2767@meccts.MECC.MN.ORG>Show Full Headers
Complete Article Headers
Relay-Version: version B 2.10 5/3/83; site utzoo.UUCP Path: arc1-ca.pugleaf.net!utzoo!mnetor!seismo!mcvax!enea!liuida!lel From: lel@ida.liu.se (Lennart Lovstrand) Newsgroups: comp.mail.misc Subject: Re: Precedence in network mail addresses Message-ID: <561@miraculix.liu.se> Date: Mon, 18-May-87 21:17:38 EDT Article-I.D.: miraculi.561 Posted: Mon May 18 21:17:38 1987 Date-Received: Wed, 20-May-87 03:26:42 EDT References: <588@bsu-cs.UUCP> <958@xanth.UUCP> <559@smidefix.liu.se> <2767@meccts.MECC.MN.ORG> Sender: lenlo@miraculix.liu.se Organization: CIS Dept, Univ of Linkoping, Sweden Lines: 42