🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: comp.mail.misc
Article #5663

Re: America OnLine creates infinite mail loop

#5663
From: Erik Naggum
Date: Mon, 26 Apr 1993 23:11
55 lines
3576 bytes
[Richard Shuford]
:
|   Maintainers of automated electronic mailing lists should beware that
|   the Internet e-mail gateway of the America OnLine commercial
|   conferencing system does NOT honor the RFC822 "Errors-To:" header.

There is no RFC 822 Errors-To header.  It is a sendmailism.  sendmail and
RFC 822 are very seldom in agreement, and if so only by coincidence, such
as being tended by a diligent systems manager who has junked the vendor
configuration files, and even the vendor's version of sendmail.

|   In the event that a message from the Internet is undeliverable to
|   "joeuser@AOL.COM", an error message, in which the full text of the
|   failed inbound message is embedded, will be returned to the "From:"
|   address.

Without further evidence (it is in the mail), we cannot be sure that you
have followed RFC 821 on this point, that is, set the envelope header
right.  You may be using one of the less clever automated mailing list
software around, and then that is at fault, not AOL.COM.

|   If the "From:" address is that of an automated mailing list to which
|   joeuser@AOL.COM belongs, when the error message gets back to the
|   mailing-list-host computer, the list host will send the ERROR message
|   out to the members of the mailing list.  Including joeuser@AOL.COM.

Why have you set the From header to the mailing list?  It held the author
of the message before you started messing with it, did it not?  If you
start to claim that people are doing evil things to you, clean up your own
place first.  Mailing lists do not generate messages, they distribute them.
A big difference that is lost on some of the less clever automated mailing
list software around.

|   Naturally, maintainers of automated network mailing lists should be
|   cautious when an AOL.COM user wants to join a list.

Until further evidence is available, the error might well be in your
particular mailing list software, not in AOL's handling of errors.  I
suggest you calm down, read the specifications you point to, and just stay
out of this business of recommending what people should do when you lack
the prerequisite clue yourself.

Of course, AOL.COM may be doing the wrong thing, too, but in that case,
only the author of the message distributed to a mailing list would get
annoyed if the mailing list distribution software did the right thing.

See also RFC 1123 Internet Host Requirements, on mail.

Best regards,
</Erik>
--
Erik Naggum                 ISO  8879 SGML                   +47 2295 0313
Oslo, Norway                ISO 10744 HyTime
<erik@naggum.no>            ISO  9899 C                 Memento, terrigena
<SGML@ifi.uio.no>           ISO 10646 UCS             Memento, vita brevis
Technical Details
Message-ID: <19930426.033@erik.naggum.no>
Path: arc1-ca.pugleaf.net!gmd.de!Germany.EU.net!mcsun!sunic!ugle.unit.no!trane.uninett.no!nntp.uio.no!ifi.uio.no!enag
References: <1rhlt4INNirb@CS.UTK.EDU>

Show Full Headers
Complete Article Headers
X-Google-Language: ENGLISH,ASCII-7-bit
X-Google-Thread: 110b4b,3c84942dfe1c7069
X-Google-Attributes: gid110b4b,public
X-Google-Thread: f4424,3c84942dfe1c7069
X-Google-Attributes: gidf4424,public
X-Google-Thread: fd322,3c84942dfe1c7069
X-Google-Attributes: gidfd322,public
X-Google-Thread: 10d8d0,3c84942dfe1c7069
X-Google-Attributes: gid10d8d0,public
X-Google-ArrivalTime: 1993-04-26 16:26:47 PST
Newsgroups: comp.mail.misc,bit.listserv.mail-l,vmsnet.mail.mx,comp.mail.headers
Path: arc1-ca.pugleaf.net!gmd.de!Germany.EU.net!mcsun!sunic!ugle.unit.no!trane.uninett.no!nntp.uio.no!ifi.uio.no!enag
From: Erik Naggum <enag@ifi.uio.no>
Message-ID: <19930426.033@erik.naggum.no>
Date: 27 Apr 1993 01:11:31 +0200
References: <1rhlt4INNirb@CS.UTK.EDU>
Subject: Re: America OnLine creates infinite mail loop
Lines: 55