🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: comp.mail.misc
Article #995

Re: MSDOS/SunOs/ethernet/NFS compatible mailers

#995
From: Greg O'Connell
Date: Wed, 26 Aug 1992 09:38
185 lines
9367 bytes
With reference to my question:
|Is anyone prepared to recommend a mailer which will run under MSDOS
|(or Windows) and support both PC-PC mail via ethernet and co-exist
|with a Unix/Internet mail system - i.e. will exchange mail between
|the PC and the Internet via a SunOS machine.

I received the following replies - thanks to those who helped out.

Greg OConnell
**********************************************************************

Date: 13 Aug 1992 09:01:42 -0400
From: David Collier-Brown <davecb%nexus.yorku.ca@lux.levels.unisa.edu.au>
Subject: Re: A Unix (SunOS) compatible mailer for MSDOS
To: goconnel

  I think you'll get a lot of message about POP3 and IMAP2...
Here's a list of programs and sites:
Author: John Wobus
Syracuse University
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Serving PCs and Workstations Using a Central Mail Server on an Internet
- ------- --- --- ------------ ----- - ------- ---- ------ -- -- --------

There are advantages to collecting mail destined to PCs and workstations
on a central server, to be turned over to the PC or workstation on
demand:

- - Your PC or workstation may be down quite a bit and less network bandwidth
  and less of the processing resouces of the sending computer are used
  if the computer receiving your mail is ready.
- - Some people use more than one PC or workstation to read mail.
- - A PC or workstation may not have the resources to store all the mail
  you receive.
- - It can make your e-mail address more like other users'.

The easiest way to "implement" this is to run the central mail server like
any multi-user system: let people sign on to it and use some mail utility.
Then PC and workstation users can use "terminal sessions" to sign on to the
central mail server and read their mail.  This has the disadvantage of
making the PC and workstation users learn and use the central mail
server's procedures.

SMTP, the "internet" mail protocol used to deliver mail between multi-user
systems only supports mail transfer initiated by the sender.  Other
protocols have been devised to allow a workstation or PC to request
transfer of mail, thus able to make use of a cnetral server.  These
include the published protocols POP (probably not used anymore), POP2,
POP3, IMAP2, and DMSP.

POP, POP2, POP3:
These are rather minimal and are designed to be so.  The three are similar
but not enough alike to be interoperable.  They are basically designed to
identify the user by username and password, to transfer the mail from
server to PC or workstation and to delete the mail transferred.  It is
assumed that SMTP will be used to send mail.  Messages can be retrieved
individually, but the only information you can get about a message without
transferring it is its length in bytes-- useful for PCs with limited
storage.

POP2 and POP3 are still used a good deal.  POP3 has a couple of optional
extensions: one to avoid sending passwords, and one to aid in reading
bulletin boards.

IMAP2:
This is similar to the POP family, but also gives clients a way to do
string searches through mail that still resides on the server.  This is
designed to allow the PC or workstation to be more selective as to which
mail will be transferred.  The POP protocols, on the other hand, are
designed for simpler server software.

DMSP (aka PCMAIL):
PCs and workstations can use this protocol to both send and receive mail.
The system is designed around the idea that each user can own more than
one workstation; however, the system doesn't seem to handle the idea of a
"public workstation" very well.  The PCs and workstations are assumed to
hold state information about the mail, a directory so to speak, and when
the PC or workstation is connected to the server, this directory is
updated to "reality".

More about the protocols:

Name:      Post Office Protocol, Version 2
Nickname:  POP2
Document:  RFC 937 (Butler et al, February 1985)
TCP-port:  109
Sites:

Name:      Post Office Portocol, Version 3
Nickname:  POP3
Document:  RFC 1081 (Rose, November 1988)
TCP-port:  110 (109 also often used)
Sites:     UC Irvine, MIT

Name:      Distributed Mail Service Protocol
Nickname:  DMSP, Pcmail
Document:  RFC 1056 (Lambert, June 1988)
TCP-port:  158
Sites:     MIT

Name:      Interactive Mail Access Protocol, Version 2
Nickname:  IMAP2
Document:  RFC 1064
TCP-port:  143
Sites:     Stanford

Implementations:

Prot   Computer    Implementation      End     Source
- ------ ----------- ------------------- ------- -------------------------------
DSMP   ?           Pcmail 3.1 reposit. server  allspice.lcs.mit.edu
DSMP   PC          pc-epsilon (3.1)    client  allspice.lcs.mit.edu
DSMP   PC          pc-netmail (3.1)    client  allspice.lcs.mit.edu
DSMP   PC          pc-reader           client  allspice.lcs.mit.edu
DSMP   Unix/EMACS  Pcmail 3.1          client  allspice.lcs.mit.edu
DSMP   PC & OS/2   PC/TCP              client  FTP Software
DSMP   OS/2        ?                   client  Essex Systems
IMAP2  Macintosh   MacMS 2.1b1         client  sumex-aim.stanford.edu
IMAP2  Macintosh   Mailstrom (future)  client
IMAP2  NeXT        EasyMail            client  ftphost.cac.washington.edu
IMAP2  NeXT        MailManager         server  ftphost.cac.washington.edu
IMAP2  TOPS20      ?                   server  ?
IMAP2  Unix        ?                   client  ftphost.cac.washington.edu
IMAP2  Unix        imapd 3.1           server  sumex-aim.stanford.edu
IMAP2  Unix        imapd               server  ftphost.cac.washington.edu
IMAP2  Unix        pine                client  ftp.cac.washington.edu
IMAP2  Xrx Lsp Mch ?                   client  ?
IMAP2  PC          pine (future)       client
POP2   Macintosh   MacPOP 1.5          client  trident.arc.nasa.gov
POP2   Macintosh   MailStop            server  boombox.micro.umn.edu
POP2   PC          PC POP 2.1          client  trident.arc.nasa.gov
POP2   PC          LifeLine Mail       client  SunSelect
POP2   PC          ka9q                server  ?
POP2   PC          MD/DOS-IP           client  U Maryland
POP2   Unix        ?                   server  boombox.micro.umn.edu
POP2   Unix        popd (USC-ISI)      server  trident.arc.nasa.gov
POP2   Unix        imapd/ipop2d        server  ftphost.cac.washington.edu
POP2   Unix        mh-6.7 (UCI RandMH) server  lilac.berkeley.edu
POP2   VM          FAL                 server  IBM
POP2   PC          PC/TCP              client  FTP Software
POP3   Macintosh   Eudora 1.1          client  ftp.cso.uiuc.edu
POP3k  Macintosh   Eudora X            client  run at Brown U.
POP3   Macintosh   MacPOP (Berkeley)   client  ftp.cc.berkeley.edu
POP3k  Macintosh   TechMail 2.0        client  net-dist.mit.edu
POP3   Macintosh   TCP/Connect II      client  Interconnect, inc
POP3   Macintosh   MacMH               client  Stanford?
POP3&2 Macintosh   POPMail II          client  boombox.micro.umn.edu
POP3   Unix        popper-1.7          server  lilac.berkeley.edu
POP3   Unix        mh-6.7 (UCI RandMH) both    ics.uci.edu
POP3   Unix        imapd/ipop3d        server  ftphost.cac.washington.edu
POP3   PC          PC/TCP              client  FTP Software
POP3   PC          TechMail(future)    client  ?
POP3   PC          ?                   client  logos.ucs.indiana.edu
POP3   PC          NUPOP (in beta)     client  (ftp.acns.nwu.edu)
POP3   VMS         IUPOP3 (1.7)        server  logos.ucs.indiana.edu
POP3   VMS         MULTINet            both    (commercial)
POP?   PC          UCDmail             client  ucdavis.ucdavis.edu
POP?   PC          NUPOP               client  ftp.acns.nwu.edu
POP?   PC          PC POP              client  ?Bill Schweickert/Sterling Fed
POP?   Macintosh   MEWS                client  ?
POP?   Macintosh   byupopmail          client  ?
- ------ ----------- ------------------- ------- -------------------------------
-------------------------------------------------------
 *****************************************************************************
From: gfoster%darpa.mil@lux.levels.unisa.edu.au (Glen Foster)


Two reasonable PC user agents are POPmail and nupop, both free and
available in the usual PC SW archives. If you want to know more, ask
and I will tell you what I can.

If you have a Novell network, the combination of Pegasus mail and a
Charon mail gateway is hard to beat. These are both free, also.

Glen Foster
gfoster@darpa.mil

******************************************************************************
From: russell%alpha3.ersys.edmonton.ab.ca@lux.levels.unisa.edu.au (Russell Schulz)

I'm not sure via ethernet, but Waffle will do it via NFS-mounted file
systems.
-- 
Russell Schulz  russell@alpha3.ersys.edmonton.ab.ca  ersys!rschulz  Shad 86c
Technical Details
Message-ID: <1992Aug26.093804.18082@csaadel.adl.csa.oz>
Path: arc1-ca.pugleaf.net!sparky!uunet!munnari.oz.au!yoyo.aarnet.edu.au!sirius.ucs.adelaide.edu.au!levels!csaadel!goconnel

Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!sparky!uunet!munnari.oz.au!yoyo.aarnet.edu.au!sirius.ucs.adelaide.edu.au!levels!csaadel!goconnel
From: goconnel@csaadel.adl.csa.oz (Greg O'Connell)
Newsgroups: comp.mail.misc
Subject: Re: MSDOS/SunOs/ethernet/NFS compatible mailers
Message-ID: <1992Aug26.093804.18082@csaadel.adl.csa.oz>
Date: 26 Aug 92 09:38:04 GMT
Reply-To: goconnel@csaadel.adl.csa.oz.au (Greg O'Connell)
Organization: Computer Sciences of Australia Pty Ltd, Adelaide
Lines: 185