Thread View: comp.mail.misc
4 messages
4 total messages
Started by Rich Skrenta
Wed, 11 Nov 1992 17:12
a!b@c
Author: Rich Skrenta
Date: Wed, 11 Nov 1992 17:12
Date: Wed, 11 Nov 1992 17:12
18 lines
870 bytes
870 bytes
I used to think that a!b@c meant "give the message to a with address b@c" (Perhaps that's what smail 2.5 did?). Lately I've been seeing lots of address binding @ the other way: "deliver to c with address a!b". In other words, which is it: a!b@c -> @c:a!b a!b@c -> @a:b@c And what of: b%a@c Is there a standard which addresses this? Are most sites giving @ higher precedence, or !? -- Rich Skrenta
Re: a!b@c
Author: Kevin Darcy
Date: Thu, 12 Nov 1992 00:55
Date: Thu, 12 Nov 1992 00:55
73 lines
3331 bytes
3331 bytes
In article <1992Nov11.171241.20094@news.acns.nwu.edu> skrenta@casbah.acns.nwu.edu (Rich Skrenta) writes:
>I used to think that a!b@c meant "give the message to a with address
>b@c" (Perhaps that's what smail 2.5 did?). Lately I've been seeing
>lots of address binding @ the other way: "deliver to c with address a!b".
>
>In other words, which is it:
>
> a!b@c -> @c:a!b
> a!b@c -> @a:b@c
From RFC 976:
2.1 Hybrid Addresses
There are (among others) two major kinds of mailing address syntax
used in the UUCP world. The a!b!c!user ("bang paths") is used by
older UUCP software to explicitly route mail to the destination. The
user@domain ("domain") syntax is used in conformance to RFC-822.
Under most circumstances, it is possible to look at a given address
and determine which sort of address it is. However, a hybrid address
with a ! to the left of an @, such as a!b@c, is ambiguous: it could
be interpreted as (a!b)@c.d or a!(b@c.d). Both interpretations can
be useful. The first interpretation is required by RFC-822, the
second is a de-facto standard in the UUCP software.
Because of the confusion surrounding hybrid addresses, we recommend
that all transport layer software avoid the use of hybrid addresses
at all times. A pure bang syntax can be used to disambiguate, being
written c.d!a!b in the first case above, and a!c.d!b in the second.
We recommend that all implementations use this "bang domain" syntax
unless they are sure of what is running on the next machine.
In conformance with RFC-822 and the AT&T Message Transfer
Architecture, we recommand that any host that accepts hybrid
addresses apply the (a!b)@c.d interpretation.
---
There you go -- RFC 976 tells you that
a!b@c -> @c:a!b
amidst whining about not using hybrid addresses at all. :-)
>And what of:
>
> b%a@c
>
>Is there a standard which addresses this? Are most sites giving
>@ higher precedence, or !?
RFC 1123, Section 5.2.16:
---
An embedded source route is sometimes encoded in the
"local-part" using "%" as a right-binding routing
operator. For example, in:
user%domain%relay3%relay2@relay1
the "%" convention implies that the mail is to be routed
from "relay1" through "relay2", "relay3", and finally to
"user" at "domain". This is commonly known as the "%-
hack".
---
------------------------------------------------------------------------------
kevin@cfc.com | Kevin Darcy, Unix Systems Administrator
...heifetz!cfctech!kevin | Technical Services (CFC)
Voice: (313) 759-7140 | Chrysler Corporation
Fax: (313) 758-8173 | 25999 Lawrence Ave, Center Line, MI 48015
------------------------------------------------------------------------------
Re: a!b@c
Author: Ronald S. Karr
Date: Thu, 12 Nov 1992 07:40
Date: Thu, 12 Nov 1992 07:40
20 lines
1001 bytes
1001 bytes
In article <1992Nov11.171241.20094@news.acns.nwu.edu> skrenta@casbah.acns.nwu.edu (Rich Skrenta) writes:
>In other words, which is it:
>
> a!b@c -> @c:a!b
> a!b@c -> @a:b@c
According to RFC822 and RFC976, the only correct interpretation is @c:a!b.
>And what of:
>
> b%a@c
>
>Is there a standard which addresses this? Are most sites giving
>@ higher precedence, or !?
b%a@c is @c:b%a. According to RFC1123, a!b%c@d is @d,@c:a!b. However,
this renders the % character useless in the UUCP zone.
--
tron |-<=>-| ARPAnet: veritas!tron@apple.com
tron@veritas.com UUCPnet: {apple,pyramid}!veritas!tron
Re: a!b@c
Author: Leslie Mikesell
Date: Thu, 12 Nov 1992 16:53
Date: Thu, 12 Nov 1992 16:53
44 lines
2497 bytes
2497 bytes
In article <1992Nov11.171241.20094@news.acns.nwu.edu> skrenta@casbah.acns.nwu.edu (Rich Skrenta) writes: >I used to think that a!b@c meant "give the message to a with address >b@c" (Perhaps that's what smail 2.5 did?). Lately I've been seeing >lots of address binding @ the other way: "deliver to c with address a!b". > >In other words, which is it: > > a!b@c -> @c:a!b > a!b@c -> @a:b@c Here's the problem: sites running stock uucp mail (i.e. what AT&T sold at least up to SysVr3) never look past the first !. They will thus send such an addres to site "a" which will interpret the remaining part "b@c". There is no provision for changing this behaviour without replacing the mail transport program on these machines. (Smail is one such replacement). In spite of this, the internet standard is to deliver to the site to the left of the @ sign letting that machine interpret the remaining part, so a machine running SMTP would deliver to site "c", giving it the remaining address "a!b". So you can't use this kind of address unless you know which machine has which kind of mailer. What's worse is that the internet standards demand addresses to be in the user@domain form and uucp mailers don't provide them. Thus the uucp->internet forwarder must provide a return address like: uucp!path!user@forwarder.domain which is fine within the SMTP realm, but when the message is passed back to a uucp site the headers are generally not modified again and will probably be misinterpreted. >And what of: > > b%a@c This notation was introduced to avoid the problem of mixing ! and @. On the uucp side it's best to use RFC 976 notation - i.e hop1!hop2!hop3!domain!user, since it doesn't require knowledge of the type of mailer used by the intermediate sites and it is understood by virtually all uucp->smtp gateways. Unfortunately nothing works reliably the other direction. Most internet mailers are of the opinion that if you don't have a domain name you don't exist, regardless of the evidence to the contrary. Les Mikesell les@chinet.chi.il.us
Thread Navigation
This is a paginated view of messages in the thread with full content displayed inline.
Messages are displayed in chronological order, with the original post highlighted in green.
Use pagination controls to navigate through all messages in large threads.
Back to All Threads