🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

1 total messages Started by John Wobus Sun, 14 Feb 1993 17:17
LAN Mail Protocols Summary
#3810
Author: John Wobus
Date: Sun, 14 Feb 1993 17:17
211 lines
11491 bytes
Archive-name: LANs/mail-protocols

Serving PCs and Workstations Using a Central Mail Server on an Internet
------- --- --- ------------ ----- - ------- ---- ------ -- -- --------
 
There are advantages to collecting mail destined to PCs and
workstations on a central server, to be turned over to the PC or
workstation on demand:

- Your PC or workstation may be down quite a bit and less network
  bandwidth and less of the processing resouces of the sending computer
  are used if the computer receiving your mail is ready.
- Some people use more than one PC or workstation to read mail.
- A PC or workstation may not have the resources to store all the mail
  you receive.
- It can make your e-mail address more like other users'.

The easiest way to "implement" this is to run the central mail server
like any multi-user system: let people sign on to it and use some mail
utility.  Then PC and workstation users can use "terminal sessions" to
sign on to the central mail server and read their mail.  This has the
disadvantage of making the PC and workstation users learn and use the
central mail server's procedures.

SMTP, the "internet" mail protocol used to deliver mail between
multi-user systems only supports mail transfer initiated by the
sender.  Other protocols have been devised to allow a workstation or PC
to request transfer of mail, thus able to make use of a cnetral
server.  These include the published protocols POP (probably not used
anymore), POP2, POP3, IMAP2, IMAP3 and DMSP.

POP, POP2, POP3:  These are rather minimal and are designed to be so.
The three are similar but not enough alike to be interoperable.  They
are basically designed to identify the user by username and password,
to transfer the mail from server to PC or workstation and to delete the
mail transferred.  It is assumed that SMTP will be used to send mail.
Messages can be retrieved individually, but the only information you
can get about a message without transferring it is its length in
bytes-- useful for PCs with limited storage.

POP2 and POP3 are still used a good deal.  POP3 has a couple of
optional extensions: one to avoid sending passwords, and one to aid in
reading bulletin boards.

IMAP2, IMAP3:  The IMAP family is similar to the POP family, but also
gives clients a way to do string searches through mail that still
resides on the server.  This is designed to allow the PC or workstation
to be more selective as to which mail will be transferred.  The POP
protocols, on the other hand, are designed for simpler server
software.

IMAP2 is used quite a bit.  IMAP3 is an incompatible offshoot that has
not been implemented much.  Recent work not yet documented in an RFC
has extended IMAP2 to include support for multimedia mail.

DMSP (aka PCMAIL):  PCs and workstations can use this protocol to both
send and receive mail.  The system is designed around the idea that
each user can own more than one workstation; however, the system
doesn't seem to handle the idea of a "public workstation" very well.
The PCs and workstations are assumed to hold state information about
the mail, a directory so to speak, and when the PC or workstation is
connected to the server, this directory is updated to "reality".
 
More about the protocols:
 
Name:      Post Office Protocol, Version 2
Nickname:  POP2
Document:  RFC 937 (Butler et al, February 1985)
TCP-port:  109
Sites:
 
Name:      Post Office Portocol, Version 3
Nickname:  POP3
Document:  RFC 1225 (Rose, May 1991)
TCP-port:  110 (109 also often used)
Sites:     UC Irvine, MIT
 
Name:      Distributed Mail Service Protocol
Nickname:  DMSP, Pcmail 
Document:  RFC 1056 (Lambert, June 1988)
TCP-port:  158
Sites:     MIT
 
Name:      Interactive Mail Access Protocol, Version 2
Nickname:  IMAP2
Document:  RFC 1176 (Crispin, August 1990)
TCP-port:  143
Sites:     Stanford, U Washington
 
Name:      Interactive Mail Access Protocol, Version 3
Nickname:  IMAP3
Document:  RFC 1203 (Rice, February 1991)
TCP-port:  220
Sites:     Stanford

Implementations:
 
Prot   Computer    Implementation      End     Source
------ ----------- ------------------- ------- --------------------------------
DSMP   PC          pc-epsilon (3.1)    client  allspice.lcs.mit.edu
DSMP   PC          pc-netmail (3.1)    client  allspice.lcs.mit.edu
DSMP   PC          pc-reader           client  allspice.lcs.mit.edu
DSMP   Unix        Pcmail 3.1 reposit. server  allspice.lcs.mit.edu
DSMP   Unix/EMACS  Pcmail 4.2          client  allspice.lcs.mit.edu
DSMP   PC          PC/TCP              client  FTP Software
DSMP   OS/2        PC/TCP              client  FTP Software
DSMP   OS/2        TCP/2               client  Essex Systems
DSMP   OS/2        TCP/2 SERVER PACK   server  Essex Systems
DSMP   OS/2        TCP/2 ADV CLIENT    client  Essex Systems
IMAP2  Macintosh   MacMS 2.2.1         client  sumex-aim.stanford.edu
IMAP2  Macintosh   Mailstrom (beta)    client  sumex-aim.stanford.edu
POP2   Macintosh   MacPOP 1.5          client  trident.arc.nasa.gov
POP2   MS-DOS      PC POP 2.1          client  trident.arc.nasa.gov
POP3   Macintosh   TCP/Connect II      client  InterCon Systems Corporation

IMAP2  NeXT        EasyMail            client  ftp.cac.washington.edu
IMAP2  NeXT        MailManager         server  ftp.cac.washington.edu
IMAP2  TOPS20      ?                   server  ?
IMAP2  Unix        ?                   client  ftp.cac.washington.edu
IMAP2  Unix        imapd 3.1           server  sumex-aim.stanford.edu*
IMAP2  Unix/X      ximap 0.7.2         client  sumex-aim.stanford.edu
IMAP2  Unix        imapd               server  ftp.cac.washington.edu
IMAP2  Unix        pine                client  ftp.cac.washington.edu
IMAP2  Xrx Lsp Mch ?                   client  ?
IMAP2  MS-DOSl+    PC-Pine (beta)      client  pine@cac.washington.edu
IMAP2  MS-WIN      ECS (beta)          client  ISA, ftp.srv.ualberta.ca
POP2   Macintosh   POPMail II          client  boombox.micro.umn.edu
POP2   Macintosh   MailStop            server  boombox.micro.umn.edu
POP2   MS-DOS      LifeLine Mail       client  SunSelect
POP2   MS-DOS      ka9q                server  ucsd.edu
POP2   MS-DOS      MD/DOS-IP           client  U Maryland
POP2   MS-DOS      PC/TCP              client  FTP Software
POP2/3 MS-DOSp     POPmail/PC 3.0      client  boombox.micro.umn.edu
POP2   Unix        POPmail/unix        server  boombox.micro.umn.edu
POP2   Unix        popd (USC-ISI)      server  trident.arc.nasa.gov
POP2   Unix        imapd/ipop2d        server  ftp.cac.washington.edu
POP2   Unix        mh-6.7 (UCI RandMH) server  ftp.cc.berkeley.edu
POP2   VM          FAL                 server  IBM
POP2   VM          ?                   server  Texas Tech University
POP2   OS/2        TCP/2 SERVER PACK   server  Essex Systems
POP2   VMS         MULTINet            server  TGV, Inc.
POP3   Macintosh   Eudora 1.2.2        client  ftp.cso.uiuc.edu
POP3   Macintosh   Eudora 1.3 (in dev) client  ftp.qualcomm.edu
POP3k  Macintosh   Eudora X            client  ftp.brown.edu
POP3   Macintosh   MacPOP (Berkeley)   client  ftp.cc.berkeley.edu
POP3k  Macintosh   TechMail 2.0        client  net-dist.mit.edu
POP3   Macintosh   MacMH               client  jessica.stanford.edu/info
POP3   Macintosh   POPMail II          client  boombox.micro.umn.edu
POP3   Macintosh   MailStop (soon)     server  UMinn
POP3t  Unix        popper-1.7          server  ftp.cc.berkeley.edu
POP3k  Unix        popper-1.7k         server  ftp.brown.edu
POP3   Unix        popper-1.831        server  ?
POP3k  Unix        mh-6.7 (UCI RandMH) both    ics.uci.edu
POP3   Unix        imapd/ipop3d        server  ftp.cac.washington.edu
POP3t  MS-DOSnpo   PC/TCP              client  FTP Software
POP3   MS-DOS      TechMail(future)    client  ? 
POP3   MS-DOS      ?                   client  logos.ucs.indiana.edu
POP3   MS-DOS      NUPOP 1.03          client  ftp.acns.nwu.edu
POP3   MS-DOS      Eudora (alpha)      client  Qualcomm Inc (pc-eudora-info@qualcom.com)
POP3   MS-DOS      ka9q (future)       server  ?
POP3   ?           POPgate (Pmail gw)  server  risc.ua.edu
POP3x  MS-WIN      WinQVT (2.1)        client  QPC Software (shareware)
POP3   MS-WIN      Eudora (future)     client  Qualcomm Inc (pc-eudora-info@qualcom.com)
POP3   MS-WINp     wnqvtnet 3.0        client  ftp.cica.indiana.edu
POP3   MS-WIN      Open Systems Mail   client  Pine Software
POP3   VMS         IUPOP3 (1.7) (1.6?) server  mythos.ucs.indiana.edu, logos?
POP3   VMS         MULTINet            both    TGV, Inc.
POP3   OS/2        TCP/2 SERVER PACK   server  Essex Systems
POP3   OS/2        TCP/2 ADV CLIENT    client  Essex Systems
POP?   MS-DOS      UCDmail             client  ucdavis.ucdavis.edu
POP?   MS-DOS      PC POP              client  ?Bill Schweickert/Sterling Fed
POP?   MS-WINnpo   Super-TCP for Wndws client  Frontier Technologies
POP?   MS-DOSni    Chameleon           client  NetManage
POP?   Macintosh   MEWS                client  ?
POP?   Macintosh   byupopmail          client  ?
POP?   VM          ?                   server  TTUVM1
?      Macintosh   Hypermail           ?       ?
------ ----------- ------------------- ------- --------------------------------
Appendix:
Some other packages for desktop systems
------ ----------- ------------------- ------- --------------------------------
uucp   Macintosh   uAccess             peer    Intecom [12/17/92]
SMTP   Macintosh   LeeMail 1.2.4       peer    Shareware, laf@mitre.org
uucp   Macintosh   FernMail            peer    Shareware, dplatt@snulbug.mtview.ca.us
prop   Macintosh   MacPost             both    ftp.lu.se
uucp   Macintosh   Eudora              peer    ftp.cso.uiuc.edu
uucp   Macintosh   UUPC                peer    dplatt@snulbug.mtview.ca.us
uucp   Macintosh   gnuucp              peer    jim@fpr.com
?      MS-DOS      Pmail 2.3 (R1)      client  splicer.cba.hawaii.edu
?      MS-DOS      Pmail 2.3 (R2)(fut) client
?      MS-Windows  Pmain/Windows (fut) client
?      Macintosh   Pmail/Mac 1.1       client  splicer.cba.hawaii.edu
?      Macintosh   Pmail/Mac 2.0(beta) client  risc.ua.edu
------ ----------- ------------------- ------- --------------------------------
Other issues:
(1) What are the common extensions to POP3 and which clients/servers
 support them?
POP3k - Kerberos
POP3a - AFS Kerberos
POP3x - ?
POP3t - xtnd xmit facility--allows client to send mail through additional
 POP commands, thus allowing server to verify/log source of mail.
(2) What DOS protocol stacks are supported?
MS-DOSm - Lan Manager
MS-DOSn - NDIS Drivers
MS-DOSl - Lan Workplace for Dos
MS-DOSp - Packet Drivers
MS-DOSo - ODI Drivers
MS-DOSi - IPXLink
MS-WIN? - similar
------ ----------- ------------------- ------- --------------------------------
Thread Navigation

This is a paginated view of messages in the thread with full content displayed inline.

Messages are displayed in chronological order, with the original post highlighted in green.

Use pagination controls to navigate through all messages in large threads.

Back to All Threads