Article View: comp.mail.multi-media
Article #175Re: MultiMedia Mailtool
From: Dominic Richens
Date: Mon, 05 Oct 1992 18:30
Date: Mon, 05 Oct 1992 18:30
32 lines
2141 bytes
2141 bytes
In article <BvG4Gz.Dqv@cs.bham.ac.uk>, sdl@rabbit.cs.bham.ac.uk (Simon D. Levitt) writes:
! I am a 3rd year undergrad at Birmingham uni, and for my project I have
! chosen to write a mailtool that should be capable of handling
! multi-media mail. It is to be written to run under the X window system,
! and I am looking for ideas for what should be included in the package in
! the way of features and operation.
Firstly, you would want to look up RFC-934, RFC-1049, and RFC-1342 to find
which standards are already out there for "Content-type" headers in e-mail
messages.
Next, anon ftp the metamail stuff from thumper.bellcore.com, which includes
a description of MIME, and modifications for 19 existing "User Agents", so
that they may use MIME.
! I would be particularly interested in suggestions for the way that
! the different types of media could be included in mails being written.
For simplicity, I would make it flexible and easily extensible. Plus you
want to limit yourself to the amount of time you have for the project. If
you have easy access to audio (i.e. you got SPARCs), include that, and
maybe a builtin gif viewer. See if you can get some info on the NeXT mail
tool, as I've seen this work with sound and colour pictures.
dominic
--
!@$^&*)($#$@!@#$^&*()_+_)(*&^$#@!$^&*()_+)(*&^$#@$^&*+_(*&^$#@#^&*()&*$#@(*&+_$!
Dominic Richens : dominic@shamin.genie.uottawa.ca : Tel. (613) 564 9911
MCRLab, Dept of Elec Eng, University of Ottawa, K1N 6N5, CANADA
"You construct intricate rituals which allow you to touch the skin of other men"
Technical Details
Message-ID:
<1992Oct5.183006.23135@csi.uottawa.ca>Path:
arc1-ca.pugleaf.net!sparky!uunet!utcsri!torn!cunews!csi.uottawa.ca!newsReferences:
<BvG4Gz.Dqv@cs.bham.ac.uk>Show Full Headers
Complete Article Headers
Newsgroups: comp.mail.multi-media Path: arc1-ca.pugleaf.net!sparky!uunet!utcsri!torn!cunews!csi.uottawa.ca!news From: dominic@skaro.genie.uottawa.ca (Dominic Richens) Subject: Re: MultiMedia Mailtool Message-ID: <1992Oct5.183006.23135@csi.uottawa.ca> Originator: dominic@shamin.genie.uottawa.ca Sender: news@csi.uottawa.ca Nntp-Posting-Host: skaro.genie.uottawa.ca Reply-To: dominic@shamin.genie.uottawa.ca Organization: MCRLab - University of Ottawa References: <BvG4Gz.Dqv@cs.bham.ac.uk> Date: Mon, 5 Oct 92 18:30:06 GMT Lines: 32