Article View: comp.mail.mush
Article #1033Re: Time Zones -- help me out
From: Steve Yelvington
Date: Tue, 13 Feb 1990 06:41
Date: Tue, 13 Feb 1990 06:41
50 lines
2535 bytes
2535 bytes
[In article <1990Feb12.181547.27427@talos.uu.net>,
kjones@talos.uu.net (Kyle Jones) writes ... ]
> Barton E. Schaefer writes:
> > * day_number month_name year_number time timezone ...
> >
> > 5 Feb 1990 14:05:57 PST
> > 5 Feb 1990 14:05:57 -0800
> > 5 Feb 1990 14:05 PST
> > (The first two are RFC822 format, which, interestingly, RFC882
> > violates in its own examples section -- there, it uses something
> > like the last one, except with no `:' between hours/minutes. No
> > one has ever complained about encountering that format.)
>
> None of these are RFC 822 complaint because the year number is supposed
> to only have two digits.
That is no longer true; see the following excerpt:
RFC1123 MAIL -- SMTP & RFC-822 October 1989
5.2.14 RFC-822 Date and Time Specification: RFC-822 Section 5
The syntax for the date is hereby changed to:
date = 1*2DIGIT month 2*4DIGIT
All mail software SHOULD use 4-digit years in dates, to ease
the transition to the next century.
There is a strong trend towards the use of numeric timezone
indicators, and implementations SHOULD use numeric timezones
instead of timezone names. However, all implementations MUST
accept either notation. If timezone names are used, they MUST
be exactly as defined in RFC-822.
The military time zones are specified incorrectly in RFC-822:
they count the wrong way from UT (the signs are reversed). As
a result, military time zones in RFC-822 headers carry no
information.
Finally, note that there is a typo in the definition of "zone"
in the syntax summary of appendix D; the correct definition
occurs in Section 3 of RFC-822.
(Followups are directed to comp.mail.headers.)
--
Steve Yelvington at the (thin ice today) lake in Minnesota
Technical Details
Message-ID:
<A86578253@thelake.mn.org>Path:
arc1-ca.pugleaf.net!utzoo!utgpu!jarvis.csri.toronto.edu!mailrus!tut.cis.ohio-state.edu!zaphod.mps.ohio-state.edu!brutus.cs.uiuc.edu!usc!snorkelwacker!apple!rutgers!umn-d-ub!cs.umn.edu!thelake!steveReferences:
<3257@taux01.UUCP> <7129@ogicse.ogc.edu> <7135@ogicse.ogc.edu> <1990Feb12.181547.27427@talos.uu.net>Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!utzoo!utgpu!jarvis.csri.toronto.edu!mailrus!tut.cis.ohio-state.edu!zaphod.mps.ohio-state.edu!brutus.cs.uiuc.edu!usc!snorkelwacker!apple!rutgers!umn-d-ub!cs.umn.edu!thelake!steve From: steve@thelake.mn.org (Steve Yelvington) Newsgroups: comp.mail.mush,comp.mail.misc Subject: Re: Time Zones -- help me out Message-ID: <A86578253@thelake.mn.org> Date: 13 Feb 90 06:41:18 GMT References: <3257@taux01.UUCP> <7129@ogicse.ogc.edu> <7135@ogicse.ogc.edu> <1990Feb12.181547.27427@talos.uu.net> Followup-To: comp.mail.headers Lines: 50