Article View: comp.mail.sendmail
Article #2656Re: discrepancies between RFC821 and RFC822 (as amended by RFC1123) regarding Received headers
From: John Gardiner Myers
Date: Sun, 10 Jan 1993 17:10
Date: Sun, 10 Jan 1993 17:10
21 lines
1531 bytes
1531 bytes
bruce@blilly.uucp (Bruce Lilly) writes: > 1) RFC821 section 4.1.1 requires the "from" and "by" clauses, while > RFC822 4.1 lists them as optional. [...] > so if a message which arrives at an > Internet site via some mechanism other than SMTP contains an RFC822 > Received header without a "from" or a "by" clause (or without both), > it is a technical violation of either RFC821 or RFC1123 to transmit > the message via SMTP to another Internet site I disagree. RFC 821 specifies the grammar of the time stamp line a server must insert at the beginning of the mail data (4.1.1.DATA). I see no prohibition in RFC 821 against transmitting a message already containing Recieved: headers that do not match the <time-stamp-line> grammar. -- _.John G. Myers Internet: jgm+@CMU.EDU LoseNet: ...!seismo!ihnp4!wiscvm.wisc.edu!give!up
Technical Details
Message-ID:
<gfICIOa00WBwQPAmVQ@andrew.cmu.edu>Path:
arc1-ca.pugleaf.net!sparky!uunet!cs.utexas.edu!uwm.edu!ogicse!das-news.harvard.edu!cantaloupe.srv.cs.cmu.edu!crabapple.srv.cs.cmu.edu!andrew.cmu.edu!jm36+References:
<1993Jan10.162048.22777@blilly.uucp>Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!sparky!uunet!cs.utexas.edu!uwm.edu!ogicse!das-news.harvard.edu!cantaloupe.srv.cs.cmu.edu!crabapple.srv.cs.cmu.edu!andrew.cmu.edu!jm36+ From: jgm+@CMU.EDU (John Gardiner Myers) Newsgroups: comp.mail.sendmail,comp.protocols.tcp-ip,comp.mail.headers Subject: Re: discrepancies between RFC821 and RFC822 (as amended by RFC1123) regarding Received headers Message-ID: <gfICIOa00WBwQPAmVQ@andrew.cmu.edu> Date: 10 Jan 93 17:10:18 GMT Article-I.D.: andrew.gfICIOa00WBwQPAmVQ References: <1993Jan10.162048.22777@blilly.uucp> Organization: Systems Group 97, Carnegie Mellon, Pittsburgh, PA Lines: 21 In-Reply-To: <1993Jan10.162048.22777@blilly.uucp>