Article View: comp.mail.sendmail
Article #2665Re: discrepancies between RFC821 and RFC822 (as amended by RFC1123) regarding Received headers
From: Bruce Lilly
Date: Mon, 11 Jan 1993 15:53
Date: Mon, 11 Jan 1993 15:53
36 lines
2479 bytes
2479 bytes
In article <gfICIOa00WBwQPAmVQ@andrew.cmu.edu>,
posted to comp.mail.sendmail,comp.protocols.tcp-ip,comp.mail.headers,
jgm+@CMU.EDU (John Gardiner Myers) wrote:
>
>I disagree. RFC 821 specifies the grammar of the time stamp line a
>server must insert at the beginning of the mail data (4.1.1.DATA). I
>see no prohibition in RFC 821 against transmitting a message already
>containing Recieved: headers that do not match the <time-stamp-line>
>grammar.
The section you mentioned explicitly states ``Relayed messages will have
multiple time stamp lines.'' The syntax for the time stamp (Received) lines
*requires* the "from" and "by" clauses. No exceptions are stated. Note that
example 8 in RFC821 shows "from" and "by" clauses in all Received headers,
not only the first one.
I suppose one could claim that Received headers without the "from"
and/or "by" clauses aren't RFC821 time-stamp lines, but are mere ordinary
RFC822 headers. Note that RFC821 states ``that the final mail data will
begin with a return path line, followed by one or more time stamp lines.
These lines will be followed by the mail data header and body''. If some
Received headers are to be considered non-time-stamps, then it will be
necessary to reorder the Received headers so that the ones which are also
time-stamp-lines are placed before the non-time-stamp lines. I feel that this
would hamper debugging, as the order of Received headers would not then
correspond to the delivery path.
I still think this area needs some clarification. For reasons mentioned in
my original article, I would like to see at least the "by" clause made
mandatory.
--
Bruce Lilly, Product Manager, |
Routers, Peripherals & Still Store,| uupsi!monymsys!sonyd1!bruce
Sony, 3 Paragon Drive, Montvale, | lilb@sony.compuserve.com
NJ 07645-1735 | Telephone: +1 201 358 4161 | FAX: +1 201 358 4274
Technical Details
Message-ID:
<1993Jan11.155339.5123@sonyd1.Broadcast.Sony.COM>Path:
arc1-ca.pugleaf.net!sparky!uunet!psinntp!monymsys!sonyd1.broadcast.sony.com!bruceReferences:
<1993Jan10.162048.22777@blilly.uucp> <gfICIOa00WBwQPAmVQ@andrew.cmu.edu>Show Full Headers
Complete Article Headers
Newsgroups: comp.mail.sendmail,comp.protocols.tcp-ip,comp.mail.headers Path: arc1-ca.pugleaf.net!sparky!uunet!psinntp!monymsys!sonyd1.broadcast.sony.com!bruce From: bruce@sonyd1.Broadcast.Sony.COM (Bruce Lilly) Subject: Re: discrepancies between RFC821 and RFC822 (as amended by RFC1123) regarding Received headers References: <1993Jan10.162048.22777@blilly.uucp> <gfICIOa00WBwQPAmVQ@andrew.cmu.edu> Organization: Bruce Lilly Date: Mon, 11 Jan 93 15:53:39 GMT Message-ID: <1993Jan11.155339.5123@sonyd1.Broadcast.Sony.COM> Reply-To: lilb@sony.compuserve.com Lines: 36