Article View: comp.mail.uucp
Article #2788Re: Interpretation of RFC-822
From: Bruce Lilly
Date: Tue, 05 Jan 1993 02:01
Date: Tue, 05 Jan 1993 02:01
32 lines
2118 bytes
2118 bytes
In article <yLmTwB4w165w@valinor.mythical.com>, posted to comp.mail.uucp, stu@valinor.mythical.com (Stu Labovitz) wrote: >RFC, here's the question: Does RFC #822 provide limits (either minimum or >maximum) upon the number of SPACE characters that separate the "To:" from >the mailbox on the destination line? Must there be at least one SPACE, >and is there any reasonable interpretation to prevent the existance of >more than one SPACE? RFC822 does not specify either a minimum or maximum. According to the rules in RFC822, it is possible to have no space, and there is no maximum. Note however that RFC822 recommends that "long" lines be folded. Depending on the context, other RFCs or specific program implementation may impose limits. For example, in the context of news articles, at least one space is required between the header field and the field body[*]. In the case of mail transmitted via SMTP, very long lines (in excess of 1000 characters at a minimum) may cause problems. And even if lines are folded, you're likely to have a problem if you have 64k or more LWSP characters between the header field and its body (the minimum message size limit per RFC1123). * Of course, news articles do not need a To header, but if one is present it must conform to the rules in RFC1036. That RFC specifically requires one space after the colon, but it is ambiguous regarding whether additional space characters are permitted. It says only "additional information" must occur after the space (which it calls a "blank"). -- Bruce Lilly blilly!bruce@Broadcast.Sony.COM ...uunet!sonyusa!sonyd1!blilly!bruce
Technical Details
Message-ID:
<1993Jan5.020145.9780@blilly.uucp>Path:
arc1-ca.pugleaf.net!sparky!uunet!UB.com!daver!hico2!sonyd1.broadcast.sony.com!blilly.uucp!bruceReferences:
<yLmTwB4w165w@valinor.mythical.com>Show Full Headers
Complete Article Headers
Newsgroups: comp.mail.uucp Path: arc1-ca.pugleaf.net!sparky!uunet!UB.com!daver!hico2!sonyd1.broadcast.sony.com!blilly.uucp!bruce From: bruce@blilly.uucp (Bruce Lilly) Subject: Re: Interpretation of RFC-822 Keywords: whitespace, structured headers, destination References: <yLmTwB4w165w@valinor.mythical.com> Organization: Bruce Lilly Date: Tue, 5 Jan 93 02:01:45 GMT Message-ID: <1993Jan5.020145.9780@blilly.uucp> Reply-To: lilb@sony.compuserve.com (Bruce Lilly) Lines: 32