Article View: comp.protocols.iso.dev-environ
Article #729ISO/CCITT standards descriptions
From: Richard Shuford
Date: Wed, 01 May 1991 04:58
Date: Wed, 01 May 1991 04:58
111 lines
5633 bytes
5633 bytes
> Date: 29 Apr 91 16:13:41 EDT
> From: ZK0E2003@VMHOST.NCTSW.NAVY.MIL (David Keith)
> To: isode@nic.ddn.mil
> Subject: ISO and CCITT
>
> Does anyone know where I might get a copy of the ISO and CCITT
> standards? I prefer to get them online if possible. More specifically
> is there somewhere on the Internet where these are maintained? Thanks
> in advance for your input.
Your question is a candidate for most "Frequently Asked Question" for this
[mailing-list,newsgroup].
First, the bad news.
Alas, there is precious little to be found online.
The ISO and CCITT conduct their proceedings in a manner foreign (so to
speak) to Internet convention. Authorized standards are available
only as copyrighted printed documents. These are sold at a price
designed to help defray the expenses of creating the standard, which is
to say, at a high price.
In the United States, the most convenient place to buy them is
Omnicom Inc.
115 Park St. SE
Vienna, VA 22180-4607
(voice) +1 703/281-1135
(fax ) +1 703/281-1505
CCITT documents are also available, I'm told, via the United Nations
Bookstore.
Now, the slight amelioration.
Summaries of the ISO/CCITT standards can be found in books from
conventional publishers. These condensed versions are not suitable
if you are going to make your living selling implementations of the
protocols and services, but a student of the subject can study them
with some profit, and the level of detail might suffice for building
a toy implementation. (I'm not deprecating the value of toys in
understanding the technology, but an implementation developed without
reference to the real documents is in danger of breaking when used
for any vital purpose.)
One such book is
\OSI Explained: End-to-End Computer Communication Standards/, 2nd ed.
by John Henshall and Sandy Shaw. Published by Ellis Horwood Ltd. 1990.
ISBN 0-13-639451-5, TK5105.5.H47, 250 pages.
You can also find some help in
\The Open Book: A Practical Perspective on OSI/ by Marshall T. Rose.
Prentice-Hall 1990. ISBN 0-13-643016-3, TK5105.5.R67, 652 pages.
If you are accustomed to learning protocols by reading Internet RFC
documents, you will find the language and terminology used in the OSI
standards to be strangely formal. Sometimes the formality obviously
was needed in writing documents intended for use by people whose native
languages are not English; other times it looks like the formality was
put in just to make the document look impressive. In this "OSIfied"
language, for instance, the word "byte" is not used. The units of
information that computers manipulate are called "octets".
As regards online sources of information, there are a few, but they
are often hard to find. The individual authors of some standards
sometimes make copies of \draft/ versions of documents available in
electronic form, but you often have to be a friend-of-a-friend to get
these.
In some cases where the technology of TCP/IP and OSI are juxtaposed,
one of the Request-for-Comment series discusses the interworking
of the two protocol families. Examples of these are:
RFC1006: ISO Transport Services on Top of the TCP
RFC 994: Protocol for Providing the Connectionless Mode Network Service
RFC1148: Mapping Between X.400(1988)/ISO 10021 and RFC822
Otherwise, sometimes a researcher will take information from an
ISO/CCITT document, cast it into different form, and then make this
derived work available electronically. One such derivative work was
constructed at the University of Twente, a description of the OSI
Transport Protocol ISO 8072 in the LOTOS protocol-specification
language. This particular work is available, until the next Great
Disk Space Crunch, by anonymous FTP from our server "cs.utk.edu"
(128.169.201.1). Look for
pub/internetworking/iso_spec/kremer_lotos_1.mail
pub/internetworking/iso_spec/tp_lotos.txt.Z
The "tp_lotos.txt" file has been compressed in the Unix style; the
compressed size is 103,177 bytes, er, octets. Set "type binary" for
the file transfer and then decompress on your end. Eventually, the
University of Twente plans to make this and some other documents
directly available for FTP (and possibly for FTAM as well).
Possibly other readers of this forum will point out additional handy
sources of OSI information.
[Incidently, does the news/mailing-list gateway send traffic in only one
direction: FROM the Usenet newsgroup "comp.protocols.iso.dev-environ"
TO the mailing list "isode@nic.ddn.mil"? I'm posting this via news,
but several things I have read in the mail have not shown up in the
newsgroup.....RSS]
--
....Richard S. Shuford | "Do not rebuke a mocker or he will hate you; rebuke
....shuford@cs.utk.edu | a wise man and he will love you. Instruct a wise
....BIX: richard | man and he will be wiser still." Proverbs 9:7 NIV
Technical Details
Message-ID:
<1991May1.045844.4774@cs.utk.edu>Path:
arc1-ca.pugleaf.net!utzoo!utgpu!news-server.csri.toronto.edu!rpi!zaphod.mps.ohio-state.edu!ncar!gatech!utkcs2!shufordReferences:
<19910429.161342.ZK0E2003@NARDAC>Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!utzoo!utgpu!news-server.csri.toronto.edu!rpi!zaphod.mps.ohio-state.edu!ncar!gatech!utkcs2!shuford From: shuford@cs.utk.edu (Richard Shuford) Newsgroups: comp.protocols.iso.dev-environ Subject: ISO/CCITT standards descriptions Summary: general case is hardcopy-only Keywords: OSI, document, protocol, FTP, access, lack of Message-ID: <1991May1.045844.4774@cs.utk.edu> Date: 1 May 91 04:58:44 GMT References: <19910429.161342.ZK0E2003@NARDAC> Sender: shuford@cs.utk.edu Followup-To: comp.protocols.iso.dev-environ Organization: University of Tennessee, Knoxville--Dept. of Computer Science Lines: 111