🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: comp.protocols.iso.x400
Article #843

2nd Newsletter from the Internet X.400 Project.

#843
From: Alf Hansen
Date: Fri, 17 May 1991 16:23
426 lines
18573 bytes
============================================================================

                              T H E  4 0 0

   Internet X.400 Pilot Project Newsletter                              No 2
                                                                 May 17 1991
   Queries to:
   C=us; ADMD= ; PRMD=xnren; O=UW-Madison; OU=cs; S=x400-project-team
                             x400-project-team@pilot.cs.wisc.edu
   Phone: +1 608 262 5084
   Fax:   +1 608 262 9777

   Computer Sciences Department, University of Wisconsin-Madison,
   1210 West Dayton Street, Madison, Wisconsin 53706, USA.

============================================================================


THIS IS OUR SECOND NEWSLETTER.
------------------------------

This Newsletter will on a regular basis inform you about the recent
developments in our project. The information is intended for

   - Organizations already participating in the experimental Internet
     X.400 service.
   - Organizations that may be interested in joining either as an MTA
     under PRMD=XNREN or as a subscriber to other PRMDs in the
     Internet.
   - Any other interested parties.


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


The project is maintaining a file store of documents.
-----------------------------------------------------

Internet X.400 documents are available by anonymous FTP from a file store
maintained by the Internet X.400 Pilot Project in Wisconsin.  Login with
the username "anonymous" and password "guest" on the machine
mhs-relay.cs.wisc.edu (128.105.8.53). After logging in, position yourself
to the correct directory:

   type "cd pub"       to find this catalog
   type "cd pub/argo"  to find information about the ARGO X.400
                       implementation.
   type "cd pub/doc"   to find the documents describing the current
                       operational documentation of the pilot Internet X.400
                       service.
   type "cd pub/gen"   to find general information resulting from the
                       Internet X.400 project.
   type "cd pub/ietf"  to find documents related to the IETF X.400
                       Operations WG.

Type "ls" to get a list of documents.

If you are a newcomer, the documents marked as 1 2 3 4 contain background
material and should be read first. The following files are available:

Last modified   Filename                       Explanation
------------------------------------------------------------------------------
pub/
May 17 1991     catalog.txt                    This catalog file.

pub/argo/
*** Contains information about the ARGO X.400 implementation.
Apr  9 1991     argo-info.txt                  General information.
Apr  9 1991     sysadmin.n                     System adm. aspects.
Apr  9 1991     sysadmin.out
Apr  9 1991     users.n                        User facilities.
Apr  9 1991     users.out

pub/doc/
*** Contains documents and information about documents describing the pilot
*** Internet X.400 service. Intended for service managers.
May  1 1991     country-us-prmds               List of Internet PRMDs.
May 15 1991     doc-info.txt                   Info about the documents.
May  1 1991     format-documents.txt           Formal format description.
May 16 1991     i-wep                          Description of I-WEPs.
Apr 18 1991     mta-us                         Description of MTAs.
Apr 17 1991     org-us                         Description of Organizations.
Apr  2 1991     rfc987-mapping1                Current address mapping tables.
Apr  2 1991     rfc987-mapping2

pub/gen/
*** General information resulting from the Internet X.400 project.
Feb 13 1991     88-to-84-downgrading-kille.txt
Feb 13 1991     dns-987.ps                     Draft RFC for use of DNS to
Feb 13 1991     dns-987.txt                    manage RFC 987 mapping info.
Jan 25 1991   4 how-to-join.txt                Info on how to join the service
Feb 13 1991     ixom-minutes-nov-28-90.txt     Initial meeting in Madison.
Feb 13 1991     mhs-md-1st-meeting-rep.txt     MHS-MD is a subgroup of the
Feb 13 1991     mhs-md-1st-meeting-slides.txt  U.S. CCITT study group D.
Apr  9 1991     mhs-md-2nd-meeting-rep.txt
Jan 14 1991     na-form.txt                    XNREN X.400 registration form.
Jan 14 1991     na-statutes.txt                Statutes XNREN Naming Authority
Jan 14 1991   1 newsletter-1.txt               Newsletter, 1st issue.
May 17 1991   2 newsletter-2.txt               Newsletter, 2nd issue.
Jan 14 1991   3 prospectives.txt               Prospectives for X.400 organiz.

pub/ietf/
*** Contains documents related to the IETF X.400 Operations WG.
Feb 18 1991     agenda-st-louis-march-12-13-91.txt
Apr  9 1991     cdc-x500-usage.txt             CDC product's X.500 usage.
Feb 13 1991     charter.txt                    IETF X.400 OPS WG charter.
May 13 1991     i-wep-def.txt                  Draft definition of I-WEP.
Apr  5 1991     minutes-st-louis-march-12-13-91.txt
Apr  9 1991     rfc-987-multimedia-ext.txt     Contribution from CDC.
Feb 13 1991     status-cdc.txt                 Input to St. Louis meeting.
Feb 13 1991     status-xnren.txt               Input to St. Louis meeting.
------------------------------------------------------------------------------

Documents are located at:

     o  CS-Department, UW-Madison
        Address:  mhs-relay.cs.wisc.edu (128.105.8.53)

For questions, please mail to

   c=us; admd= ; prmd=xnren; o=UW-Madison; ou=cs; pn=postmaster
   postmaster@pilot.cs.wisc.edu




- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


What has happened since November 90?
------------------------------------

IETF:

The IETF X.400 Operations WG meeting in St. Louis, March 12-13 1991,
showed that there is a great interest in X.400 operations in the Internet
community. Some major draft decisions were made in St. Louis:

  1) The WG agreed on an X.400/RFC-822 address mapping scheme for the U.S.
     Internet community (will be described later in this Newsletter).

  2) A minimum solution for X.400 routing, using a structure of I-WEPs,
     was adopted.

  3) Documents in the Internet X.400 Documentation will be used as a
     mechanism to describe and ensure end-user X.400 connectivity over
     different underlaying network protocol suites (RFC-1006/TCP/IP -
     TP-0/X.25 - TP-4/CLNP)

  4) An outline of a new RFC: "Requirements for Internet PRMDs," was
     drafted.

The project team will produce the draft RFC described in 4) to be reviewed
at the next IETF in Atlanta (July 29 - August 2 1991).


OPERATIONAL STATUS:

The draft decisions made on address mapping, routing and documentation
are to be implemented by the pilot operational Internet X.400 services now
comprising 4 operational PRMDs: ARC, CDC, Hughes and XNREN.

The number of real X.400 users is still very low. However with the new
operational PRMDs, the number is growing.

The following organizations are operational and interconnected as X.400
systems. Addressing examples are given in order to show what the X.400
addresses look like. The X.400 addresses are presented both in X.400
Standard Attribute (SA) form and in RFC 822 form.

Organizations,
PRMD XNREN:       X.400 address in SA form and RFC 822 form
------------------------------------------------------------------------
University of Wisconsin-Madison
Madison, WI
                  C=us; ADMD= ; PRMD=xnren; O=uw-madison; OU=cs; S=User
                  User@pilot.cs.wisc.edu

National Science Foundation
Washington, D.C.
                  C=us; ADMD= ; PRMD=xnren; O=nsf; PN=User
                  User@pilot.nsf.gov

Rice University
Houston, TX
                  C=us; ADMD= ; PRMD=xnren; O=rice-univ; PN=User
                  User@exp.rice.edu

Mitre Corporation
McLean, VA
                  C=us; ADMD= ; PRMD=xnren; O=mitre; OU=ieg; PN=User
                  User@pilot.ie.org

University of Pennsylvania
Philadelphia, PA
                  C=us; ADMD= ; PRMD=xnren; O=upenn; OU=cis; PN=User
                  User@pilot.upenn.edu



Organizations,
PRMD Hughes:      X.400 address in SA form and RFC 822 form
------------------------------------------------------------------------
Hughes Aircraft Company,
Space & Communications Group
Los Angeles, CA
                  C=us; ADMD=MCI; PRMD=Hughes; O=SCG; OU=whitney; S=User
                  User@whitney.hac.com



Organizations,
PRMD ARC:         X.400 address in SA form and RFC 822 form
------------------------------------------------------------------------
NASA-Ames Research Center
CA
                  C=us; ADMD=telemail; PRMD=arc; O=nasa; OU=argo; PN=User
                  User@pilot.arc.nasa.gov



Organizations,
PRMD CDC:         X.400 address in SA form and RFC 822 form
------------------------------------------------------------------------
Control Data Corporation
Arden Hills, MN
                  C=us; ADMD=ATTMail; PRMD=CDC; O=CPG; S=User
                  User@cpg.cdc.com


These organizations can communicate with X.400 users in the R&D MHS
Service in the following countries:

Austria, Australia, Belgium, Canada, Denmark, Germany, Finland, France,
Iceland, Ireland, Italy, The Netherlands, Norway, Portugal, Spain, Sweden,
Switzerland, United Kingdom, and Yugoslavia.

The project is operating an RFC 987 gateway (PP) between the U.S. Internet
mail service and the international R&D MHS Service (X.400). This gateway
is also the experimental U.S. WEP (WEP = Well known Entry Point) in the
COSINE MHS Service in Europe, and it is directly connected to other WEPs
in Canada, Finland, France, Norway, Spain, Switzerland and United Kingdom.
X.400 traffic to the other countries in the COSINE MHS Service, is routed
via the Norwegian WEP operated by the UNINETT project.

France, Norway, Spain and Switzerland are routing some of their X.400
initiated traffic destined to the U.S. Internet mail domains, via our
gateway as an experiment. This means that messages initiated in X.400
can be kept in the X.400 "world" all the way to the U.S. and gatewayed
here, if necessary. Due to these routing experiments the monthly traffic
through our WEP has increased considerably.


TECHNICAL ASSISTANCE:

The project is distributing the ARGO X.400 implementation to
non-commercial organizations, and we are also offering assistance to
organizations who are starting to use the PP X.400/RFC-987 gateway system
from UCL, London. The assistance we offer is limited to operational
issues, initial PP configuration, address mapping tables, etc. E-mail us
if you would like such assistance. General software support should be
obtained from the pp-support team in London.


EXTERNAL PRESENTATIONS:

The project was presented at the 2nd Joint European Networking Conference
in Blois, France, May 13 - 16 1991. "X.400 in the Internet" will be
presented at the INET '91 Conference in Copenhagen, Denmark, June 17 - 20
1991.


VALUE ADDED SERVICES:

The project team is developing a FAX gateway service between X.400 and
FAX. Status so far is that a text file can be sent to a given fax number.
More work has to be done to develop this into a useful service allowing
end-users to use their X.400 User Agent to send a text message to a fax-
subscriber in the U.S. It is a goal to negotiate agreements with other
countries such that X.400 users in the U.S. also can send international
fax using similar fax gateways in other countries.

This service, when developed, will be made available for all X.400
users in the Internet X.400 service, and also on a bilateral basis to
X.400 users in other countries.


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


    * * * Topic of today: * * *

The "St. Louis decision" on address mapping.
--------------------------------------------

The draft decision in St. Louis is valid for the U.S. Internet, and can
also be viewed as a recommendation for communities outside the U.S.

The address mapping issue can be split into two parts:

  1) Specification of RFC-822 addresses seen from the X.400 world.

  2) Specification of X.400 addresses seen from the RFC-822 world.


1) Specification of RFC-822 addresses seen from the X.400 world.

   The following is from the St. Louis minutes:

"  It was agreed that RFC822 addresses should be expressed using X.400
   domain defined attributes.  Furthermore, a special PRMD named "Internet"
   will be defined to facilitate the specification of RFC822 addresses.
   For example, an X.400 user will address an RFC822 recipient by
   constructing an X.400 address such as:

     /c=us/admd= /prmd=Internet/dd.RFC-822=user(a)some.place.edu/

   Participating MTA's will be configured to recognize
   "/c=us/admd= /prmd=Internet/" as a special case.  The presence of
   this address will cause a message to be routed to a regional RFC987
   gateway.  In effect, this special PRMD identifies a community of
   gateways to RFC822 recipients.  This strategy is user friendly in that all
   users everywhere need only remember this one address, and it is
   efficient in that it avoids having to establish a single, common gateway
   which would tend to become a bottleneck and single point of failure."


2) Specification of X.400 addresses seen from the RFC-822 world.

   The following is also from the same minutes:

"  After considerable discussion, it was agreed that RFC822 users should be
   able to address X.400 recipients in RFC822/Internet terms.  This
   implies the necessity of maintaining and distributing address mapping
   tables to all participating RFC987 gateways, at least in the short term.
   Other mapping strategies were discussed (loudly and enthusiastically), but
   it was shown that these alternate strategies would sometimes cause
   messages (or replies to messages) to pass through more than one gateway.
   Since this behavior would probably cause information to be lost in
   translation, it was quickly agreed that the alternate strategies were
   inferior to the good old table driven approach.

   Nevertheless, it was also pointed out that some X.400 addresses do
   not map cleanly to RFC822 addresses, even when the table driven
   mapping strategy is used.  For example, X.400 personal names which
   contain generation qualifiers, personal names which contain initials
   but no given name, and initials which contain periods cannot be mapped
   to RFC822 symmetrically such that a reverse mapping is possible.
   Similarly, X.400 addresses which contain X.121 address elements
   (sometimes used for expressing fax telephone numbers), unique UA
   identifiers, or physical addressing attributes cannot be mapped nicely.
   Consequently, it will be necessary for RFC987 gateways to generate RFC987
   address syntax occasionally.

   It was recommended that our RFC should contain guidelines for the
   creation of X.400 personal names.  In following these guidelines,
   users will avoid creating personal names which can not be mapped
   nicely between X.400 and RFC822.

   It was generally agreed that long term reliance upon static mapping
   tables is unacceptable.  Therefore, it was agreed that the X.400
   Operations Working Group should devise a strategy for using X.500
   directory services instead.

   Another option could be to use the DNS system for this purpose, if the
   X.500 infrastructure appears to be too premature."

In other words, in most of the cases RFC-822 users will not see the
difference between an RFC-822 address and an X.400 address. Example:

The X.400 address:

   C=us; ADMD=ATTMail; PRMD=CDC; O=CPG; S=Jordan; G=Kevin

will from an RFC-822 user look like:

   Kevin.Jordan@cpg.cdc.com

The mapping tables in the gateways will describe this mapping.

The other way around, an X.400 user, will normally see the difference of
an X.400 address and an RFC-822 address, because the RFC-822 address will
be using PRMD=Internet and dd.RFC-822 (example):

The RFC-822 address:

   ok@subdomain.edu

will from an X.400 user look like:

   C=us; ADMD= ; PRMD=Internet; DD.RFC-822=ok(a)subdomain.edu

The decision to use Domain Defined Attributes (DDAs) requires modification
of the current mapping table coordination procedures defined by the
European RARE-WG1. Such modifications have already been discussed and some
proposals are on the table.


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


Internet X.400 Project Contact Points:
--------------------------------------

If you need information from the project, please look first in the
catalog.txt file in our file server and check if there are some documents
there that might give you the information you need.

To contact the project team, please use the coordinates in the beginning
of this Newsletter.

The following persons are working on the Internet X.400 Project:

Allan.Cargille@pilot.cs.wisc.edu
C=us; ADMD= ; PRMD=xnren; O=UW-Madison; OU=cs; S=Cargille; G=Allan

Rob Hagens <hagens@cs.wisc.edu>
C=us; ADMD= ; PRMD=Internet; DD.RFC-822=hagens(a)cs.wisc.edu

Alf.Hansen@pilot.cs.wisc.edu
C=us; ADMD= ; PRMD=xnren; O=UW-Madison; OU=cs; S=Hansen; G=Alf

Larry Landweber <lhl@cs.wisc.edu>
C=us; ADMD= ; PRMD=Internet; DD.RFC-822=lhl(a)cs.wisc.edu

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Technical Details
Message-ID: <910517112138*/G=Alf/S=Hansen/OU=cs/O=uw-madison/PRMD=xnren/C=us/@MHS>
Path: arc1-ca.pugleaf.net!utzoo!utgpu!news-server.csri.toronto.edu!rpi!zaphod.mps.ohio-state.edu!sdd.hp.com!elroy.jpl.nasa.gov!jarthur!ucivax!gateway

Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!utzoo!utgpu!news-server.csri.toronto.edu!rpi!zaphod.mps.ohio-state.edu!sdd.hp.com!elroy.jpl.nasa.gov!jarthur!ucivax!gateway
From: Alf.Hansen@pilot.cs.wisc.edu (Alf Hansen)
Newsgroups: comp.protocols.iso.x400
Subject: 2nd Newsletter from the Internet X.400 Project.
Message-ID: <910517112138*/G=Alf/S=Hansen/OU=cs/O=uw-madison/PRMD=xnren/C=us/@MHS>
Date: 17 May 91 16:23:10 GMT
Lines: 426
Approved: usenet@ics.uci.edu
X400-Originator: Alf.Hansen@pilot.cs.wisc.edu
Content-Identifier: 910517112138
X400-Received: by mta pilot.cs.wisc.edu in /PRMD=xnren/ADMD= /C=us/; Relayed;
               Fri, 17 May 1991 11:21:50 +0000
X400-Received: by /PRMD=xnren/ADMD= /C=us/; Relayed;
               Fri, 17 May 1991 11:21:41 +0000
X400-Content-Type: P2-1984 (2)
X400-MTS-Identifier: [/PRMD=xnren/ADMD= /C=us/;hansen674497301.12hermit.cs.uw]