🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Thread View: comp.protocols.iso.x400
1 messages
1 total messages Started by Harald.T.Alvestrand Fri, 01 Jan 1993 03:01
Frequently Asked Questions on comp.protocols.iso.X400 - with answers
#856
Author: Harald.T.Alvestrand
Date: Fri, 01 Jan 1993 03:01
332 lines
13996 bytes
This is the Frequently Asked Questions file for
the mailing list MHSNEWS/newsgroup comp.protocols.iso.X400

It is sent to the list on the first of every month.

$Revision: 1.12 $
$Date: 1992/11/30 10:37:50 $

CURRENT QUESTIONS

1) What is X.400?
2) How does X.400 compare to SMTP?
3) What X.400 implementations are available?
4) Where can I FTP the X.400 standards?
5) Where can I find more information about X.400 and OSI?
6) How do I send to Telefax from X.400?
7) On which type of network may I use X.400
8) What books can be recommended on X.400?
9) What is my X.400 address?
10) Why does mail to /..../@gateway fail?

QUESTIONS AND ANSWERS

1) What is X.400?
=================
X.400 is the short name for the set of standards from ISO and the
CCITT that describe a mail service.
It is the only non-proprietary standard for interchange of electronic
mail that has the sanction of an official standards body.

It currently exists in 3 flavours:

- X.400/84: This is what most implementations today in fact run.
  It was documented in the "Red Book" series from CCITT.

- ISO MOTIS/86 (mostly dead): This was the first attempt from ISO to
  agree to what the CCITT had done. It died at the DIS stage.
  It contains some elements you need in order to conform to the
  European functional profiles and make manageable systems from the
  1984 version, like domain-internal trace and the ISO6937 body part.

- X.400/88: This is documented in the "Blue Book" series.
  Most people seem to think that this is a great improvement over 84,
  but the number of systems implementing it has been underwhelming.
  This one is also an International Standard by ISO.

2) HOW DOES X.400 COMPARE TO SMTP?
==================================
This depends on what you are asking for.

SMTP has got:
- Simplicity
- Wide acceptance
- Public domain implementations
- Public domain user interfaces

X.400 has got:
- Acceptance in the standards communities
- Commercial vendors of service
- Defined ways to transfer things other than ASCII text
  (but only a few implementations have implemented it)
- Standard notifications of delivery to user's mailbox and notification
  of a message being read by the user (these ones are often implemented, too!)

3) WHAT X.400 IMPLEMENTATIONS EXIST?
====================================

The answer to this question formed the largest and fastest-changing part
of the FAQ; it is now sent out as a separate message. It should be the
one immediately following this one.

4) Where can I FTP the X.400 standards?
=======================================

Officially, you can't.
The OSI community has a large number of organizations that derive
revenue from *selling* copies of these standards.

The CCITT, not being funded in that way, made an experiment in which
they made all the CCITT documents available for anonymous FTP, but
that experiment terminated on December 31, 1991.

Currently, the ITU has set up an automatic mail responder at the
address teledoc@itu.arcom.ch (C=ch;admd=arcom;prmd=itu;s=teledoc)
that contains a large number of documents, but not, at the moment,
the text of the standards themselves.
The press release says that "TELEDOC will be available on request,
on a trial period of one year, at no access cost".
If you send a message with HELP as the first word in the body, you will
get a simple user guide.

ISO documents cannot in general be put online. In some cases, the authors
have placed copies of last-version drafts online, since drafts are not
copyrighted by ISO. They are available (at cost) from your local
standards body. Some organizations also provide subscription services
and provide copies of the standards.

5) Where can I find more information about X.400 and OSI?
=========================================================
There is various information on the FTP server at Uni-Erlangen:

     ftp ftp.uni-erlangen.de

and log in as "anonymous" with your e-mail address as password.
Look in the directory pub/doc/ISO/english. There are a lot of
files containing USENET articles and other sources of information
about OSI protocols and related ISO/CCITT standards. The file
INDEX contains a summary of the contents.

Markus Kuhn <mskuhn@immd4.informatik.uni-erlangen.de>, who kindly
supplied me with this information, maintains this archive. Please
contact him if you have additional interesting files.

Other interesting places, supplied by Markus Kuhn:


ftp.uni-erlangen.de   pub/doc/ISO           collected USENET articles etc.
osi.ncsl.nist.gov
ftp.uu.net            networking/osi        ISODE and other OSI stuff
                      networking/x25
nic.ddn.mil           protocols             DoD and GOSIP related stuff
                      rfc                   RFC Repository
cs.ucl.ac.uk          src                   ISODE, PP, OSIMIS, ...
                      osi-ds                Internet X.500 documents
                      ietf-osi-oda          Internet ODA documents
aun.uninett.no        ietf/mhs-ds           X.500 based routing drafts
ftp.ifi.uio.no        pub/SGML              SGML/HyTime related things
ftp.uni-stuttgart.de  info/standards        various documents
                      info/osi-rus          X.400/X.500 papers
nnsc.nsf.net          CCR                   IEEE CCR articles
uu.psi.com            isode                 ISODE 8.0

The CCITT standards are not officially online any more.

6) How do I send Telefax from X.400?
====================================

The answer, as usual, is "ask your service provider".
The most common schemes:

- The standardized one: C=<country>;ADMD=<service provider>;X121=9<telephone>
  Unfortunately, this ignores the fact that 99.9% of all fax machines are
  multiuser machines, which makes it useless for mailing list purposes; there
  is no way to tell the recipient who it is for.
- The DDA one: C=<country>;<a lot of other attributes>;
               DD.FAX=<telno>;DD.ATTN=<name>
  A lot of variants are turned on this; but it fulfils the USER requirements.
- Another variant (used by PRIME) is to allow S and G attributes in the
  O/R name instead of having a DD.ATTN attribute.

7) ON WHICH TYPE OF NETWORK MAY I USE X.400
===========================================

  X.400 '84 has been defined to run over a standard OSI stack (X.25,
TP0, BAS Session), thus most implementations, and all that pass
conformance tests, are able to run over a X.25 network. Often these
implementations have a X.25 or a transport level interface with
manufacturers supplied lower layers. In the case of transport-level,
X.400 is thus able to run over CLNS as long as this is supported under
the Tli or XTi.
  However, in order to enable use of TCP/IP network, many
implementations offer RFC1006 ( TP0 over TCP/IP) access. This is
almost mandatory within TCP/IP based LAN and a real plus for the R&D
community which maily use TCP/IP WANs.
  Additionaly a few implementations such as PP/ISODE and M.PLUS/UCOM.X
come along with an RFC1006 TS-bridge which act as a relay between
X.25 and TCP/IP network for OSI applications such as X.400 and
X.500.
  Finaly many X.400 implementations for PCs or Mac have been developped
to use what exists in the PC arena such as PC-NFS, NETBios, X.32
or even dialup over modems. Carefully check what is available with
your favourite supplier!


8) WHAT BOOKS SHOULD I READ ON X.400?
=====================================

In spite of the large interest on the topic, there does not seem to be
many specific X.400 books around.

The ones that have been mentioned are:

  X400 Message Handling, Standards, Interworking, Applications
  by B. Plattner, C. Lanz, H. Lubich, M. M"uller and T. Walter
    of the Swiss Federal Institute of Technology (ETH), Zurich
  It was translated by Stephen S. Wilson
  Published by Addison-Wesley, 1991, data communications and networks series
  ISBN 0-201-56503-X
  Price approximately USD 41

  The German edition is named:
  Elektronische Post und Datenkommunikation:
  X.400: Die Normen und ihre Anwendung.
  Bonn: Addison-Wesley, 1989

  It includes:
  - Basics of the OSI reference model and the X.400 MHS model
  - Stuff about interworking (mentioning RARE MHS!), EDI and more
  - Improvements of X.400 from 84 to 88, and the problems in interworking
  - A lot of useful appendices.

Information by Marcel Mink <M.J.Mink@fel.tno.nl>
Also mentioned by:
Philipp Hoschka <Philipp.Hoschka@sophia.inria.fr>
David McAnally <ACUS02@WACCVM.corp.mot.com>


  Carl-Uno Manros
  The X.400 blue book companion
  Twickenham: Technology Appraisals, 1989.
  ISBN: 1-871802008

  Not very detailed, but helps if one also reads the standard "in parallel".

Information by Philipp Hoschka <Philipp.Hoschka@sophia.inria.fr>

  Robert Babatz, Manfred Bogen und Uta Pankoke-Babatz
  Elektronische Kommunikation - X.400
  Braunschweig: Vieweg, 1990.
  ISBN: 3-528-06389-0

  Very helpful, but in German. There might be plans for
  an English edition, though.

Information by Philipp Hoschka <Philipp.Hoschka@sophia.inria.fr>

  Sara Radicati
  Electronic Mail, an introduction to the X.400 Message Handling Standards
  McGraw-Hill 1992 (Uyless Black series on computer communication)
  ISBN: 0-07-051104-7

  Fairly comprehensible and readable. A good introductory text

Information by Erik Skovgaard <eskovgaa@cue.bc.ca>
Mentioned by Hans P. Holen <h.p.holen@usit.uio.no>

9) What is my X.400 address?

If you have an Internet address of the form username@domain.name, there
are two alternatives for your X.400 address:

EITHER there is a defined mapping onto standard attributes for your domain,
so that, for instance

   Harald.Alvestrand@delab.sintef.no

           maps to

   C=no;ADMD= ;PRMD=uninett;O=sintef;OU=delab;S=Alvestrand;G=Harald

OR there is no such mapping, and you will have to use a Domain Defined
Attribute:

  Someone@somewhere.com

       maps to

  <Std. Attributes of a gateway>;DD.RFC-822=Someone(a)somewhere.com

An IETF working document (draft-ietf-x400ops-mgtdomains-01.txt) gives
the suggestion to use C=us;ADMD= ;PRMD=Internet to mean "any gateway to
the Internet". This is not yet final, but might be supported on some
X.400 services. It is not likely to work in commercial services.

The following characers have special conversion rules when used in DDAs:

@       ->      (a)     at sign
!       ->      (b)     exclamation point (bang)
%       ->      (p)     percent sign
_       ->      (u)     underscore

All the hoary details may be found in RFC 1327.
A more readable version is the COSINE addressing user guide, found in
English and French at nic.switch.ch.

FTP access: login COSINE, directory public/user-guides, file addressing-*
Email access: send to cosine-mhs-server@nic.switch.ch with the
   body saying "SEND public/user-guides-address-ing-english-080992.txt"

A few places where you can use TELNET to a port, type in your address
and see what it maps to, are:

   relay.surfnet.nl(130.161.180.100) port 4545
   nic.switch.ch, login as "mailaddr"
   sirius.dfn.de, login as "adressen"

These services are also available via X.25 PAD and e-mail; get the
addressing guide mentioned above for the details.

NOTE: If you use gateways that do not conform to RFC 987, RFC 1148 or
RFC 1327, all bets are off. For instance, the kindest description of
the result of passing through the gateways of most commercial X.400
service providers is "interesting".


10) Why does mail to /..../@gateway fail?

This is a bug of long standing.

Typically, you see a message like:

<< /...../@gateway: Cannot mail directly to files

This has a long and convoluted history.
Usually, it involves a mailer that knows how to do UUCP.

It turns out that one program used in UUCP (uuxqt) is capable of
executing a large set of commands, some of which may destroy important
files if given filename arguments.

So, in order to protect this from happening, HDB UUCP will follow in
the tradition of fixing loose thumbtacks with sledgehammers, and
refuse to accept any command that has an argument that looks like a
filename that is relative to the root.

In the common UUCP setup, where only rmail and rnews are permitted,
this does not make sense, but it is not possible to turn it off.

In Taylor UUCP, it is a compile time option.
(This information supplied by Ian Lance Taylor <ian@airs.com>)

Another "nice" feature that helps in causing this is the "s" flag in
the Sendmail mailer definition. This strips the quotes off the local
part of the address, so that "/..../"@gateway gets turned into
/..../@gateway, which easily makes things go haywire.
This flag should be nuked on all mailers except the "local" and "prog"
mailers. Unfortunately, SUN ships it on all mailers by default, but then,
anyone who uses a SUN default Sendmail configuration has problems anyway.


.
Thread Navigation

This is a paginated view of messages in the thread with full content displayed inline.

Messages are displayed in chronological order, with the original post highlighted in green.

Use pagination controls to navigate through all messages in large threads.

Back to All Threads