🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: comp.protocols.misc
Article #854

Re: 802.2 DSAP/SSAP assignments

#854
From: Rob Warnock
Date: Wed, 05 Oct 1988 07:41
70 lines
3422 bytes
In article <23647@hi.unm.edu> cyrus@hi.unm.edu (Tait Cyrus) writes:
+---------------
| Before I call IEEE, I was wondering if anyone had a more detailed
| list of the 802.2 Link Service Access Points than are listed in
| RFC 1010.  Currently the RFC has:
| ...	06	DOD IP
| 	AA	SNAP ...
+---------------

NOTA BENE: The use of the "06" LSAP/DSAP is deprecated, in favor of the
SNAP-based scheme described in RFC 1042, which gives you the full 16-bit
Ethernet types, not just "IP".  (This is primarily because the IEEE committee
wouldn't allocate a bunch of other types for the other link-level things
we all know and love on Ethernet and feel are needed for a useful IP suite:
ARP, RARP, BOOTP, etc.)

In fact, in RFC 1010, just after the table you mention, is the following
section:

	Due to some evolution of the IEEE 802.2 standards and the need to
	provide for a standard way to do additional DoD-IP related protocols
	(such as the Address Resolution Protocol (ARP) on IEEE 802 network,
	the following new policy is established, which will replace the old
	policy (see RFC 960 and RFC 948 [108]).

	The new policy is for the Internet community to use the IEEE 802.2
	encapsulation on 802.3, 802.4, and 802.5 networks by using the SNAP
	with an organization code indicating that the following 16 bits
	specify the EtherType code (where IP = 2048 (0800 hex), see Ethernet
	Numbers of Interest).

								  Header
	...--------+--------+--------+
	MAC Header|      Length     |                        802.{3/4/5} MAC
	...--------+--------+--------+
	+--------+--------+--------+
	| Dsap=K1| Ssap=K1| control|                                802.2 SAP
	+--------+--------+--------+
	+--------+--------+---------+--------+--------+
	|protocol id or org code =K2|    Ether Type   |            802.2 SNAP
	+--------+--------+---------+--------+--------+

	The total length of the SAP Header and the SNAP header is 8-octets,
	making the 802.2 protocol overhead come out on a nice boundary.

	K1 is 170.  The IEEE likes to talk about things in little-endian bit
	transmission order and specifies this value as 01010101.  In
	big-endian order, as used in Internet specifications, this becomes
	10101010 binary, or AA hex, or 170 decimal.

	K2 is 0 (zero).

	The use of the IP LSAP (K1 = 6) is to be phased out as quickly as
	possible.

This change was initiated several years ago at the first TCP/IP Interoperability
Conference in Monterey, CA. As far as I know, no one but H-P is still using
the IP LSAP (and they may have quit by now). Similarly, virtually no one is
actually using "802.3" framing; they're all using "Ethernet". The above scheme
*is* being used on 802.5 token rings, and is already in use by some people on
FDDI.


Rob Warnock
Systems Architecture Consultant

UUCP:	  {amdcad,fortune,sun}!redwood!rpw3
ATTmail:  !rpw3
DDD:	  (415)572-2607
USPS:	  627 26th Ave, San Mateo, CA  94403
Technical Details
Message-ID: <23133@amdcad.AMD.COM>
Path: arc1-ca.pugleaf.net!utzoo!utgpu!water!watmath!clyde!att!osu-cis!tut.cis.ohio-state.edu!mailrus!uflorida!gatech!amdcad!rpw3
References: <23647@hi.unm.edu>

Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!utzoo!utgpu!water!watmath!clyde!att!osu-cis!tut.cis.ohio-state.edu!mailrus!uflorida!gatech!amdcad!rpw3
From: rpw3@amdcad.AMD.COM (Rob Warnock)
Newsgroups: comp.protocols.misc
Subject: Re: 802.2 DSAP/SSAP assignments
Keywords: 802.2,LSAP
Message-ID: <23133@amdcad.AMD.COM>
Date: 5 Oct 88 07:41:28 GMT
References: <23647@hi.unm.edu>
Reply-To: rpw3@amdcad.UUCP (Rob Warnock)
Distribution: na
Organization: [Consultant] San Mateo, CA
Lines: 70