🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: comp.protocols.ppp
Article #244

comp.protocols.ppp part7 of 8 of frequently wanted information

#244
From: Ignatios Souvatzis
Date: Tue, 14 Dec 1993 14:02
250 lines
11654 bytes
Archive-name: ppp-faq/part7
Version: $Revision: 3.8 $
Last-modified: $Date: 93/12/14 14:55:37 $

                    7. COMMERCIAL PPP SOFTWARE PACKAGES
                                     
7.1 Amiga Inet

   A version, which will support SLIP (but, alas, not PPP), is expected to
   be distributed with AmigaOS 3.1 in spring 93
   
7.2 MSDOS with and without MSWindows

  7.2.1 COMMERCIAL PPP PACKAGES FOR MS-DOS AND MS-WINDOWS
  

  This information orignally appeared in the December 7th, 1992 issue
of "Open Systems Today", a newspaper published by CMP Publications,
(516) 562-5882.

  Each of these packages costs around $400 not including volume or other
discounts. Call the vendor for details.

  Each of the packages is a complete TCP/IP stack with assorted client
programs, ftp, telnet, etc.., that run under MS-DOS and/or MS-Windows.
The TCP/IP client programs included in each package vary. Some use the
DOS command line (even under MS-Windows) while others have full Windows
GUI interfaces.  A PPP client (but not server) is included with each of
these packages.

7.2.1.1.  LAN WorkPlace for DOS 4.1 beta (see also 7.2.2)
    Novell
    USA: (801) 429-5588

  Summary: This is an MS-DOS TSR (Terminate and Stay Ready) solution so it
  runs under either MS-DOS or MS-Windows. It includes a program called
  "DIALUP" that only allows connections at 8 bits, no parity. You can use
  the public domain "kermit" program instead if you need 7 bits, parity
  connections.

7.2.1.2.  PC/TCP
    FTP Software
    USA: (508) 685-4000
    Contact: info@ftp.com

  Summary: PC/TCP is an MS-DOS TSR solution that had PPP long before it
  was fashionable. Not surprisingly, it was the only non-beta product
  available for this review.

  Comment: PC/TCP 2.2 was shipped 24/25 March 1993 (information indirectly
     through one of their customers.) I copy parts of the feature list:

    1. Autoinstall/Autoconfig (graphical interface, easy install)
    2. PCTCPNET (mount InterDrives from File Manager)
    3. PCNFSD Print Support (multiple print redirection through PCNFSD)
    4. Router Discovery - RFC 1256
    5. 8K UDP Writes
    6. WMSG (Demonstrates IP Multicast)
    7. NFS/TCP Support
    8. International Character Set Support / Names in InterDrive
    9. International Character Set Support / Directory in InterDrive
    10. MVSLogin Support for InterDrive
    11. TN Mouse and light pen Support
    12. VI Compression for both SLIP and PPP
    13. WinSockAPI Meets Final Revision
    14. Interdrive EMM Caching Support - use EMM for buffers
    15. Inet - Serial line additions debug SLIP and PPP connections
    16. Kerberos/Ktelnet
    17. Kernel/Netbios Interactions imporved support for LANtastic, LAN MAN


7.2.1.3.  Distinct TCP/IP 3.0 beta
    Distinct Inc.
    USA: (408) 741- 0781

  Summmary: This is a Windows DLL solution so it only runs under MS-Windows
.
  Nice scripting features and built-in support (stored configuration
  strings, basically) for various modems.

7.2.1.4.  Super-PPP for Windows 1.0 beta
    Frontier Technologies Corp
    USA: (414) 241-4555

  Summary: This is a Windows DLL solution that is an optional component of
  their Super-TCP for Windows product. Super-TCP comes in both TSR and
  DLL flavors but the Super-PPP product is strictly DLL. Very configurable.


  Performance notes: If you run PPP under MS-Windows, your performance will
  suck (it might not work at all!) unless you have 16550A UARTs in your PC.

  If you have an extra card slot, you can add two 16550A ports with the
  DSP 550 card from STB Systems, (214) 234-8750. To find out what kind
  of UARTs are in your PC, use the program "msd.exe" in your MS-Windows 3.1
  install directory or retrieve the program
  /published/open-systems-today/uarttype.zip from ftp.uu.net .
  Older UARTs are the 8250 or the 16450.  These UARTs will work ok under
  MS-DOS. A fast CPU helps, though. No performance tests were run because
  three of the four packages above are still in beta.

  For more information, read the Open Systems Today article and stay
  tuned to this FAQ.

  7.2.2 MSDOS/NOVELL:
  
   Novell now offers PPP support (asynchronous) in LAN WorkPlace for DOS
    version 4.1, and PPP support for synchronous and T1 connections on
   NetWare v3.11 servers in the MultiProtocol Router WAN Links option.
    NetWare server support for the routing of IP and IPX protocols over
    asynchronous dialup lines will be available sometime around mid-1993.
   
       This is an excerpt from LWP41.TXT, a document describing LAN
   WorkPlace for DOS v4.1 (the entire text can be found on
   sjf-lwp.sjf.novell.com in ~/lwp4dos/lwp41.txt):
   

       *  SLIP (Serial Line Internet Protocol) and PPP (Point to Point
          Protocol) support.  SLIP and PPP support is provided in the form
          of a custom ODI driver for LAN WorkPlace: SLIP_PPP.COM.  This
          driver allows the Novell TCP/IP Transport for DOS v4.1 to use
          asynchronous connections for IP services required by DOS and
          Windows applications.  It supports the following:
           -  SLIP
           -  Compressed SLIP (C-SLIP) using Van Jacobson TCP/IP header
              compression (as described in RFC-1144).
           -  PPP with support for Van Jacobson TCP/IP header compression
              option negotiation and PAP (Password Authentication
              Protocol) as described in RFC-1334.
           -  Support for National Semiconductor's 16550, 16550A, 16450
              and 8250 UARTs (Universal Asynchronous Receiver
              Transmitter).  Use of a 16550 UART is strongly recommended
              (and is required for use with Windows at speeds of 9600bps
              or greater).  NOTE: One can use the Microsoft Diagnostics
              program supplied with Windows v3.1 (MSD.EXE) to determine
              which type of UART is installed in a PC.
           -  Interface speeds up to 57,600 bps when used with a
              V.32bis/V.42bis modem and 16550A UART.

        brian@novell.com (Brian Meek) clarified on my request, that:
   
        IP is the only protocol supported directly by the LAN     WorkPlace
   SLIP_PPP driver in this initial release.  One can use     the IPTUNNEL
   LAN driver (also included in LAN WorkPlace) to     encapsulate IPX in
   UDP/IP and attach to a NetWare v3.11 server     running a similar
   driver.  This "IP Tunneling" mechanism is     described in RFC 1234.
   
        Direct IPX support for this PPP driver will be added later,     but
   the current tunneling mechanism is presently more widely
   applicable... since few (if any) PPP implementations are presently
   available with support for IPX.
   
7.3 386/486 PC's with SCO Unix:

  7.3.1 SCO UNIX ODT2.0 AND LATER FOR 386/486 PC'S CONTAINS PPP.
  
  7.3.2 MORNING STAR PPP RUNS UNDER SCO UNIX AND ODT (SEE 7.4)
  
7.4 for lots of computers running some Unix derivate:

        Morning Star PPP
      
  Price:                  $795 (40% discount for .edu)
                         
    Supported systems:    Sun 4, Sun 3, NeXT, DECstation, RS/6000, SCO
                         UNIX, ISC
                         UNIX, and Silicon Graphics (for an actual complete
                         list, look at  self-description
                         
      .
      
       Features
       demand-dial, scripting, filtering, redial, header compression,
      client, server, tunneling, extra escaping, the ability to work with
      various keycard access systems that require user interaction during
      the script
      
       Self-description
      
      Morning Star claims that their async PPP and SLIP run fine over
      UNIX systems' native serial ports, with no additional hardware
      required.  For better performance, they recommend that users of
      PC-based UNIX systems install either a serial interface card based
      on the NS16550AFN UART, or a multiport "smart" card. They claim to
      do async PPP and SLIP/CSLIP as fast as the underlying UNIX supports
      (usually 38400), and to do sync PPP up to T1 (1.544Mb/s) or E1
      (Euro-T1, 2.048Mb/s) over their SnapLink. They provide
      dynamically-loadable modules for SunOS 4.1.* and NeXTStep 2.1 and
      3.0, so users needn't even reboot during the installation process.
      
       WWW
      
      http://www.morningstar.com
      
       FTP
       ftp.morningstar.com        ftp.uu.net:/vendors/MorningStar/
      
       E-mail:
       marketing@morningstar.com
      
7.5 for SUN computers running SunOS

  7.5 FOR SUN COMPUTERS RUNNING SUNOS
  
  7.5.2 BRIXTON PPP
  
   Supported systems: Sun 4
   
     Features: demand-dial
   
  7.5.3 SUNLINK PPP 1.0
  
   was announced in SunFLASH Vol 49 # 1 (January 1993)
   
  Requires                SPARC(R) system running Solaris(R) 1.x operating
                         environment  and either SunLink HSI/S or SunLink
                         MCP.
                         
   Features               supports only synchronous up to 2MB/s lines,
                         load-sharing,  dynamic routing. Only the obsolete
                         RFC1171/2 standard, but  should interoperate with
                         newer implementations.
                         
   Price                  $1,225 (media, doc, and RTU) [in the USA only]
                         
   Comment                for a necessary patch,   look at the
                         configuration section.
                         
  7.5.4 SOLARIS 2.3
  
   In article  <CDtJoB.D48@twinsun.com>, eggert@twinsun.com (Paul Eggert)
   writes:   A frequently asked question in this newsgroup is ``How can I
   get PPP working on Solaris 2.x?''  If you're willing to wait a few
   weeks, Sun will do it for you.  On Tuesday, SunSoft announced that
   Solaris 2.3 will contain PPP.  The press release says that Solaris 2.3
   ``will be generally available in early November.''
   
7.6 for NeXT

  7.6.1 MORNING STAR PPP SEE 7.4
  
   *** Go back here.  To the top page here. Read on here.
   
   
-- 
-- 
	Ignatios Souvatzis
-
Solaris 2.1:  it's slow, needs 200M of disk space and comes without C compiler,
which makes it remarkably close to MS-Windows. oleg@gd.cs.csufresno.edu
Technical Details
Message-ID: <ppp-faq/part7_755877488@cs.uni-bonn.de>
Path: arc1-ca.pugleaf.net!senator-bedfellow.mit.edu!bloom-beacon.mit.edu!gatech!howland.reston.ans.net!xlink.net!zib-berlin.de!uni-paderborn.de!urmel.informatik.rwth-aachen.de!news.rhrz.uni-bonn.de!ignatios

Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!senator-bedfellow.mit.edu!bloom-beacon.mit.edu!gatech!howland.reston.ans.net!xlink.net!zib-berlin.de!uni-paderborn.de!urmel.informatik.rwth-aachen.de!news.rhrz.uni-bonn.de!ignatios
From: ignatios@cs.uni-bonn.de (Ignatios Souvatzis)
Newsgroups: comp.protocols.ppp,news.answers,comp.answers
Subject: comp.protocols.ppp part7 of 8 of frequently wanted information
Supersedes: <ppp-faq/part7_755205601@cs.uni-bonn.de>
Followup-To: poster
Date: 14 Dec 1993 14:02:39 GMT
Organization: computer science department, university of Bonn, Germany
Lines: 250
Approved: news-answers-request@MIT.Edu
Message-ID: <ppp-faq/part7_755877488@cs.uni-bonn.de>
NNTP-Posting-Host: theory.cs.uni-bonn.de
Summary: This document contains information about the Internet Point-to-Point
 Protocol, including a bibliography, a list of public domain and
 commercial software and hardware implementations, a section on
 configuration hints and a list of frequently asked questions and
 answers on them.
 It should be read by anybody interested in connecting to Internet
 via serial lines, and by anybody wanting to post to
 comp.protocols.ppp (before he/she does it!)