Article View: comp.protocols.tcp-ip
Article #7965Re: Sequence Numbers in TCP/IP
From: Thomas Skibo
Date: Sat, 23 Jan 1993 02:45
Date: Sat, 23 Jan 1993 02:45
41 lines
2669 bytes
2669 bytes
In article <16594@auspex-gw.auspex.com>, guy@Auspex.COM (Guy Harris) writes: |> >The window is how much the other end is prepared to accept (65535 implies |> >infinite). (this is bigger than the maximum packet size on every network |> >I have ever seen) |> |> Yes, but, as far as I know, it's not required that the sending TCP stuff |> everything into one packet, and there's a "TCP Big Window" option |> mentioned in RFC1106, to increase the maximum window size beyond 64K. |> |> There's also an RFC, RFC1110, entitled "A Problem with the TCP Big |> Window Option"; both date back to mid-1989, and not being a full-time |> networking weenie, I don't know what the state of Big Windows in TCP is |> (except that I seem to remember Vernon Schryver talking about cranking |> the window size up when using FDDI, in order to light the fibre up, so I |> suspect there's at least a semi-stable standard for Big Windows). RFC 1323 is the latest RFC describing big windows. It is basically an update to RFC's 1072 (window scaling, time-stamps for rtt measurement, and selective acknowledgements) and 1185 (using the same time-stamps for rejecting old, duplicate segments). The selective acknowledgement was dropped from 1323 because it was felt that more research needed to be done. RFC 1106 was another method of getting >64K windows. I don't know much about it. The problem with big windows described in RFC 1110 (that a 32-bit sequence number isn't good enough with 30-bit windows) was addressed in RFC 1185 and refined in RFC 1323. RFC 1323 is pretty solid. SGI's next major OS release will include a TCP that can do RFC 1323 (both window scaling, and time-stamps). Vernon nearly saturates an FDDI ring with a couple of Indigos and a single TCP connection with a 60K window (no window scaling needed). But, he likes to crank up the window to 128K+ to squeeze the last 0.2 MBytes/s out. Since the "big windows" will be available soon, you'll be able to try this at home. -- --- Thomas Skibo Advanced Networking, Silicon Graphics skibo@sgi.com
Technical Details
Message-ID:
<v7evfu0@twilight.wpd.sgi.com>Path:
arc1-ca.pugleaf.net!sparky!uunet!usc!cs.utexas.edu!sun-barr!olivea!sgigate!odin!twilight!florida.wpd.sgi.com!skiboReferences:
<andreas-220193121931@i2pc5.informatik.rwth-aachen.de> <1993Jan22.142637.26110@aston.ac.uk> <16594@auspex-gw.auspex.com>Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!sparky!uunet!usc!cs.utexas.edu!sun-barr!olivea!sgigate!odin!twilight!florida.wpd.sgi.com!skibo From: skibo@florida.wpd.sgi.com (Thomas Skibo) Newsgroups: comp.protocols.tcp-ip Subject: Re: Sequence Numbers in TCP/IP Message-ID: <v7evfu0@twilight.wpd.sgi.com> Date: 23 Jan 93 02:45:51 GMT References: <andreas-220193121931@i2pc5.informatik.rwth-aachen.de> <1993Jan22.142637.26110@aston.ac.uk> <16594@auspex-gw.auspex.com> Sender: news@twilight.wpd.sgi.com ( CNews Account at twilight.wpd.sgi.com ) Organization: Silicon Graphics, Inc. Lines: 41