Article View: comp.sys.mac.apps
Article #6535Re: telnet & packet size
From: Joe Touch
Date: Tue, 06 Oct 1992 18:30
Date: Tue, 06 Oct 1992 18:30
61 lines
3186 bytes
3186 bytes
In article <22569@venera.isi.edu> touch@ISI.EDU (Joe Touch) writes:
(to follow up on my own post ;-} )
From: touch@ISI.EDU (Joe Touch)
Date: 6 Oct 92 18:13:08 GMT
References: <1992Oct06.143633.17743@bnr.ca>
Organization: USC-ISI
In article <1992Oct06.143633.17743@bnr.ca> johnh@nnshh127.uucp (John Hawkins) writes:
>Problem: > One character per packet from (mac) not host via the
wide-area-network. With ten users on the system they take up ~60% of capacity of WAN. > > >
>Question: > Is there anyway to configure either the drivers of tcp/ip
or the telnet software itself (mac side) to only send a packet
when a newline or tab character is input?
The application is made to run on any 'dumb' terminal.
In order to aggregate the packets, you'd need some kind of
*line-oriented* terminal, i.e., NOT a 'dumb' terminal, but an
'intelligent' one, e.g., the IBM series (the 4-digit numbered ones,
I don't remember the number, but 3870 or something like that seems
close).
Found it - it's an IBM 3270.
The idea is that in order to group the characters and send them out
only when a linefeed is generated, you have to have the terminal take
care of everything that happens before the linefeed. That includes
backspace erasing, and any other editing and echo. Similarly, more
complex features (such as command-line completion) are nearly
impossible, because the terminal doesn't know what the commands are.
I forgot to mention, this line-oriented mode IS part of the existing
TELNET standard, although only as elective, i.e., a 'standard'
implementation can omit them. (sort of defeats the purpose of a
standard, huh? :-} )
The two options of interest are the TOPT-DATA Data Terminal Entry
option (Option #20, Proposed, Elective, RFC 1043), and the TOPT-3270
Telnet 3270 regime (Option #29, Proposed, Elective, RFC 1041). Both
are versions of line-editing terminals, designed to overcome the
network overloading of character-based 'dumb' terminals you have
observed.
The status of these options is described in the IAB Official Protocol
Standards status RFC 1360.
These RFC's are "request for comments" memos of the Internet
Activities Board. On-line access to them is described in any general
telecommunications text, such as Tannenbaum's "Computer Networks",
Rose's "The Simple Book", Stallings' "Handbook of Computer
Communications Standards Vol. 3", etc.
Again, I hope this helps. Unfortunatly, it may mean you need a smarter
terminal.
Joe Touch
Computer Scientist / protocols, high-performance networks
USC/ Information Sciences Institute
touch@isi.edu
Technical Details
Message-ID:
<22571@venera.isi.edu>Path:
arc1-ca.pugleaf.net!sparky!uunet!dtix!darwin.sura.net!wupost!usc!isi.edu!venera.isi.edu!touchReferences:
<1992Oct06.143633.17743@bnr.ca> <22569@venera.isi.edu>Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!sparky!uunet!dtix!darwin.sura.net!wupost!usc!isi.edu!venera.isi.edu!touch From: touch@ISI.EDU (Joe Touch) Newsgroups: comp.sys.mac.apps,comp.unix.questions Subject: Re: telnet & packet size Message-ID: <22571@venera.isi.edu> Date: 6 Oct 92 18:30:44 GMT References: <1992Oct06.143633.17743@bnr.ca> <22569@venera.isi.edu> Sender: news@isi.edu Distribution: usa Organization: USC-ISI Lines: 61 In-reply-to: touch@ISI.EDU's message of 6 Oct 92 18:13:08 GMT