Article View: de.comm.gateways
Article #1198Re: MetaMail '93
From: Matthias Urlichs
Date: Mon, 04 Jan 1993 22:23
Date: Mon, 04 Jan 1993 22:23
82 lines
3693 bytes
3693 bytes
In de.comm.gateways, article <0X.54973@A-LINK-H.zer.sub.org>, gatebau@a-link-h.comlink.de writes: > Die Minimalanforderungen, die ein Gateway erfuellen muss, ist, die folgenden > Metamail-Informationen bereitzustellen: "Metamail" hat im Internet inzwischen eine andere Bedeutung. Vorsicht Begriffsverwirrung! > [...] > > References: <53CsdfgddsfgSDF@system2.do2.main2.sub.org> > > Die Message-Id's aller direkten Bezugsnachrichten (Nachrichten, auf > die hier geantwortet wird). In der Regel kann es nur eine geben (eine > Antwort bezieht sich auf genau eine Nachricht), einige Netze erlauben > aber auch Antworten auf mehrere Nachrichten in einer Message. Es ist allerdings eine sehr gute Idee, hier mehrere IDs aufzufuehren. Insbesondere sollte als erste ID die der urspruenglichen Nachricht stehenbleiben, d.h. wenn B eine Antwort auf A, C eine auf B und D auf C ist, dann sollten in der References:-Zeile von D die IDs von A und C stehen, und zwar in dieser Reihenfolge. Hauptsaechlicher Grund: Der Benutzer sagt "ich will diesen Lall nicht mehr lesen". Das Newssystem kann sich dann die ID A merken und alle Nachrichten mit A im References:-Header automatisch ueberspringen. :-) > Reply-To: user@system.do.main.de > > Antworten auf diese Nachricht gehen an die angegebene Adresse. > Bei der Angabe > > Reply-To: - > > ist keine persoenliche Antwort erwuenscht. "-" ist laut RFC822 ein erlaubter Username. Ein RFC-Mailer kann das Teil daher ungestraft domainisieren und zB "-@smurf.sub.org" draus machen. Meine Meinung dazu: Wer keine Antwort will, soll entweder gar keine Mail schreiben oder diesen Wunsch im Text zum Ausdruck bringen. > Gibt ein Haltbarkeitsdatum der Nachricht an. Nach Ablauf dieses > Datums kann die Nachricht automatisch geloescht werden. Ein > > Expires: - > > besagt, dass die Nachricht niemals automatisch geloescht werden darf. Wie auch die ganzen anderen Minusangaben ist das nicht Teil der RFCs. Das Konzept eines nie geloeschten Postings gibt es in RFC 1036 gar nicht und die meisten Admins wuerden sich auch nicht dran halten. Das Problem ist, dass dann jedr Dummuser alle seine Artikel mit "Expires: -" markiert, weil das ja so geil ist. :-( Ich will damit uebrigens nicht eure Ideen madig machen, sondern auf moegliche Probleme hinweisen. > X-Error: unknown user "karl@blah.sub.org" > > Diese Nachricht ist eine Fehlermeldung. Sollten bei der Zustellung > dieser Nachricht Fehler auftreten, ist keine automatische Mail an > den Absender zu schicken. > Wird ueber SMTP (RFC 821) durch einen leeren String im MAIL-FROM angegeben. Ausserdem stimmt die Fehlermeldung nicht. ;-) > Und wieder hat irgendein DOSseliger Texteditor seinen Schlonz mit Control-Z beendet. Grummel. -- A project can not be considered complete until the total height of the viewgraphs produced exceeds the height of the shortest PI. -- Robert Metzger, scientist and author. -- Matthias Urlichs -- urlichs@smurf.sub.org -- urlichs@smurf.ira.uka.de /(o\ Humboldtstrasse 7 -- 7500 Karlsruhe 1 -- Germany -- +49-721-9612521 \o)/
Technical Details
Message-ID:
<1iadd1INNick@smurf.sub.org>Path:
arc1-ca.pugleaf.net!sparky!uunet!zaphod.mps.ohio-state.edu!howland.reston.ans.net!sol.ctr.columbia.edu!ira.uka.de!smurf.sub.org!newsReferences:
<0X.54973@A-LINK-H.zer.sub.org>Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!sparky!uunet!zaphod.mps.ohio-state.edu!howland.reston.ans.net!sol.ctr.columbia.edu!ira.uka.de!smurf.sub.org!news From: urlichs@smurf.sub.org (Matthias Urlichs) Newsgroups: de.comm.gateways Subject: Re: MetaMail '93 Date: 4 Jan 1993 23:23:28 +0100 Organization: University of Karlsruhe, FRG Lines: 82 Message-ID: <1iadd1INNick@smurf.sub.org> References: <0X.54973@A-LINK-H.zer.sub.org> NNTP-Posting-Host: 127.0.0.1