🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: de.newusers
Article #109

<94-03-06> Headerzeilen

#109
From: Wolfgang Zenker
Date: Tue, 02 Apr 1996 00:17
209 lines
9617 bytes
Archive-name: de-newusers/headerzeilen
Posting-frequency: monthly

               Diese merkwuerdigen Headerzeilen
               ================================


Sinn und Zweck dieses Artikels:
-------------------------------
Du solltest nach der Lektuere dieses Artikels wissen, was die Header,
welche Dir Dein Newsreader beim Schreiben eines Artikels anbietet,
bedeuten und welche Du ggf. hinzufuegen koenntest. Der Artikel
erhebt keinen Anspruch auf Vollstaendigkeit, es sollen hier nur
die wichtigsten Header behandelt werden. Wenn Du mehr wissen willst:
Am Ende des Artikels findest Du Quellenangaben fuer mehr Infos,
sowie einige Hinweise fuer neue News-Administratoren.


Was ist eine Headerzeile?
--------------------------
Ein Newsartikel besteht aus Headerzeilen, gefolgt von einer Leer-
zeile und dem Artikeltext.  Headerzeilen beeinflussen den Transport,
die Speicherung und die Verarbeitung von Newsartikeln.
Die meisten Newsreader erlauben Dir, einen Artikel inklusive Header-
zeilen zu editieren. Dabei sind bestimmte Formvorschriften einzuhalten:
Headerzeilen haben unmittelbar nach dem ersten Wort einen Doppelpunkt
und nach diesem Doppelpunkt genau ein Leerzeichen, danach weitere Werte.
Einige Newssysteme verlangen darueber hinaus, dass eine Headerzeile
mit einem Grossbuchstaben beginnt.


Welche Header muessen vorhanden sein:
-------------------------------------
- Subject:
  --------
  Der Subject-Header (Betreff) soll angeben, worum es in Deinem
  Artikel geht. Viele Leser entscheiden anhand dieses Betreffs,
  ob sie Deinen Artikel lesen oder ueberspringen. Wenn Du auf
  einen anderen Artikel antwortest, wird normalerweise der
  Betreff des anderen Artikels [mit einem vorangestellten Re:]
  automatisch uebernommen. Falls sich die Diskussion in eine
  andere Richtung entwickelt, solltest Du jedoch den "Subject:"-
  Header an die veraenderte Thematik anpassen. Es ist hierbei
  ueblich, nach dem neuen Subject in Klammern (was: altes Subject)
  anzugeben ["was" ist hierbei englisch fuer "war"]. Beim Antworten
  auf einen solchen Artikel solltest Du dann die Klammer entfernen.
  [Siehe dazu auch -> Netiquette in de.newusers.]

- Newsgroups:
  -----------
  Hierhin kommt der Name der Gruppe, in die der Artikel gepostet
  wird. Ab und zu kann es sinnvoll sein, den Artikel in mehr als
  eine Gruppe zu posten. In diesem Fall gibst Du in diesem Header
  die Namen aller betroffenen Gruppen an. Die Gruppennamen muessen
  dabei jeweils durch ein Komma getrennt werden. Bitte *nicht*
  denselben Artikel in die Newsgruppen einzeln posten!

  Die Methode, mehrere Gruppennamen in diesen Header zu schreiben
  nennt man "Crossposting". Sie hat gegenueber dem "einzeln in
  mehrere Gruppen schreiben" eine Reihe von Vorteilen: Der Artikel
  wird nur einmal uebertragen, auf vielen Newssystemen steht der
  Artikeltext nur einmal auf der Platte, und viele Newsreader er-
  kennen, dass der Artikel bereits in einer anderen Gruppe gelesen
  wurde und zeigen ihn nicht nochmals in den weiteren Gruppen an.

  Achtung: nach einem trennenden Komma auf keinen Fall ein Leer-
  zeichen setzen, der Artikel wird sonst von vielen Newssystemen
  als fehlerhaft weggeworfen.

  Meist wird es sinnvoll sein, bei einem "crossgeposteten" Artikel
  die Antworten nur in eine Gruppe zu leiten. Siehe hierfuer
  den "FollowUp-To:"-Header weiter unten.

- automatisch ergaenzte Header:
  -----------------------------
  ausser den obengenannten muessen noch die Header "From:",
  "Message-ID:", "Date:" und "Path:" vorhanden sein. Diese
  werden beim Absenden automatisch erzeugt, und Du solltest
  daran nichts editieren.

  "From:" gibt den Autor des Artikels an [also Dich],
  "Date:" das Absendedatum, "Path:" den Weg, ueber welchen
  der Artikel bisher transportiert wurde, "Message-ID:"
  ist eine weltweit eindeutige Kennzeichnung des Artikels.

optionale Header:
-----------------

- Distribution:
  -------------
  Der Sinn dieses Headers ist es, die Verbreitung eines Artikels
  *einzuschraenken*. Wenn Du alle Leser einer Gruppe erreichen
  willst, dann lass diesen Header weg oder setze "world" ein.
  Beides bedeutet das gleiche, naemlich *keine* Einschraenkung.
  Welche anderen Distributions es gibt, ist eine Vereinbarungs-
  sache zwischen den Systemen, die eine Distribution austauschen.
  Frage Deinen SysAdmin nach den lokal vorhandenen Distributions.
  Eine Distribution fuer "Deutschland" *gibt es nicht*. Viele
  Systeme verwenden die Distribution "local" fuer Artikel, die
  das eigene System nicht verlassen sollen. Ein "Distribution:"-
  Header ist eine *Empfehlung* von Dir, wem dieser Artikel
  geschickt werden soll und wem nicht, Du solltest Dich aber
  nicht darauf verlassen, dass sich alle an diese Empfehlung halten.

- Organization:
  -------------
  Angabe, wem der Rechner gehoert, auf dem Du Deinen Artikel
  schreibst. Wird normalerweise automatisch eingesetzt.

- References:
  -----------
  Sollte nur existieren, wenn Du auf einen anderen Artikel
  antwortest. Hier steht die "Message-ID:" des beantworteten
  Artikels und eventuell ausserdem die Message-IDs aus der
  "References:"-Zeile, welche der beantwortete Artikel schon
  enthalten hat. Dies wird von manchen Newsreadern benutzt,
  um zu erkennen, dass sich Dein Artikel auf den beantworteten
  bezieht. Falls Deine Antwort eine neue Diskussion eroeffnet,
  solltest Du eventuell den References-Header loeschen und
  damit den Bezug zum alten Artikel loesen.
  Die References-Zeile kann u.U. sehr lang werden. Falls
  Dein System Probleme mit der Bearbeitung sehr langer Zeilen
  hat und Du die References-Zeile kuerzen willst, solltest
  Du mindestens die erste und die beiden letzten IDs stehen
  lassen.

- Followup-To:
  ------------
  Dieser Header dient der Umleitung von Antworten auf Deinen
  Artikel. Du gibst hier die Newsgruppe(n) an, in welche
  Antworten auf den Artikel gehen sollen, falls diese von
  den Gruppen im "Newsgroups:"-Header abweichen. Verwendet
  wird dies z.B. wenn Du einen Artikel in mehrere Gruppen
  schreibst, aber die Antworten in nur einer Gruppe haben
  willst, oder wenn es zu der Gruppe, in welcher der Artikel
  steht, eine separate "Diskussionsgruppe" gibt (die meistens
  die Endung ".d" traegt), wie beispielsweise "de.talk.jokes"
  fuer Witze, "de.talk.jokes.d" fuer Diskussionen darueber.

  Ein Sonderfall ist die Angabe von "poster". Dies bedeutet,
  dass Antworten nur per Mail an Dich erlaubt sind, jedoch
  keine FollowUps in den News. Leider verstehen das einige
  Newsreader-programme nicht.

- Reply-To:
  ---------
  Dieser Header dient dazu, Antworten per Mail an eine andere
  Adresse als im "From:"-Header umzuleiten, zum Beispiel weil
  die "From:"-Adresse nicht per Mail erreichbar ist.

- viele weitere mehr
  ------------------
  Es gibt noch eine Unzahl weiterer moeglicher Header, die hier
  nicht aufgefuehrt wurden. Zum Schreiben eines Artikels sind
  sie nicht noetig.


Wo erfaehrst Du mehr:
---------------------

Die Newsheader sind in den Internet-Standard-Dokumenten, den
sog. RFCs (Requests for Comment) definiert. Fuer Newsheader
relevant sind derzeit RFC 822 mit Ergaenzungen aus RFC 1123
sowie RFC 1036. Eine Einfuehrung in deutscher Sprache findet
sich auch in der Zeitschrift "iX", Ausgabe 4/92, Seite 107.


Hinweise fuer News-Administratoren:
-----------------------------------
Hier kurz die haeufigsten Konfigurationsfehler im Zusammen-
hang mit Newsheadern:

Der "Path:"-Header dient dazu, zu speichern, ueber welche
Sites ein Artikel bereits gelaufen ist, damit der Artikel
nicht nochmals zu diesen Sites geschickt wird. Das setzt
voraus, dass Deine Site hier einen *weltweit eindeutigen*
String eintraegt. Dies sollte Dein uucp-Name sein, *wenn*
dieser in der Worldmap eingetragen ist. Wenn nicht, verwende
hier bitte einen Domainnamen [so Du einen hast].

Der "Message-ID:"-Header sollte ebenfalls weltweit eindeutig
sein; darueber hinaus ist dafuer folgendes Format vorge-
schrieben: <localPart@sitename.domain>, wobei localPart eine
Reihe von Sonderzeichen, wie u. a. Klammern, Doppelpunkt und
insbesondere "@" nicht enthalten sollte. Rechts vom "@"
*muss* ein Domainname stehen. Wenn Du keinen registrierten
Domainnamen hast, sollte hier sitename.uucp eingetragen
werden.

Beim "Date:"-Header gibt es of Probleme mit Zeitzonenangaben.
Es gibt leider keine international genormte Bezeichnung
fuer europaeische Zeitzonen (ausser GMT). Unbekannte Zeit-
zonen werden von den meisten Programmen als GMT interpretiert.
Am besten funktioniert es in Deutschland, als Zeitzone "+0100"
bzw. bei Sommerzeit "+0200" einzutragen. Die Zeitzone darf
nur aus *einem* Wort bestehen, die Angabe "GMT +0100" ist
also fehlerhaft.


Danksagung:
-----------
Fuer diesen Artikel habe ich Hinweise und Anregungen von
Oliver Fink, Gert Doering, Werner Icking, Martin Sluka,
Ralf Wenk, Walter Mildenberger, Andreas Bewersdorff,
Christian-Peter Weiss und Klaus Baldermann erhalten.
Hierfuer meinen herzlichen Dank.


Gruss, Wolfgang              (wolfgang@lyxys.ka.sub.org)
Technical Details
Message-ID: <deu.new.hdr.1117@astel.de>
Path: arc1-ca.pugleaf.net!jat.de!achim

Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!jat.de!achim
From: wolfgang@lyxys.ka.sub.org (Wolfgang Zenker)
Newsgroups: de.newusers,de.newusers.questions
Subject: <94-03-06> Headerzeilen
Message-ID: <deu.new.hdr.1117@astel.de>
Reply-To: newusers@noris.net
Date: 02 Apr 96 00:17:36 GMT
Followup-To: de.newusers.questions
Approved: achim@astel.de
Supersedes: <deu.new.hdr.1116@astel.de>