Article View: demon.ip.developers
Article #349POP3 authentication
From: Mike Mann
Date: Thu, 01 Jan 1998 00:00
Date: Thu, 01 Jan 1998 00:00
31 lines
1812 bytes
1812 bytes
Life is becoming complicated for developers of POP3 clients. As well as the standard USER / PASS clear text scheme, there seem to be several alternative means of authenticating: o The APOP command defined in RFC 1939, which uses encryption based on the MD5 algorithm described in RFC 1321. o Remote Passphrase Authentication (RPA), described in http://www.compuserve.com/rpa/rpadtails.htm, which is now used by Compuserve. o Secure Password Authentication (SPA) using the AUTH command, which is the only authentication method supported by MSN's POP3 servers. I haven't been able to find any references to SPA although the POP3 AUTH command is described in RFC 1734 which refers to IMAP-AUTH which seems to be described in RFC 1730 and others. Can anyone confirm whether SPA on POP3 is indeed the mechanism described in RFC 1734 and ideally provide some further references? Any opinions on the likely take-up of the alternative authentication methods would also be appreciated. Many thanks and Seasons Greetings. Regards, Mike. -- Home: mike@kempston.demon.co.uk | kempston@netcomuk.co.uk PGP 2.6.2i public key available by mail from pgp@kempston.demon.co.uk
Technical Details
Message-ID:
<34ac1586.40831803@nntp.netcomuk.co.uk>Path:
arc1-ca.pugleaf.net!unknown!not-for-mailShow Full Headers
Complete Article Headers
X-Google-Language: ENGLISH,ASCII-7-bit X-Google-Thread: 10bb05,cbd560a8b4493a34,start X-Google-Attributes: gid10bb05,public From: mike@kempston.demon.co.uk (Mike Mann) Subject: POP3 authentication Date: 1998/01/01 Message-ID: <34ac1586.40831803@nntp.netcomuk.co.uk> X-Deja-AN: 311982982 Content-Transfer-Encoding: 7bit Content-Type: text/plain; charset=us-ascii X-Complaints-To: abuse@corp.netcom.net.uk X-Trace: taliesin.netcom.net.uk 883696050 19868 194.42.228.94 (1 Jan 1998 23:07:30 GMT) Organization: Switched on in Kempston Mime-Version: 1.0 Newsgroups: demon.ip.developers