Article View: demon.ip.developers
Article #500Re: Posting multiple messages with DIS/SN software?
From: Brian {Hamilton Kelly}
Date: Wed, 23 Apr 1997 00:00
Date: Wed, 23 Apr 1997 00:00
105 lines
6217 bytes
6217 bytes
In article <861698352snz@dottie.demon.co.uk>
glider@dottie.demon.co.uk "Michael Moliver" writes:
> {Using the 'Demon-supplied' DIS v1.29 UK DOS software with PCElm v1.11
> and SN v1.30.03.}
[Under OS/2 (like me) as you said in another message?]
> If I post a message to a newsgroup a normal outgoing message file ["nnn.TXT"]
> is generated with the lines, for example,
>
> To: mail2news@news.demon.co.uk
> Newsgroups: demon.ip.developers
There are other required lines in there to satisfy both the RFC-822 and
RFC-1036 requirements --- oh, and the article body as well, of course :-)
> in the header. The corresponding 'background' file ["nnn.WRK"] is also
> generated containing the lines
>
> news.demon.co.uk
> glider@dottie.demon.co.uk
> mail2news@news.demon.co.uk
That's (generally) called the "work" file (hence the file extension), and
contains the RFC-821 SMTP envelope details. The first line is the host
to be contacted, the second the envelope's "MAIL FROM" address, and the
third and subsequent lines all the addressees, to be used in "RCPT TO"
commands.
> If I then want to post the same message to another newsgroup, I repeat the
> process and insert the {previously saved} text of the first message into the
> second message while it is open in the editor. I then end up with two {or
> more} queued .TXT messages which only differ in what follows "Newsgroups:" in
> their headers. The .WRK files will be identical.
WHY do you want to post multiple identical messages? It's a gross waste
of bandwidth, for all concerned: you when uploading; Demon for
propagating the multiple messages to its peers; all those peers
propagating multiple copies of the same text to each of the 400,000 news
servers around the planet; each of those servers downloading copies of
each message to each of their users that take two or more of the groups.
It also is a waste of "wetware" bandwidth for those users, in that they
end up *reading* the message multiple times.
What you should instead do is CROSS-post the article; in a cross-posted
article, all the newsgroups addressed can be included in a single
Newsgroups line, and only *one* message sent: it will nevertheless be
available on each server in each of those newsgroups, for those that take
only one, and yet only one copy will travel around the world, even to
those end users that read two or more of the groups. Moreover, by
placing a suitable (list of) newsgroup name(s) in the Followup-To header,
one can arrange for a message to be visible in a number of groups, but
gather together all subsequent discussion thereon in a smaller number of
groups. To demonstrate this, I've cross-posted this response (which was
to an article originally posted only into demon.ip.developers) into
d.i.s.os2 and d.i.s.pc as well (since you're using DIS under OS/2; since
it is not really a d.i.d matter, I've directed f.u.s to d.i.s.pc ---
however, I fear I'm going to find that you also separately posted to
those newsgroups :-(
NB The list of newsgroups must not contain spaces, only commas, between
group names: however, wrapping following the usual linear whitespace
rules of RFC-822 and other standards is permitted (i.e. change to a
newline, with at least one space or tab on that new line, is treated as
if not there at all).
With a proper newsreader (such as SNews) instead of a web browser, even
wetware is not unnecessarily wasted: once you read a cross-posted article
in one newsgroup, all the other "copies" of it [1] are automatically
marked as read, so that the newsreader doesn't trouble you by
representing them.
[1] Locally in your newsbase: as I said, only one copy travels around the
world, and is stored on each news server's spool.
> Is there a way of posting a single message to multiple newsgroups in one go,
> either directly through the SN software or else by manually editing the
> "Newsgroups:" line in the header of the .TXT file to list several newsgroups
> {and/or anything in the corresponding .WRK file}?
Well, you could of course edit the .TXT file :-) But there's a MUCH
simpler method: you can edit the headers of the article directly from
within SNews (using your editor of choice), either by editing a *second*
time, or by running SNews in expert mode. SNews even presents you with
empty headers for some of the things one might want to add, such as
Followup-To, but one isn't limited to these: one could, for instance, add
the X-No-Archive: Yes header if one wanted it (since, unlike PCElm, SNews
has no capability for adding random additional header lines
automatically).
One final note: be very sure that your article is on-topic for all the
newsgroups that you're targetting (with either multiple or cross
posting): there are very few articles that can in any way justify being
posted to more than about five newsgroups, so anything greater will
probably involve accusations of spammage --- moreover, they may not even
be seen: many people set up kill files to eliminate any article that's
excessively cross-posted.
--
Brian {Hamilton Kelly} bhk@dsl.co.uk
"We've heard that a million monkeys at a million keyboards could produce
the Complete Works of Shakespeare; now, thanks to the Internet, we know
this is not true." Robert Wilensky, University of California
Technical Details
Message-ID:
<861777383snz@dsl.co.uk>Path:
arc1-ca.pugleaf.net!unknown!not-for-mailReferences:
<861698352snz@dottie.demon.co.uk>Show Full Headers
Complete Article Headers
X-Google-Language: ENGLISH,ASCII-7-bit
X-Google-Thread: 10bb05,1610410c237cc4b4
X-Google-Attributes: gid10bb05,public
X-Google-Thread: fb525,3e9f9e9a2b2ca754
X-Google-Attributes: gidfb525,public
X-Google-Thread: 140e4a,706017b6f0ca4cce,start
X-Google-Attributes: gid140e4a,public
From: bhk@dsl.co.uk (Brian {Hamilton Kelly})
Subject: Re: Posting multiple messages with DIS/SN software?
Date: 1997/04/23
Message-ID: <861777383snz@dsl.co.uk>
X-Deja-AN: 236751421
References: <861698352snz@dottie.demon.co.uk>
X-Mail2News-User: bhk@dsl.co.uk
Followup-To: demon.ip.support.pc
X-Mail2News-Path: dragnhll.demon.co.uk
Organization: Dragonhill Systems Ltd
Newsgroups: demon.ip.developers,demin.ip.supposrt.os2,demon.ip.support.pc