🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: demon.ip.developers
Article #549

Re: Protocol for getting mail from post.demon.co.uk

#549
From: Richard Clayton
Date: Fri, 04 Apr 1997 00:00
56 lines
2918 bytes
In article <yFmIRDAFRCRzEw7I@objmedia.demon.co.uk>, Snail
<snail@objmedia.demon.co.uk> writes

>My initial idea was that since SMTP was used to send the email I could
>use SMTP with the 'TURN<CRLF>' command to make the demon end of the
>connect become the sender and my end the receiver. Sadly
>post.demon.co.uk doesn't implement TURN (TURN is optional in the spec).

no one implements TURN; it is a big security headache. Demon don't
implement the rather more secure ETRN either.

>That said the email configure dialog in Turnpike sort of indicates that
>SMTP, POP and POP3 can be used...

You can arrange for email delivery to your Demon node by either running
an SMTP server or by using a POP3 client

>So I'm wondering how Turnpike (which I'm using to write this) loads its
>email.

your choice (see above)

> I'm not using POP3 at present (Indeed the POP3 code I have can't
>open port 110 on post.demon.co.uk (I don't know that it is indeed
>post.demon.co.uk if using POP3, a quick look at www.demon.net didn't
>show any pointers).

POP3 mail should be collected from pop3.demon.co.uk/110. If you run an
SMTP server then you will need to listen on port 25. A longer look at
www.demon.net would locate this information: start at www.demon.net/faq
and follow all the links!

>I've tried WWW searches on POP and POP3 specs with no luck so far.

try ftp://ftp.demon.co.uk/pub/mirrors/internic/rfc/rfc-index.txt

>So could someone please tell me what protocol I should be trying to use, 
>and if I should be talking to something other than post.demon.co.uk.
>I'd be most grateful for the pointers.

some people find clients simpler than servers, so a POP3 client may be
easier for you. Certainly in the POP3 world you have fewer obligations
to fulfill to conform to relevant STDs.

>Likewise, I'm sure I'll run into the same protocol requirements/troubles
>for news, so pointers on what demon use will be gratefully received.

NNTP is documented in RFC977, the format of messages in RFC1036, though
you should read "son-of-RFC1036" (easily found on ftp://zoo.toronto.edu)
and of course you must be familiar with RFC821, 822 and 1123 already

-- 
richard                      richard.clayton    @    T U R N P I K E .com
                                                     tel: +44 1306 732300
"Assembly of Japanese bicycle require great peace of mind" quoted in ZAMM
Technical Details
Message-ID: <2OdCsiAWmNRzEAav@turnpike.com>
Path: arc1-ca.pugleaf.net!unknown!not-for-mail
References: <yFmIRDAFRCRzEw7I@objmedia.demon.co.uk>

Show Full Headers
Complete Article Headers
X-Google-Language: ENGLISH,ASCII-7-bit
X-Google-Thread: 10bb05,b973d95685d66028
X-Google-Attributes: gid10bb05,public
From: Richard Clayton <richard@turnpike.com>
Subject: Re: Protocol for getting mail from post.demon.co.uk
Date: 1997/04/04
Message-ID: <2OdCsiAWmNRzEAav@turnpike.com>
X-Deja-AN: 230633354
Distribution: world
X-NNTP-Posting-Host: pillar.turnpike.com
References: <yFmIRDAFRCRzEw7I@objmedia.demon.co.uk>
Organization: Turnpike Ltd
Newsgroups: demon.ip.developers