Article View: demon.tech.unix
Article #48Re: Help! Intermittent PPP negotiation probs with Red & Green ROMPs
From: Mike Mann
Date: Tue, 20 Jun 2000 00:00
Date: Tue, 20 Jun 2000 00:00
57 lines
3225 bytes
3225 bytes
On 20 Jun 2000 21:05:11 GMT, nospam@merp.demon.co.uk.invalid (Julie Brandon) wrote: >Correct, my error. In the situations it was failing, it was being invoked >incorrectly, which lead to it not getting at the right set of ppp options >which meant pppd not knowing who it was or who it was calling and hence >unable to authenticate. So you've found the problem and fixed it? >>I can look up the meaning of these unrecognised options if no-one >>immediately recognises them. It's odd that Demon's end isn't >>consistent in the options it requests: if this behaviour (by Demon) >>has started recently, that may explain why your system has only just >>started to show failed connections. >I'd love to know what those options mean, is there a reference anywhere >that I could look up? Where do I start? :-) There's an introductory Web page on analysing a PPP connection log at http://www.kempston.net/solaris/ppplog.html . This is specifically for users of aspppd on Solaris but the general principles apply to any PPP. "Using and Managing PPP" by Andrew Sun, published by O'Reilly, ISBN 1-56592-321-9, is an excellent and very readable primer on PPP. RFC 1548 defines PPP and LCP. "TCP/IP Illustrated" (all 3 volumes) by W R Stevens, published by Addison-Wesley, is probably the standard work on TCP/IP but there's not much about PPP. LCP options are listed at http://www.isi.edu/in-notes/iana/assignments/ppp-numbers from which the options being sent by Demon and unrecognised by pppd appear to be: 0x00 : Vendor Specific [RFC2153] 0x11: Multilink-MRRU [RFC1717] 0x13: Multilink-Endpoint-Discriminator [RFC1717] >Yes, I also find it interesting that the options >don't appear to be completely consistant!? At least it doesn't appear to be >the cause of this failure. True. Glad you sorted it (if I've interpreted your opening remarks correctly :-) Regards, Mike. -- Solaris on Intel: http://www.kempston.net/solaris/ PGP public key available by mail from pgp@kempston.net
Technical Details
Message-ID:
<p1ovksssg5eq9hfs22bkain6k95m8n1o8b@4ax.com>Path:
arc1-ca.pugleaf.net!unknown!not-for-mailReferences:
<slrn8kva3d.i6u.nospam@merp.demon.co.uk> <i0jvksg4hjeumi2pfg9qaqqai44878vm1m@4ax.com> <slrn8kvn47.ktf.nospam@merp.demon.co.uk>Show Full Headers
Complete Article Headers
X-Google-Language: ENGLISH,ASCII-7-bit X-Google-Thread: fad9d,268c7f09ef7efed7 X-Google-Attributes: gidfad9d,public X-Google-Thread: 108f6a,268c7f09ef7efed7 X-Google-Attributes: gid108f6a,public X-Google-Thread: fac57,268c7f09ef7efed7 X-Google-Attributes: gidfac57,public From: Mike Mann <mike@kempston.net> Subject: Re: Help! Intermittent PPP negotiation probs with Red & Green ROMPs Date: 2000/06/20 Message-ID: <p1ovksssg5eq9hfs22bkain6k95m8n1o8b@4ax.com> X-Deja-AN: 636964386 Content-Transfer-Encoding: 7bit References: <slrn8kva3d.i6u.nospam@merp.demon.co.uk> <i0jvksg4hjeumi2pfg9qaqqai44878vm1m@4ax.com> <slrn8kvn47.ktf.nospam@merp.demon.co.uk> Content-Type: text/plain; charset=us-ascii X-Abuse-Info: Otherwise we will be unable to process your complaint properly X-Complaints-To: abuse@GigaNews.Com X-Trace: sv2-7Z6muKF9VwbZWS6AaBeByU08rkP5lu6gZAAA2ekfiyv7GcFw/0lkSzR4LtgKumt6ukZLvYKVGqH3AC0!q8fPjQhiWA== Organization: Switched on in Kempston Mime-Version: 1.0 NNTP-Posting-Date: Tue, 20 Jun 2000 16:38:53 CDT Newsgroups: demon.tech.unix,demon.ip.support.unix,demon.service