Article View: dnet.archiv
Article #152[ISO,X.400] PP 5.0 - der X.400 Mailer und mehr aus dem ISODE Paket
From: Michael Kuschke
Date: Fri, 21 Sep 1990 16:03
Date: Fri, 21 Sep 1990 16:03
145 lines
4951 bytes
4951 bytes
Themengebiete : ISO
Schluesselworte : X.400 Mailer, Format Konvertierung, hohes Mailaufkommen
Dateiname : /pub/network/iso/isode/pp-5.tar.Z
Groesse : 1976 kB
Vorraussetzungen : ISODE 6.0 und BSD-UNIX (BSD, SunOs, Ultrix, ...)
Erhaeltlich : per FTP auf unido.informatik.uni-dortmund.de
(129.217.64.64)
Kurzbeschreibung : PP ist der lange und mit Spannung erwartete X.400 Mailer
der nun erstmalig oeffentlich verfugbar gemacht wird
Bemerkung : PP setzt das ISODE 6.0 Paket vorraus und ist wirklich nur
was fuer Sites mit hohem Mailaufkommen und Gatewayfunktionen
Beschreibung : Es folgt die Beschreibung aus dem Original-README:
We are delighted to annonce the first public release of the
PP Message Transfer Agent.
Steve Kille + Julian Onions
A N N O U N C E M E N T
The next release of PP will be available on September 21st, 1990. This
release will be the first general public release. It is known as
PP 5.0
PP is a Message Transfer Agent, intended for high volume message
switching, protocol conversion, and format conversion. It is targeted for
use in an operational environment, but may also be useful for investigating
Message related applications. Good management features are a major
aspect of this system. PP supports the 1984 and 1988 versions of the
CCITT X.400 / ISO 10021 services and protocols. Many existing RFC 822
based protocols are supported, along with RFC 1148 conversion to X.400.
PP is an appropriate replacement for MMDF or Sendmail.
o PP is not proprietary and can be used for any purpose. The only
restriction is that suing of the authors for any damage the code may
cause is not allowed.
o PP runs on a range of UNIX and UNIX-like operating systems, in
particular: SUNOS, Ultrix, and BSD. No kernel modifications are
required.
o Current modules include:
- X.400 (1984) P1 protocol
- JNT Mail (Grey Book) Protocol
- Simple Mail Transfer Protocol (SMTP / RFC 821)
- UUCP Mail transfer
- Distribution List expansion and maintenance.
- RFC 822 based local delivery
- Delivery time processing of messages
- Conversion between X.400 and RFC 822 according to RFC 1148
and RFC 987
- Conversion support for reformatting body parts and headers.
- X-Windows based management console.
- Message Authorisation checking
- X.400 (1988) P1 protocol (beta test)
- X.500 based distribution list facility using the QUIPU directory
(beta test)
o No User Agents (UAs) are included with PP. However, procedural
access to the MTA is documented, to encourage others to write or to
port UAs. Several existing UAs, such as MH, may be used with PP.
o PP 5.0 requires ISODE 6.0. Releases of ISODE before and after 6.0
cannot be used as alternatives.
1
o X-Windows release X11R4 is neded by some of the management
tools. PP can be operated without these tools.
o Although PP is not "supported" per se (but see later), it does have a
problem reporting address:
RFC 822: PP-SUPPORT@CS.UCL.AC.UK
X.400: S=PP-Support; OU=CS; O=UCL;
PRMD=UK.AC; ADMD= ; C=GB;
Bug reports (and fixes) are welcome.
o The discussion group PP-PEOPLE@CS.UCL.AC.UK is used as an
open forum on PP; Contact
PP-PEOPLE-REQUEST@CS.UCL.AC.UK to be added to this list.
o The primary documentation for this release consists of a three and a
half volume User's Manual (approx. 300 pages) and a set of UNIX
manual pages. The sources to the User's Manual are in LaTeX
format.
For more information, contact:
Steve Kille
Department of Computer Science
University College London
Gower Street
London
WC1E 6BT
England
Michael Kuschke uucp: mk@unido.uucp
Computer Science Department - IRB BITNET: MK@DDOINF6.BITNET
University of Dortmund FAX: +49 231 755 2386
D-4600 Dortmund 50,PO-Box 500500, W.-Germany voice: +49 231 755 5135
Technical Details
Message-ID:
<mk.653932982@bilbo>Path:
arc1-ca.pugleaf.net!gmdzi!unido!laura!mk@unido.informatik.uni-dortmund.deShow Full Headers
Complete Article Headers
X-Google-Language: GERMAN,ASCII-7-bit X-Google-Thread: 11b371,9beac03aed30ed69,start X-Google-Attributes: gid11b371,public X-Google-ArrivalTime: 1990-09-22 01:36:42 PST Path: arc1-ca.pugleaf.net!gmdzi!unido!laura!mk@unido.informatik.uni-dortmund.de From: mk@bilbo.informatik.uni-dortmund.de (Michael Kuschke) Newsgroups: dnet.archiv Subject: [ISO,X.400] PP 5.0 - der X.400 Mailer und mehr aus dem ISODE Paket Keywords: X.400, Format Konvertierung, ISODE Message-ID: <mk.653932982@bilbo> Date: 21 Sep 90 16:03:02 GMT Sender: news@laura.UUCP Distribution: dnet Lines: 145 Posted: Fri Sep 21 17:03:02 1990