🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: fj.editor.emacs
Article #553

Re: emacsのMUAのrfc2231対応

#553
From: Katsumi Yamaoka
Date: Wed, 25 Aug 2004 22:46
31 lines
2381 bytes
>>>>> In <cghr1i$uri$1@zzr.yamada.gr.jp>
>>>>>	qwertyui <ziwndm@hotmail.com> wrote:

> gnusやsemiはrfc2231に対応していないのでしょうか。

Gnus は標準で添付ファイル名などの MIME パラメータを RFC2231 でエ
ンコードします。2001年4月にリリースされた Oort Gnus から対応して
います (Emacs 付属の Gnus については後述)。

SEMI を使うメール/ニュースリーダが使う FLIM には、やはり RFC2231
エンコードを行なう分派 (CVS の flim-1_14-rfc2231-encoder 枝) が
あります。

Gnus についてもう少し書くと、

リリースされた Emacs の最新版である 21.3 に付属しているものは標
準が RFC2045 エンコードであり、非 ASCII 文字のパラメータは適切に
エンコードされません。次にリリースされる Emacs に付属する Gnus
から RFC2231 になります。

ただ、RFC2231 で日本語名の添付ファイルを送っても相手が扱えないこ
とが多くて困ったので、不本意ながら RFC2047 もどきのエンコーダを
先端の No Gnus には入れてあります。これは次の Emacs 付属の Gnus
には、入れないつもりです。

そんな Gnus に関するあれこれを以下のページに書いてあるので、興味
があれば。

http://www.jpl.org/elips/Gnus-Tips-ja.html
-- 
山岡
Technical Details
Message-ID: <b9yisb6defr.fsf@jpl.org>
Path: arc1-ca.pugleaf.net!g2news1.google.com!news2.google.com!fu-berlin.de!uni-berlin.de!not-for-mail
References: <cghr1i$uri$1@zzr.yamada.gr.jp>

Show Full Headers
Complete Article Headers
X-Google-Thread: ff358,137bffc5df872a0
X-Google-Attributes: gidff358,public
X-Google-Language: Japanese,JIS
Path: arc1-ca.pugleaf.net!g2news1.google.com!news2.google.com!fu-berlin.de!uni-berlin.de!not-for-mail
From: Katsumi Yamaoka <yamaoka@jpl.org>
Newsgroups: fj.editor.emacs
Subject: Re: emacsのMUAのrfc2231対応
Date: Thu, 26 Aug 2004 07:46:00 +0900
Organization: Emacsen advocacy group
Lines: 31
Message-ID: <b9yisb6defr.fsf@jpl.org>
References: <cghr1i$uri$1@zzr.yamada.gr.jp>
Mime-Version: 1.0
Content-Type: text/plain; charset=iso-2022-jp
X-Trace: news.uni-berlin.de +gU2qB0uxmYUB1nFPYi7lw1RjQOvKjEYsfjaW2srp7514TPh4=
X-Face: #kKnN,xUnmKia.'[pp`;Omh}odZK)?7wQSl"4o04=EixTF+V[""w~iNbM9ZL+.b*_CxUmFk
 B#Fu[*?MZZH@IkN:!"\w%I_zt>[$nm7nQosZ<3eu;B:$Q_:p!',P.c0-_Cy[dz4oIpw0ESA^D*1Lw=
 L&i*6&(
User-Agent: Gnus/5.1006 (Gnus v5.10.6) Emacs/21.3.50 (gnu/linux)
Cancel-Lock: sha1:HnrdPEG74AjdqcDMAqrlaI00iT8=