🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: fj.net.mime
Article #240

Re: Tips for E-Mail ver 6.0beta

#240
From: TANAKA Goh
Date: Fri, 06 Dec 1996 00:00
77 lines
3378 bytes

>>>>> "岩崎" == Hiroshi Iwasaki <iwasaki@ed.kanazawa-u.ac.jp> writes:

岩崎> 岩崎@元記事の著者です。

会社を 2 日程休んでいたので遅くなりました。

岩崎> 元記事の記述は適切と考えてよろしいでしょうか。もし不適切なら削除します
岩崎> し、注意書きが必要なら付けますが。

元記事の記述とは

| それでも漢字を使いたいときは「半角」のローマ文字と併記しましょう。
|       Subject: subject in alphabet / 漢字の題名
| こうすれば、万が一、漢字の部分が読めなくても大丈夫です。

ですよね。

<57vst3$25sr@daphnis.yamato.ibm.com> にも書いた通り、僕はこ
れを

  Subject: subject in alphabet / =?ISO-2022-JP?B?GyRCNEE7eiROQmpMPhsoQg==?=

のようにエンコードするべきだと思いますが、``漢字の題名'' だ
けでなく、``subject in alphabet / 漢字の題名'' をまとめてエ
ンコードしてしまっても RFC 的には問題ないと思います。

実際には、多くの実装が RFC1522 にも従っていなくて、RFC1342 
ベースであるがために

  Subject: Japanese/日本語

という記述が元記事のような意味で通用しているわけですが、
RFC2047 は 8. Examples にも見られるように、RFC1522 以前の曖
昧さはほとんどなくなっているので、MIME Part Three が RFC に
なったことで

  Subject: Japanese/日本語

を

  Subject: =?ISO-2022-JP?B?SmFwYW5lc2UvGyRCRnxLXDhsGyhC?=

のようにエンコードする UA が、今後は増えていくのではないかと
思います。

そういうわけで、いろいろと意見はわかれるでしょうが、個人的に
は元記事の記述は削除しておいた方が良いと思います。

#本当は、皆が encoded-word を decode できると幸せだと思うの
#ですけど… (^_^;

岩崎> 「すべてのメーラでうまくいくわけではありません。」と書くぐらいなら削除
岩崎> した方が混乱が起きないかもしれませんね。

そうですね。

たた、Microsoft	Internet Mail & News や Mozilla が作成する 
encoded-word は RFC2047 に従っているというわけではなく、それ
以前に規格に反するところが多過ぎるので、こういうおかしな実装
を前提にして考える必要は全くないと思います。

RFC2047 に従って、text, ctext, word を最小単位として 
encoded-word を普通に作成すれば、

  Subject: subject in alphabet / 漢字の題名

は

  Subject: subject in alphabet / =?ISO-2022-JP?B?GyRCNEE7eiROQmpMPhsoQg==?=

になるのじゃないの (^_^) というのが僕の理解であり、主張でも
あります。
--
日本アイ・ビー・エム(株)    ワークグループ開発  田中 剛
E-mail: goh@yamato.ibm.co.jp
Technical Details
Message-ID: <587rk0$17vm@daphnis.yamato.ibm.com>
Path: arc1-ca.pugleaf.net!unknown!not-for-mail
References: <r9nhgm5xpxy.fsf@silicon.jaist.ac.jp> <57um9l$iqq@monaco.csl.rdc.toshiba.co.jp> <57vst3$25sr@daphnis.yamato.ibm.com> <582kvv$5pc@icews5.ipc.kanazawa-u.ac.jp>

Show Full Headers
Complete Article Headers
X-Google-Language: Japanese,JIS
X-Google-Thread: 100bbf,7220d506efff5172
X-Google-Attributes: gid100bbf,public
From: TANAKA Goh <goh@yamato.ibm.co.jp>
Subject: Re: Tips for E-Mail ver 6.0beta
Date: 1996/12/06
Message-ID: <587rk0$17vm@daphnis.yamato.ibm.com>
X-Deja-AN: 202608139
x-pgp-fingerprint: 42 FF 63 EA BC 0C 4C 41  83 C2 04 2D 25 C6 05 26
references: <r9nhgm5xpxy.fsf@silicon.jaist.ac.jp>  <57um9l$iqq@monaco.csl.rdc.toshiba.co.jp>  <57vst3$25sr@daphnis.yamato.ibm.com> <582kvv$5pc@icews5.ipc.kanazawa-u.ac.jp>
content-type: text/plain; charset=ISO-2022-JP
organization: IBM Japan, Ltd.
mime-version: 1.0 (generated by tm-edit 7.94)
newsgroups: fj.net.mime