Article View: fj.net.mime
Article #49encode filename
From: ι£―ε³Άζε /Iijima Akihiro
Date: Wed, 30 Sep 1998 00:00
Date: Wed, 30 Sep 1998 00:00
63 lines
3262 bytes
3262 bytes
MIME$B$N(B multipart$B$G(B $B$G%U%!%$%k$rE:IU$9$k$H(B
$B$3$N$h$&$KCf$K%X%C%@ItJ,$,$G$-$^$9$,!"(B
Content-type: image/x-MS-bmp;
name="=?iso-2022-jp?B?GyRCJU0lLyU/JSQbKEIuYm1w?="
Content-Disposition: attachment; filename="
=?iso-2022-jp?B?GyRCJU0lLyU/JSQbKEIuYm1w?="
Content-transfer-encoding: base64
Content-Description: Windows Bitmap
$B$=$3$G(B name= $B$H$+(B filename= $B$H$$$&ItJ,$,$"$C$F(B
$B%U%!%$%kL>$,F~$C$?$j$7$^$9!#(B
$B85$N%U%!%$%kL>$,F|K\8l$N$H$-$K(B $B$3$NItJ,$,(B
MIME$BJQ49(B(encoded-word)$B$5$l$?%U%!%$%kL>$,$D$$$?$j(B
MIME$BJQ49$5$l$:$KF|K\8l$N$^$^$@$C$?$j(B
$B%a!<%i$K$h$C$F$^$A$^$A$G$9!#(B
$B$3$l$O(B RFC$B$G$O(B $B$I$A$i$,@5$7$$$N$G$7$g$&$+!)(B
$B!v!v!v(B
$BD4$Y$F8+$k$H(B MIME$B$N(B RFC$B$O(B
2045 Multipurpose Internet Mail Extensions (MIME) Part One: Format of
Internet Message Bodies. N. Freed & N. Borenstein. November 1996.
(Format: TXT=72932 bytes) (Obsoletes RFC1521, RFC1522, RFC1590)
(Updated by RFC2184, RFC2231) (Status: DRAFT STANDARD)
2046 Multipurpose Internet Mail Extensions (MIME) Part Two: Media
Types. N. Freed & N. Borenstein. November 1996. (Format: TXT=105854
bytes) (Obsoletes RFC1521, RFC1522, RFC1590) (Status: DRAFT STANDARD)
2047 MIME (Multipurpose Internet Mail Extensions) Part Three: Message
Header Extensions for Non-ASCII Text. K. Moore. November 1996.
(Format: TXT=33262 bytes) (Obsoletes RFC1521, RFC1522, RFC1590)
(Updated by RFC2184, RFC2231) (Status: DRAFT STANDARD)
2048 Multipurpose Internet Mail Extensions (MIME) Part Four:
Registration Procedures. N. Freed, J. Klensin & J. Postel. November
1996. (Format: TXT=45033 bytes) (Obsoletes RFC1521, RFC1522, RFC1590)
(Also BCP0013) (Status: BEST CURRENT PRACTICE)
2049 Multipurpose Internet Mail Extensions (MIME) Part Five:
Conformance Criteria and Examples. N. Freed & N. Borenstein. November
1996. (Format: TXT=51207 bytes) (Obsoletes RFC1521, RFC1522, RFC1590)
(Status: DRAFT STANDARD)
$B$3$N(B 5$B$D$N$h$&$G$9$,!"(Brfc2047$B$r$_$k$H(B $BCfDx$G(B
5. Use of encoded-words in message headers
+ An 'encoded-word' MUST NOT be used in parameter of a MIME
Content-Type or Content-Disposition field, or in any structured
field body except within a 'comment' or 'phrase'.
$B$H=q$$$F$"$j$^$9!#(B
Content-Type $B$d(B Content-Disposition $B$H$$$&(B field$B$G$O(B
encoded-word $B$r;H$C$F$O(B $B$$$1$J$$(B
$B$H(BRFC$B$O8@$C$F$$$k$s$G$9$h$M!)(B
--
$BEl5~9)6HBg3X(B $BAm9g>pJs=hM}%;%s%?!<(B $B%M%C%H%o!<%/%7%9%F%`1?MQ3](B
$BHSEg(B $B><Gn(B (Akihiro Iijima) aki@noc.titech.ac.jp
Technical Details
Message-ID:
<AKI.98Sep30152244@nocs3.noc.titech.ac.jp>Path:
arc1-ca.pugleaf.net!unknown!not-for-mailShow Full Headers
Complete Article Headers
X-Google-Language: Japanese,JIS X-Google-Thread: 100bbf,4f043a51eb3ae7a6,start X-Google-Attributes: gid100bbf,public X-Google-Thread: 10a13d,4f043a51eb3ae7a6,start X-Google-Attributes: gid10a13d,public From: aki@noc.titech.ac.jp (ι£―ε³Άζε /Iijima Akihiro) Subject: encode filename Date: 1998/09/30 Message-ID: <AKI.98Sep30152244@nocs3.noc.titech.ac.jp> X-Deja-AN: 396247815 Organization: Network Operation Center, Tokyo Institute of Technology, Japan. Newsgroups: fj.net.mime,fj.mail.reader