πŸš€ go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: fj.net.mime
Article #51

Re: encode filename

#51
From: 飯峢昭博 /Iijima Akihiro
Date: Wed, 30 Sep 1998 00:00
45 lines
2367 bytes
$B$9$s$^$;$s(B $B65$($F$/$@$5$$!#(B

> $BF|K\8l$rF~$l$k$H$$$&0UL#$G$O$I$A$i$b$^$A$,$$$G$9!#(B
> US-ASCII $B0J30$NJ8;z$r(B parameter $B$K;H$&J}K!$O(B RFC2231 $B$G7h$^$C$F$$$^$9!#(B

 Content-type: image/x-MS-bmp;
      name="=?iso-2022-jp?B?GyRCJU0lLyU/JSQbKEIuYm1w?="
 Content-Disposition: attachment;
      filename="=?iso-2022-jp?B?GyRCJU0lLyU/JSQbKEIuYm1w?="
 
$B$3$N(B name$B$d(B filename$B$O(B MIME$B$N@bL@$G$NMQ8l$G$$$&$H(B $B$J$K$KAjEv$9$k$N$G$7$g(B
$B$&$+!)(B

$B;d$O(B
  Content-type: image/x-MS-bmp; name="??????"
$B$3$N#19TA4BN$O(B RFC2045$B$h$j(B
    (2)   A Content-Type header field, generalized from RFC 1049,
          which can be used to specify the media type and subtype
          of data in the body of a message and to fully specify
          the native representation (canonical form) of such
          data.
$B$H$+(B
5.  Content-Type Header Field
$B$K=q$$$F$"$k$N$G(B $B$?$/$5$s<oN`$N$"$k(Bheader$B$NCf$N(B $B$R$H$D!"(B
multipart$B$N>l9g$G$b(B $B$=$NCf$N(B1$B$D$N(Bpart$B$G8+$?>l9g$K$O(B $B$=$N(B header$BItJ,$K(B
$B8=$l$k$b$N(B $B$H;W$C$F$$$^$7$?!#(B

$B$3$N(B 1$B9TA4BN$N$3$H$O(B
  Content-Type Header Field
$B$H8F$Y$P$$$$$N$G$7$g$&$+!)(B



$B$G(B $B$3$NItJ,!"(B name="??????" $B$@$1$r<($9>l9g$O!"(B
5.1.  Syntax of the Content-Type Header Field
     content := "Content-Type" ":" type "/" subtype
                *(";" parameter)
                ; Matching of media type and subtype

parameter $B$H8F$V$N$,$$$$$N$G$7$g$&$+!)(B

$B$H$j$"$($:(B $B$3$3$^$G!#(B
--
$BEl5~9)6HBg3X(B $BAm9g>pJs=hM}%;%s%?!<(B $B%M%C%H%o!<%/%7%9%F%`1?MQ3](B
	$BHSEg(B $B><Gn(B (Akihiro Iijima) aki@noc.titech.ac.jp
Technical Details
Message-ID: <AKI.98Sep30185956@nocs3.noc.titech.ac.jp>
Path: arc1-ca.pugleaf.net!unknown!not-for-mail
References: <AKI.98Sep30152244@nocs3.noc.titech.ac.jp> <rsqyar2vxr3.fsf@crane.jaist.ac.jp>

Show Full Headers
Complete Article Headers
X-Google-Language: Japanese,JIS
X-Google-Thread: 100bbf,4f043a51eb3ae7a6
X-Google-Attributes: gid100bbf,public
X-Google-Thread: 10a13d,4f043a51eb3ae7a6
X-Google-Attributes: gid10a13d,public
From: aki@noc.titech.ac.jp (飯峢昭博 /Iijima Akihiro)
Subject: Re: encode filename
Date: 1998/09/30
Message-ID: <AKI.98Sep30185956@nocs3.noc.titech.ac.jp>
X-Deja-AN: 396286631
References: <AKI.98Sep30152244@nocs3.noc.titech.ac.jp> <rsqyar2vxr3.fsf@crane.jaist.ac.jp>
Organization: Network Operation Center, Tokyo Institute of Technology, Japan.
Newsgroups: fj.net.mime,fj.mail.reader