Article View: fj.net.mime
Article #92Re: 『Re: Re: 』の件(Re: 田中さんってどういう人?(ナ)
From: Tanaka Akira
Date: Sat, 04 Apr 1998 00:00
Date: Sat, 04 Apr 1998 00:00
51 lines
3080 bytes
3080 bytes
In article <24006.891308061@rananim.ie.u-ryukyu.ac.jp>,
kono@ie.u-ryukyu.ac.jp (Shinji Kono) writes:
> えーと、=??=のあとの空白ってデコードする時に消すんじゃなかったかな。
それって RFC1342 の話ですね。
RFC1522(および RFC2047)では, encoded-word 間の空白を消すように変わって
います。
つまり, encoded-word 直後に空白があってもその後が encoded-word でなけ
れば空白は残ります。従って「いろはABC」で「いろは」だけをエンコードす
れば余計な空白が入ってしまいます。
> でも、ABCD=? ってやってはいけないわけ?
RFC2047 ではやってはいけないことになってます。
(だからといって, 世の中の実装がそうなっているか, というと必ずしもそう
ではないのですが。)
(1) An 'encoded-word' may replace a 'text' token (as defined by RFC 822)
in any Subject or Comments header field, any extension message
header field, or any MIME body part field for which the field body
is defined as '*text'. An 'encoded-word' may also appear in any
user-defined ("X-") message or body part header field.
Ordinary ASCII text and 'encoded-word's may appear together in the
same header field. However, an 'encoded-word' that appears in a
header field defined as '*text' MUST be separated from any adjacent
'encoded-word' or 'text' by 'linear-white-space'.
注: おそらく, 最後の 'text' は空白を除いたものだと思う。たぶん。
> それはいけませんねぇ...
何考えて決めたんでしょうねぇ。空白で区切らなければならないっていうのは,
どう考えても利点より欠点が多いよなぁ。
> Subject: Re: =?.....?=
>
> とするわけね。それはそれで合理的だと思います。問題は、一分の
> 不合理的なencodingなんだけど... 結局、decodeしてからparse す
> るしかないような気もする。MIMEの規格がたこなので、そうせざる
> を得ないってことですよね。いまさら、Re: に対する扱いを決めて
> も手遅れか....
必要最小限のエンコードを行なう, というつつましい方針で作られている限り
問題はなかったんですけどねぇ。
--
[田中 哲][たなか あきら][Tanaka Akira]
Technical Details
Message-ID:
<rsqyaxmrhmn.fsf@carbon.jaist.ac.jp>Path:
arc1-ca.pugleaf.net!unknown!not-for-mailReferences:
<rsqlntvgg7t.fsf@carbon.jaist.ac.jp> <24006.891308061@rananim.ie.u-ryukyu.ac.jp>Show Full Headers
Complete Article Headers
X-Google-Language: Japanese,JIS X-Google-Thread: 100bbf,cd8874228a716aeb X-Google-Attributes: gid100bbf,public X-Google-Thread: f4393,cd8874228a716aeb X-Google-Attributes: gidf4393,public From: Tanaka Akira <akr@jaist.ac.jp> Subject: Re: 『Re: Re: 』の件(Re: 田中さんってどういう人?(ナ) Date: 1998/04/04 Message-ID: <rsqyaxmrhmn.fsf@carbon.jaist.ac.jp> X-Deja-AN: 340553062 References: <rsqlntvgg7t.fsf@carbon.jaist.ac.jp> <24006.891308061@rananim.ie.u-ryukyu.ac.jp> Content-Type: text/plain; charset=ISO-2022-JP X-Emacs: Emacs 20.2, MULE 3.0 (MOMIJINOGA) Organization: JAIST, Hokuriku; Tatsunokuchi, Nomi, Ishikawa, Japan Mime-Version: 1.0 (generated by SEMI 1.2.0 - "Nishiizumi") Newsgroups: fj.net.mime,fj.news.reader.msin