Thread View: fj.net.www
3 messages
3 total messages
Started by I. Taku
Mon, 08 Apr 2002 15:20
HTMLのmailto:に関する質問
Author: I. Taku
Date: Mon, 08 Apr 2002 15:20
Date: Mon, 08 Apr 2002 15:20
20 lines
1646 bytes
1646 bytes
いとうと申します。 HTMLについての質問なのですが、このグループで不適切であればお許し 下さい。 HTMLを書いていて、疑問に思ったのですが、メールの宛て先へのリンク、 例えば、 <a href="mailto:hogehoge@hogehoge.co.jp">メールはここへ</a> についてですが、このmailto:というのは、HTMLの正式な仕様なのでしょう か? W3CのHTML4.01仕様書を調べたのですが、小生の力量不足でmailto:に関 する記述を見つけることはできませんでした。 また、書き方として、 <a href="mailto: hogehoge@hogehoge.co.jp">メールはここへ</a> のように、mailto:とメールアドレスの間に半角スペースを空けるのは間違っ た書き方なのでしょうか? よろしくお願いします。
Re: HTMLのmailto:に関する質問
Author: 中内英裕
Date: Mon, 08 Apr 2002 17:27
Date: Mon, 08 Apr 2002 17:27
17 lines
1604 bytes
1604 bytes
HTMLの仕様書をよく読めば分かりますが、A要素のHREF属性の値はURIであること が要求されています。URIに関する仕様書がRFC1630であることも記述されていま す。 問いに対する答 mailto:xxx@yyy.domain はURIに適合しています。 mailto: xxx@yyy.domain では、URIに適合していません。 -- 中内英裕 mailto:hidehiro.nakauchi@nifty.ne.jp
Re: HTML$B$N(Bmailto:$B$K4X$9$k<ALd(B
Author: Masayasu Ishikawa
Date: Tue, 09 Apr 2002 05:44
Date: Tue, 09 Apr 2002 05:44
25 lines
2086 bytes
2086 bytes
$B;d$N5-21$,3N$+$J$i$P!"(BJST $B;~4V(B2002$BG/(B04$B7n(B09$BF|(B($B2P(B) 02$B;~(B27$BJ,(B40$BIC:"!"(B
fj.net.www $B$N(B <a8sjuc$n6g$1@mariners.mctv.jp> $B$N5-;v$K$*$$$F(B
hidehiro.nakauchi@nifty.ne.jp $B$5$s$O=q$-$^$7$?!#(B
>HTML$B$N;EMM=q$r$h$/FI$a$PJ,$+$j$^$9$,!"(BA$BMWAG$N(BHREF$BB0@-$NCM$O(BURI$B$G$"$k$3$H(B
>$B$,MW5a$5$l$F$$$^$9!#(BURI$B$K4X$9$k;EMM=q$,(BRFC1630$B$G$"$k$3$H$b5-=R$5$l$F$$$^(B
>$B$9!#(B
$B$=$l$O@53N$J@bL@$G$O$"$j$^$;$s!#(BHTML 4.01 $B$N(B "6.4 URIs" [1] $B$O(B
This specification uses the term URI as defined in [URI]
(see also [RFC1630]).
$B$HDj5A$7$F$$$^$9!#$G!"(B[URI] $B$,;2>H$7$F$7$F$$$k$N$O(B RFC 2396
$B$G$9(B [2]$B!#(BRFC 1630 $B$O(B informative $B$J(B "see also" $B$G$"$C$F(B
normative $B$G$O$"$j$^$;$s(B [3]$B!#(B
[1] http://www.w3.org/TR/html401/types.html#h-6.4
[2] http://www.w3.org/TR/html401/references.html#ref-URI
[3] http://www.w3.org/TR/html401/references.html#ref-RFC1630
--
Masayasu Ishikawa
# $B$=$l$h$j(B RFC 1808 $B$r;2>H$9$k$N$O$$$$2C8:;_$a$FM_$7$$(B > HTML 4
Thread Navigation
This is a paginated view of messages in the thread with full content displayed inline.
Messages are displayed in chronological order, with the original post highlighted in green.
Use pagination controls to navigate through all messages in large threads.
Back to All Threads