🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: gnu.emacs.gnus
Article #708

Bug fix for a couple of 3.10 problems

#708
From: Masanobu UMEDA
Date: Thu, 17 Nov 1988 08:42
42 lines
2178 bytes
   Date: 16 Nov 88 14:32:45 GMT
   From: flab!fgw!uunet!triceratops.cis.ohio-state.edu!karl  (Karl Kleinpaste)
   Organization: OSU

   First, in the Path: header, We Believe In Domains, and we like all
   host references to show up with fully-qualified domain names.

   Actually, I would argue that GNUS shouldn't be messing with Path: at
   all, since Path: is correctly created by whichever version of inews is
   in use.  A similar thought applies to Message-Id; why does GNUS
   bother, when inews builds a correct Message-Id?

RFC977 said:

** If posting is permitted, the article should be presented in the
** format specified by RFC850, and should include all required header
** lines.

RFC1036 (which obsoletes RFC850) said:

**                     The required header lines are "From", "Date",
** "Newsgroups", "Subject", "Message-ID", and "Path".

That's why GNUS does it by itself.

   Second, since inews (both NNTP and local, direct versions) include
   .signature files, it seems inappropriate for GNUS to include them as
   well, since it will cause doubled signature inclusions.
   Per-distribution .signatures might be nice, but they rather conflict
   with normal inews activities.

An NNTP inews appends .signature unconditionally. That's why you get
confused. At least, I have no problems with posting with POST command
of NNTP and real local inews.

Do I have to introduce new variable, gnus-append-signature-p or
something like that?

Masanobu UMEDA
umerin@flab.flab.Fujitsu.JUNET
umerin%flab.flab.Fujitsu.JUNET@uunet.uu.NET
Technical Details
Message-ID: <8811170842.AA01254@photon.stars.flab.fujitsu.junet>
Path: arc1-ca.pugleaf.net!utzoo!utgpu!watmath!uunet!tut.cis.ohio-state.edu!UUNET.UU.NET!kddlab!photon.stars.flab.fujitsu.junet!umerin
References: <KARL.88Nov16093245@triceratops.cis.ohio-state.edu>

Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!utzoo!utgpu!watmath!uunet!tut.cis.ohio-state.edu!UUNET.UU.NET!kddlab!photon.stars.flab.fujitsu.junet!umerin
From: kddlab!photon.stars.flab.fujitsu.junet!umerin@UUNET.UU.NET (Masanobu UMEDA)
Newsgroups: gnu.emacs.gnus
Subject: Bug fix for a couple of 3.10 problems
Message-ID: <8811170842.AA01254@photon.stars.flab.fujitsu.junet>
Date: 17 Nov 88 08:42:44 GMT
References: <KARL.88Nov16093245@triceratops.cis.ohio-state.edu>
Sender: daemon@tut.cis.ohio-state.edu
Reply-To: info-gnus-english@tut.cis.ohio-state.edu
Distribution: gnu
Organization: The Internet
Lines: 42