Article View: gnu.emacs.vm.bug
Article #268Re: mbox format problem
From: Uday Reddy
Date: Sun, 13 Feb 2011 09:47
Date: Sun, 13 Feb 2011 09:47
39 lines
2831 bytes
2831 bytes
On 2/12/2011 7:24 PM, José Manuel García-Patos wrote:
> Uday Reddy<uDOTsDOTreddy@cs.bham.ac.uk> writes:
>
>> The VM code is in the function vm-find-leading-message-separator in
>> the file vm-folder.el. All that it looks for is "From " at the
>> beginning of the line and some sequence of digits at the end of the
>> line. The RFC 4155 is unfortunately very loose. It doesn't guarantee
>> the leading separator line to be a particular format. So, VM can't
>> assume too much about the format of the separator line.
>
> Given the RFC says that there has to be an email address «conformant with
> the "addr-spec" syntax from RFC 2822», couldn't the regexp in
> vm-find-leading-message-separator be something more like the following?
>
> "^From .+@.+ .+ [+-]?[0-9][0-9][0-9][0-9]$"
>
> That would eliminate most, though probably not all, false positives.
After looking at the RFC 4122 more closely, I notice that it defines a
"default" mbox format that is more tightly defined. This RFC came out
only in 2005, it seems, and then too it is only an "informational" RFC,
not a standard. So, if we want compatibility with other mail tools, we
cannot depend on it.
My Thunderbird folders have leading separator lines like the following:
From - Sun Oct 03 00:20:05 2010
VM itself produces separator lines like this:
From VM Mon Feb 6 16:51:47 2006
Neither of these would satisfy your syntax.
There could be value in defining a new mbox type for VM that is RFC
4122-compliant. I will think about it.
Cheers,
Uday
Technical Details
Message-ID:
<4D57A8B0.9010105@cs.bham.ac.uk>Path:
arc1-ca.pugleaf.net!g2news1.google.com!news3.google.com!news2.google.com!news.glorb.com!dotsrc.org!filter.dotsrc.org!news.dotsrc.org!not-for-mailReferences:
<8739nuxoil.fsf@cervantes.cervantes.es> <4D55C927.40404@cs.bham.ac.uk> <87r5bdvyxi.fsf@cervantes.cervantes.es>Show Full Headers
Complete Article Headers
X-Google-Thread: f6829,681143edebf5735e X-Google-NewGroupId: yes X-Google-Attributes: gida16957f451,domainid0,public,usenet X-Google-Language: ENGLISH,UTF8 Path: arc1-ca.pugleaf.net!g2news1.google.com!news3.google.com!news2.google.com!news.glorb.com!dotsrc.org!filter.dotsrc.org!news.dotsrc.org!not-for-mail Message-ID: <4D57A8B0.9010105@cs.bham.ac.uk> Date: Sun, 13 Feb 2011 09:47:28 +0000 From: Uday Reddy <uDOTsDOTreddy@cs.bham.ac.uk> User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7 MIME-Version: 1.0 Newsgroups: gnu.emacs.vm.bug To: José Manuel García-Patos <jmgarciap@madrid.uned.es> Subject: Re: mbox format problem References: <8739nuxoil.fsf@cervantes.cervantes.es> <4D55C927.40404@cs.bham.ac.uk> <87r5bdvyxi.fsf@cervantes.cervantes.es> In-Reply-To: <87r5bdvyxi.fsf@cervantes.cervantes.es> Content-Type: text/plain; charset=UTF-8; format=flowed Content-Transfer-Encoding: 8bit Lines: 39 Organization: SunSITE.dk - Supporting Open source NNTP-Posting-Host: 92.232.137.113 X-Trace: news.sunsite.dk DXC=;fPZRdoDgP58NX=BCM0\c1YSB=nbEKnk;P^4KGf[6iN0^H_C>[:W;B6UdS?DZIH?U16E]45i7E1P1iLQiXd?DWb7G[N=S<g]Z5<dD][fHGBS;9 X-Complaints-To: staff@sunsite.dk