🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: gnu.emacs.vm.bug
Article #9550

vm busting digests

#9550
From: Kyle Jones
Date: Wed, 29 May 1991 01:58
25 lines
1858 bytes
Arnaldo Mandel writes:
 > 	I have been using vm-4.41 for a while, and was quite happy with it.
 > Recently, some digests I receive have become undigestible.  Looks like there
 > was a change in the digest format which confuses vm. I tried something newer,
 > and installed version 5.31.  It is working fine, except for the same problem.
 > That is, when a digest is burst, it really goes to pieces, with some messages
 > being taken apart as several messages, and the beginning and end of the text
 > not being recognized.
 > 	Should anybody (Kyle?) care tackling this bug, I can mail a copy of
 > one of these digests, so the nature of the bug can be checked.

VM currently demands RFC 934 compliant digest.  If you give
vm-burst-digest a prefix arg, it will allow for some slop in the
format.  Otherwise non-conformant digests will be split in
strange places.  In the works are VM support for RFC 1153 and RFC
1154 digests.

RFC 1153 is basically a codification of existing practice, as far
as Internet digests are concerned.  While I don't think it is as
useful as RFC 934, it is at long last something that's _written_,
so implementors no longerhave to guess.

RFC 1154 actually is a proposal for general encoding of different
message types on the Internet.  I can see multi-media documents
being shipped using the RFC 1154 form.
Technical Details
Message-ID: <9105290158.AA23449@wendy-fate.UU.NET>
Path: arc1-ca.pugleaf.net!gmdzi!unido!mcsun!uunet!wendy-fate.uu.net!bug-vm
References: <9105272034.AA08639@relay1.UU.NET>

Show Full Headers
Complete Article Headers
X-Google-Language: ENGLISH,ASCII-7-bit
X-Google-Thread: f6829,2d2d26a9fc5b397a
X-Google-Attributes: gidf6829,public
X-Google-ArrivalTime: 1991-05-29 01:34:54 PST
Path: arc1-ca.pugleaf.net!gmdzi!unido!mcsun!uunet!wendy-fate.uu.net!bug-vm
From: kyle@uunet.uu.net (Kyle Jones)
Newsgroups: gnu.emacs.vm.bug
Subject: vm busting digests
Message-ID: <9105290158.AA23449@wendy-fate.UU.NET>
Date: 29 May 91 01:58:04 GMT
References: <9105272034.AA08639@relay1.UU.NET>
Sender: bug-vm-request@uunet.uu.net
Lines: 25