🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: net.lan
Article #998

Re: List of ethernet protocol numbers wanted

#998
From: Walter R. Underwood
Date: Wed, 19 Mar 1986 20:49
93 lines
4748 bytes
The numbers are listed in RFC-960, "Assigned Numbers".  This is availabe
for FTP from SRI-NIC.  Get the file "RFC:RFC960.TXT".  A couple of times
a year, a new version of "Assigned Numbers" is published, with a new
RFC number.  RFC-960 was published in December 1985.

I've removed a few blank lines in the two pages below.

wunder

-----------------------

Assigned Numbers                                                 RFC 960
IEEE 802 SAP Numbers


                    IEEE 802 SAP NUMBERS OF INTEREST

   Some of the networks of all classes are IEEE 802 Networks.  These
   systems may use a Service Access Point field in much the same way the
   ARPANET uses the "link" field.  For further information and SAP
   number assignments, please contact: Mr. Maris Graube, Chairman, IEEE
   802, Route 1, 244 H, Forest Grove, Oregon, 97116.

   Assignments:

      Service Access Point               Description          References
      --------------------               -----------          ----------
      decimal  binary
        127   01111111                   ISO DIS 8473              [JXJ]
         96   01100000                   DOD IP              [39,91,JBP]

   The IEEE 802.3 header does not have a type field to indicate what
   protocol is used at the next level.  As a work around for this
   problem, one can put the Ethernet type field value in the IEEE 802.3
   header's length field and use the following test to determine the
   appropriate processing on receipt.

   If the value in the length field of the IEEE 802.3 header is greater
   than the Ethernet maximum packet length, then interpret the value as
   an Ethernet type field.  Otherwise, interpret the packet as an IEEE
   802.3 packet.

   The proposed standard for transmission of IP datagrams over IEEE
   802.3 networks is specified in RFC 948 [127].



Reynolds & Postel                                              [Page 26]

Assigned Numbers                                                 RFC 960
Ethernet Numbers


                      ETHERNET NUMBERS OF INTEREST

   Many of the networks of all classes are Ethernets (10Mb) or
   Experimental Ethernets (3Mb).  These systems use a message "type"
   field in much the same way the ARPANET uses the "link" field.

   If you need an Ethernet number, contact the XEROX Corporation, Office
   Products Division, Network Systems Administration Office, 333 Coyote
   Hill Road, Palo Alto, California, 94304.

   Assignments:

      Ethernet          Exp. Ethernet    Description          References
      -------------     -------------   -----------           ----------
      decimal  Hex      decimal  octal
         512   0200        512   1000   XEROX PUP                [1,HGM]
         513   0201        -      -     PUP Addr. Trans.           [HGM]
        1536   0600       1536   3000   XEROX NS IDP           [128,HGM]
        2048   0800        513   1001   DOD IP               [39,91,JBP]
        2049   0801        -      -     X.75 Internet              [HGM]
        2050   0802        -      -     NBS Internet               [HGM]
        2051   0803        -      -     ECMA Internet              [HGM]
        2052   0804        -      -     Chaosnet                   [HGM]
        2053   0805        -      -     X.25 Level 3               [HGM]
        2054   0806        -      -     ARP                     [74,JBP]
        2055   0807        -      -     XNS Compatability          [HGM]
        2076   081C        -      -     Symbolics Private         [DCP1]
       32771   8003        -      -     Cronus VLN            [116,DT15]
       32772   8004        -      -     Cronus Direct         [116,DT15]
       32774   8006        -      -     Nestar                     [HGM]
       32784   8010        -      -     Excelan                    [HGM]
       32821   8035        -      -     Reverse ARP             [42,JCM]
       36864   9000        -      -     Loopback                   [HGM]

   The standard for transmission of IP datagrams over Ethernets and
   Experimental Ethernets is specified in RFC 894 [54] and RFC 895 [76]
   respectively.


Reynolds & Postel                                              [Page 27]
Technical Details
Message-ID: <2980001@hpcea.HP>
Path: arc1-ca.pugleaf.net!utzoo!watmath!clyde!cbosgd!gatech!hplabs!hpcea!wunder
References: <10806@amdcad.UUCP>

Show Full Headers
Complete Article Headers
Relay-Version: version B 2.10 5/3/83; site utzoo.UUCP
Path: arc1-ca.pugleaf.net!utzoo!watmath!clyde!cbosgd!gatech!hplabs!hpcea!wunder
From: wunder@hpcea.HP (Walter R. Underwood)
Newsgroups: net.lan
Subject: Re: List of ethernet protocol numbers wanted
Message-ID: <2980001@hpcea.HP>
Date: Wed, 19-Mar-86 15:49:17 EST
Article-I.D.: hpcea.2980001
Posted: Wed Mar 19 15:49:17 1986
Date-Received: Fri, 21-Mar-86 06:34:12 EST
References: <10806@amdcad.UUCP>
Lines: 93