🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: swnet.general
Article #79

SUNET angriper problemen med svenska tecken i datorpost

#79
From: Hans Wallberg
Date: Thu, 03 Nov 1994 10:15
192 lines
9622 bytes
                                                     SUNET 1994-11-01


HUR SUNET F\RS\KER L\SA PROBLEMEN MED SVENSKA BOKST[VER I
DATORPOST


Styrelsen f|r det svenska universitetsdatorn{tet, SUNET, har
beslutat att starta ett projekt f|r att f} till st}nd en
b{ttre hantering av svenska tecken i datorpost. Nuvarande
situation med flera olika teckenkoder som anv{nds parallellt
{r klart otillfredsst{llande. 

Det huvudsakliga problemet {r att de tre sista bokst{verna i
det svenska alfabetet alltf|r ofta kan bli felaktigt visade p}
bildsk{rmen hos mottagaren av ett datorbrev. Detta kan ha tv}
orsaker:
  
1. Avs{ndaren och mottagaren anv{nder olika teckenkod* (svensk
   7-bits teckenkod*, Latin-1*, Mac-teckenkod, PC-teckenkod
   etc).

2. N}got av de program som sk|ter transporten av brevet har
   f|rst|rt eller f|r{ndrat teckenkoden till n}gonting som
   inte passar mottagarens datorpostprogram.

   En vanlig form av f|rvanskning -- att man f}r EDV i st{llet
   f|r de tre nationella svenska bokst{verna -- beror p} att
   n}got program p} v{gen mellan avs{ndare och mottagare
   nollst{ller den h|gsta biten i varje oktett/byte. Detta {r
   dock helt enligt den grundstandard, SMTP*, som g{ller f|r
   datorpost p} SUNET och Internet.

Vid ett m|te den 28 september med datorpostansvariga vid
svenska universitet och h|gskolor och efter h|rande av
SUNET:s tekniska referensgrupp har SUNET beslutat att fr}n
den 1 januari 1995 rekommendera att datorpost utanf|r den
egna organisationen hanteras enligt den nya standarden MIME*
f|r datorpost p} Internet. [ven inom den egna organisationen
b|r datorpost hanteras enligt samma standard.

Den teckenkod som ska anv{ndas f|r svensk text {r Latin-1. D{r
representeras de tre sista bokst{verna i det svenska alfabetet
av h|ga* oktetter. 

Enligt det sedan b|rjan av 80-talet anv{nda protokollet f|r
datorpost, SMTP, ska dock inga h|ga oktetter anv{ndas.
Fortfarande g{ller att man under INGA omst{ndigheter f}r
skicka dessa oktetter ut p} n{tet "rakt upp och ner". I
st{llet b|r i f|rsta hand utvidgningen ESMTP* av SMTP-
protokollet till{mpas. Det inneb{r att h|ga oktetter skickas
bara om det mottagande programmet bekr{ftar att det kan
hantera brev med h|ga oktetter. I andra hand skall text i
teckenkoden Latin-1 transportkodas enligt MIME-metoden
Quoted-Printable*.

Detta inneb{r att den gamla rekommendationen att anv{nda
svensk 7-bits teckenkod i datorpost inte l{ngre g{ller efter 1
januari 1995.

Vi bed|mmer dock inte tiden som mogen att {ven f|rorda MIME
generellt f|r "Internet News"* - officiella Internet-
rekommendationer saknas {nnu och antalet News-hanterings-
program som klarar att l{sa och skapa News-inl{gg med MIME {r
l}gt. Rekommendationen att anv{nda svensk 7-bits teckenkod f|r
News kvarst}r allts} tills vidare. (H|ga oktetter skall allts}
inte skickas i News-inl{gg.)

Det {r givetvis inte tillfredst{llande att anv{nda fundamen-
talt olika s{tt att representera svensk text i datorpost och i
News, med tanke p} behoven av n{ra samverkan mellan dessa
kommunikationsformer. SUNET vill d{rf|r stimulera till en
|ppen diskussion om hur problemen med nationella bokst{ver ska
l|sas i News. Tills vidare b|r den f|ras i News-gruppen
swnet.mail.

SUNET avser att rekommendera generell anv{ndning av tecken-
koden Latin-1 i rena textfiler och HTML*-filer som tillhanda-
h}lls via Gopher*, World Wide Web* och anonym FTP*. [ven
Gopher-menyer och titelf{ltet f|r WWW-sidor b|r anv{nda
Latin-1. Diskussion om en s}dan rekommendation {r l{mplig och
genomf|rbar b|r f|ras i News-gruppen swnet.mail.


F|r att underl{tta den beslutade |verg}ngen till MIME kommer
SUNET att utv{rdera datorpostprogram i Macintosh-, MS-Windows-
och Unix-milj|er. Utv{rderingen skall avse MIME-kompatibilitet
och MIME-anv{ndbarhet. SUNET kommer d{refter att kunna ge
rekommendationer om l{mpliga datorpostprogram.

SUNET kommer ocks} att vidareutveckla konverteringsprogrammet
EMIL s} att det f}r |kad funktionalitet och blir l{ttare att
installera och konfigurera. Med hj{lp av EMIL {r det m|jligt
att ge MIME-st|d till datormilj|er som av n}gon orsak inte
omedelbart kan g} |ver till MIME.

Mer information om MIME i allm{nhet och detta SUNET-projekt i
synnerhet kan f}s via World Wide Web, URL:

http://www.nada.kth.se/sunet-mime/

En del av dokumenten kan ocks} h{mtas via s.k. anonym FTP fr}n
ftp.nada.kth.se, i katalogen pub/sunet-mime.

Diskussion om detta projekt f|resl}s ske i News-m|tet
swnet.mail. Fr}gor och tips till projektgruppen kan skickas
till <sunet-mime-info@sunet.se>


Om du undrar |ver n}got av de tekniska orden
--------------------------------------------

Teckenkod = en fullst{ndig upps{ttning regler f|r hur olika
tecken ska representeras i form av nollor och ettor i datorn.

Svensk 7-bits teckenkod = den teckenkod f|r svensk text som
var vanlig i datorer i b|rjan p} 80-talet. Liknar den
amerikanska teckenkoden ASCII mycket, men bland annat hak-
parenteser och bak}tlutande snedstreck har ersatts med svenska
bokst{ver. Den {r en svensk standard och kallas i MIME f|r
SEN_850200_B. G}r ocks} under den oegentliga ben{mningen
"svensk ASCII".

Latin-1 = den teckenkod som kommer att rekommenderas f|r
anv{ndning i SUNET. Anv{nds i Microsoft Windows och m}nga
Unixdatorer. Den {r dubbelt s} stor som ASCII och svensk
7-bits teckenkod och rymmer d{rf|r alla ASCII-tecken och
dessutom alla bokst{ver med accenter och liknande som anv{nds
i v{steuropeiska spr}k. [r en internationell standard och
kallas i MIME f|r ISO-8859-1.

H|ga oktetter = oktetter d{r h|gsta biten {r 1. All
information i en dator lagras som bitar, som antingen {r noll
eller ett. Ofta behandlas }tta s}dana som en enhet, en oktett
eller byte. ]tta bitar ger 256 olika kombinationsm|jligheter,
man s{ger att oktetten har ett v{rde mellan 0 och 255. H|ga
oktetter har v{rden mellan 128 och 255. I teckenkoden Latin-1
ing}r 256 tecken, eftersom varje tecken representeras av en
oktett. Bland annat de svenska nationella bokst{verna
representeras i Latin-1 av h|ga oktetter.
 
Quoted-Printable = metod definierad i MIME f|r att under
transporten av ett datorbrev tillf{lligt representera h|ga
oktetter med l}ga oktetter. Om de tre besv{rliga svenska
bokst{verna {r kodade enligt Latin-1 s} representeras de stora
bokst{verna av teckentripplarna =C5 =C4 =D6 och de sm} av =E5
=E4 =F6, enligt Quoted-Printable.

SMTP = Simple Mail Transfer Protocol:
den grundstandard f|r datorpost som anv{nds i SUNET och
Internet. SMTP definieras i Internet-dokumentet RFC* 821.

MIME = Multipurpose Internet Mail Extensions:
ett till{gg till bl.a. SMTP som beskriver hur brev
inneh}llande "oamerikanska" tecken eller multimedia-objekt kan
skickas p} Internet. MIME definieras i dokumenten RFC 1521 och
RFC 1522.

ESMTP = Extended Simple Mail Transfer Protocol: 
En modifiering av SMTP som g|r det m|jligt att skicka ocks}
h|ga oktetter i datorbrev. Detta g|rs genom anv{ndning av
kommandot EHLO och parametern BODY=8BITMIME till kommandot
MAIL FROM. Detta definieras i Internet-dokumenten RFC 1651 och
RFC 1652.

RFC = Request for Comments:
En serie av tekniska dokument som har tagits fram under
utvecklingen av Internet. Bland annat definieras alla
kommunikationsprotokoll p} Internet i olika RFC-dokument.
RFC:erna f}r kopieras och spridas gratis och tillhandah}lls p}
m}nga datorer p} Internet, bland annat p} SUNET:s dator
sunic.sunet.se.

Internet News:
Det f|rsta v{rldsomsp{nnande, helt |ppna datorkonferens-
systemet. Diskussionerna {r uppdelade p} tusentals olika
intresseomr}den, s.k. News-grupper. Alla anv{ndare p} en
Internet-ansluten News-dator kan l{sa andras artiklar i en
News-grupp och skicka egna dit.

World Wide Web (WWW), Gopher, anonym FTP:
Olika metoder f|r att l{sa och h{mta information, bilder,
program m.m. som finns tillg{ngliga p} Internet.

HTML = HyperText Markup Language:
Det dokumentformat som normalt anv{nds f|r information som
g|rs tillg{nglig i World Wide Web.

(Detta meddelande har skickats till: sunet-mime@sunet.se, 
nordpost@nada.kth.se, sunstyr@vhs.se, tref@vhs.se samt till
swnet.general, swnet.mail, swnet.siren, nordunet.talk.skandinaviska,
dk.general, soc.culture.nordic)
Technical Details
Message-ID: <Pine.ULT.3.91.941103111052.26551P-100000@poseidon.umdc.umu.se>
Path: arc1-ca.pugleaf.net!nntp.gmd.de!newsserver.jvnc.net!netnews.upenn.edu!dsinc!newsfeed.pitt.edu!gatech!howland.reston.ans.net!pipex!sunic!umdac!poseidon.umdc.umu.se!hwg

Show Full Headers
Complete Article Headers
X-Google-Language: SWEDISH,ASCII-7-bit
X-Google-Thread: 10a632,fcbaeba7422bd743,start
X-Google-Attributes: gid10a632,public
X-Google-Thread: fe902,fcbaeba7422bd743,start
X-Google-Attributes: gidfe902,public
X-Google-Thread: 10adee,fcbaeba7422bd743,start
X-Google-Attributes: gid10adee,public
X-Google-Thread: fdf62,fcbaeba7422bd743,start
X-Google-Attributes: gidfdf62,public
X-Google-Thread: f4659,fcbaeba7422bd743,start
X-Google-Attributes: gidf4659,public
X-Google-Thread: 1135b8,fcbaeba7422bd743,start
X-Google-Attributes: gid1135b8,public
X-Google-ArrivalTime: 1994-11-03 02:15:34 PST
Path: arc1-ca.pugleaf.net!nntp.gmd.de!newsserver.jvnc.net!netnews.upenn.edu!dsinc!newsfeed.pitt.edu!gatech!howland.reston.ans.net!pipex!sunic!umdac!poseidon.umdc.umu.se!hwg
From: Hans Wallberg <hwg@poseidon.umdc.umu.se>
Newsgroups: swnet.general,swnet.mail,swnet.siren,nordunet.talk.skandinaviska,dk.general,soc.culture.nordic
Subject: SUNET angriper problemen med svenska tecken i datorpost
Followup-To: swnet.mail
Date: Thu, 3 Nov 1994 11:15:34 +0100
Organization: University of Umea, Sweden
Lines: 193
Message-ID: <Pine.ULT.3.91.941103111052.26551P-100000@poseidon.umdc.umu.se>
NNTP-Posting-Host: poseidon.umdc.umu.se
Mime-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII