🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: uk.comp.os.linux
Article #477

Re: Proxy server

#477
From: Andrew M. Bishop
Date: Tue, 14 Dec 1999 00:00
64 lines
3523 bytes
In newsgroup uk.comp.os.linux,demon.tech.unix
Ian Stirling <root@mauve.demon.co.uk> wrote:
> Andrew M. Bishop <amb@gedanken.demon.co.uk> wrote:
> >I would suggest that you look at WWWOFFLE if you have a dialup
> >connection.
> 
> A very nice program, that I'd hate to live without.

> However, I've recently run into a couple of problems.
> 
> Should I be able to go to the request page, and type
> http://user:pass@some.site.org/
> 
> As the search string, or is this a "will sometimes work" thing.

If you enter this into the URL box of a browser or the WWWOFFLE
request page then it will get it.

> I've enocountered various strangenesses, such as 
> a fetch for http://USER:PASSWORD@site/ (in netscape, url directly typed)
> that's sent to the wwwoffled proxy port correctly,
> coming out as 
> 
> wwwoffles[8514]: URL='http://user:PASSWORD@host' (With username/password).

This means that the USER:PASSWORD@host has been parsed by WWWOFFLE as
a hostname because the username and password are not displayed in this
informational message.  If you run WWWOFFLE with debugging level of
error reporting (wwwoffled -d 5) you will see the URL split up into
the constituent parts.

I would guess that you have some funny characters in the username or
password (like a '/' in the password which according to RFC 1738
should be replaced by %2f, ':' and '@' also need hex encoding).

For example: if the username is 'user' and the password is '8000/foo'
then the URL you might type is 'http://user:8000/foo@host/' which is
parsed as a hostname and port number.  You should instead have used
'http://user:8000%2ffoo@host/' which is obviously a passworded URL.

I believe that WWWOFFLE does do this parsing correctly, if you can
come up with an actual username and password which does not work then
mail me (it doesn't have to be your real one, just an example that
fails).

> Is there somewhere I can read up on how passwords are supposed to work
> in general, in http, so I can better understand what the code should
> do, and why it isn't?

The HTTP and URL specifications, that would be RFC 1945 for HTTP/1.0,
RFC 2616 for HTTP/1.1 and RFC 1738 for URLs.

WWWOFFLE will convert all URLs of the form http://USER:PASSWORD@site/
into an HTTP request for http://site/ with a Basic authentication
scheme using USER:PASSWORD as the username/password.

-- 
Andrew.
----------------------------------------------------------------------
Andrew M. Bishop                             amb@gedanken.demon.co.uk
                                      http://www.gedanken.demon.co.uk/

WWWOFFLE users page:
        http://www.gedanken.demon.co.uk/wwwoffle/version-2.5/user.html
Technical Details
Message-ID: <vo4sdlxs2p.fsf@g2.gedanken>
Path: arc1-ca.pugleaf.net!unknown!not-for-mail
References: <38513F91.261413D9@dunvegan1.demon.co.uk> <vo7lily94t.fsf@g2.gedanken> <945092872.13260.0.nnrp-07.9e98d142@news.demon.co.uk>

Show Full Headers
Complete Article Headers
X-Google-Language: ENGLISH,ASCII-7-bit
X-Google-Thread: 10d8ad,4fef5e0e83c62cd2
X-Google-Attributes: gid10d8ad,public
X-Google-Thread: fac57,4fef5e0e83c62cd2
X-Google-Attributes: gidfac57,public
From: amb@gedanken.demon.co.uk (Andrew M. Bishop)
Subject: Re: Proxy server
Date: 1999/12/14
Message-ID: <vo4sdlxs2p.fsf@g2.gedanken>
X-Deja-AN: 560872125
X-NNTP-Posting-Host: gedanken.demon.co.uk:158.152.211.20
Sender: amb@g2.gedanken
References: <38513F91.261413D9@dunvegan1.demon.co.uk> <vo7lily94t.fsf@g2.gedanken> <945092872.13260.0.nnrp-07.9e98d142@news.demon.co.uk>
X-NNTP-Server: PNews (Perl News Server)
X-Complaints-To: abuse@demon.net
X-Trace: news.demon.co.uk 945240577 nnrp-02:28035 NO-IDENT gedanken.demon.co.uk:158.152.211.20
Newsgroups: uk.comp.os.linux,demon.tech.unix