Article View: bit.listserv.mail-l
Article #759RFC1341 on MIME: Multipurpose Internet Mail Extensions
From: Roger Fajman
Date: Fri, 12 Jun 1992 05:02
Date: Fri, 12 Jun 1992 05:02
89 lines
4536 bytes
4536 bytes
== For Your Information ==
A new Request for Comments is now available in the online RFC
libraries.
Note: This is a PostScript RFC, a secondary version is available in
ASCII. The secondary ASCII version may lack figures and the
information encoded in typographic variation (italics, boldface,
etc.). Since this information often provides essential context, the
ASCII version is at best incomplete and at worst misleading. Anyone
expecting to understand this document is strongly encouraged to obtain
the PostScript version.
RFC 1341:
Title: MIME (Multipurpose Internet Mail Extensions):
Mechanisms for Specifying and Describing
the Format of Internet Message Bodies
Author: N. Borenstein & N. Freed
Mailbox: nsb@bellcore.com, ned@innosoft.com
PS-Pages: 69 ASCII-Pages: 80
PS-Characters: 347,082 ASCII-Characters: 211,117
Updates/Obsoletes: none
RFC 822 defines a message representation protocol which specifies
considerable detail about message headers, but which leaves the
message content, or message body, as flat ASCII text. This document
redefines the format of message bodies to allow multi-part textual and
non-textual message bodies to be represented and exchanged without
loss of information. This is based on earlier work documented in RFC
934 and RFC 1049, but extends and revises that work. Because RFC 822
said so little about message bodies, this document is largely
orthogonal to (rather than a revision of) RFC 822.
In particular, this document is designed to provide facilities to
include multiple objects in a single message, to represent body text
in character sets other than US-ASCII, to represent formatted
multi-font text messages, to represent non-textual material such as
images and audio fragments, and generally to facilitate later
extensions defining new types of Internet mail for use by cooperating
mail agents.
This document does NOT extend Internet mail header fields to permit
anything other than US-ASCII text data. It is recognized that such
extensions are necessary, and they are the subject of a companion
document (RFC 1342). This document is the product of the Internet
Message Extensions Working Group of the IETF.
This is now a Proposed Standard Protocol.
This RFC specifies an IAB standards track protocol for the Internet
community, and requests discussion and suggestions for improvements.
Please refer to the current edition of the "IAB Official Protocol
Standards" for the standardization state and status of this protocol.
Distribution of this memo is unlimited.
This announcement is sent to the IETF list and the RFC-DIST list.
Requests to be added to or deleted from the IETF distribution list
should be sent to IETF-REQUEST@NRI.RESTON.VA.US. Requests to be added
to or deleted from the RFC-DIST distribution list should be sent to
RFC-REQUEST@NIC.DDN.MIL.
RFCs can be obtained via FTP from FTP.NISC.SRI.COM, NIS.NSF.NET,
NISC.JVNC.NET, VENERA.ISI.EDU, WUARCHIVE.WUSTL.EDU, SRC.DOC.IC.AC.UK,
FTP.CONCERT.NET, or NIC.DDN.MIL.
Details on obtaining RFCs via FTP or EMAIL may be obtained by sending
an EMAIL message to "rfc-info@ISI.EDU" with the message body
"help: ways_to_get_rfcs". For example:
To: rfc-info@ISI.EDU
Subject: getting rfcs
help: ways_to_get_rfcs
Requests for special distribution should be addressed to either the
author of the RFC in question, or to NIC@NIC.DDN.MIL. Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.
Submissions for Requests for Comments should be sent to
RFC-EDITOR@ISI.EDU. Please consult RFC 1111, "Instructions to RFC
Authors", for further information.
Joyce K. Reynolds
USC/Information Sciences Institute
Technical Details
Message-ID:
<MAIL-L%92061201040489@BITNIC.EDUCOM.EDU>Path:
arc1-ca.pugleaf.net!sparky!uunet!zaphod.mps.ohio-state.edu!uwm.edu!psuvax1!psuvm!auvm!NIHCU.BITNET!RAFShow Full Headers
Complete Article Headers
X-Google-Language: ENGLISH,ASCII-7-bit X-Google-Thread: 10d8d0,143016612233bf20,start X-Google-Attributes: gid10d8d0,public X-Google-ArrivalTime: 1992-06-11 12:23:18 PST Comments: Gated by NETNEWS@AUVM.AMERICAN.EDU Path: arc1-ca.pugleaf.net!sparky!uunet!zaphod.mps.ohio-state.edu!uwm.edu!psuvax1!psuvm!auvm!NIHCU.BITNET!RAF Message-ID: <MAIL-L%92061201040489@BITNIC.EDUCOM.EDU> Newsgroups: bit.listserv.mail-l Date: Fri, 12 Jun 1992 01:02:39 EDT Sender: BITNIC MAIL-L List <MAIL-L@UGA.BITNET> From: Roger Fajman <RAF@NIHCU.BITNET> Subject: RFC1341 on MIME: Multipurpose Internet Mail Extensions Lines: 89