🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: comp.client-server
Article #160

Re: Sun RPC time-out question

#160
From: Lupe Christoph
Date: Sun, 20 Dec 1992 16:46
40 lines
2274 bytes
guido@cwi.nl (Guido van Rossum) writes:

>Is there an expert on Sun RPC in this group?

>I am in the process of re-implementing Sun RPC.  All the documentation
>I have are RFC1014 (XDR) and RFC1057 (RPC), and RFC1094 (NFS).  I have
>a question that isn't answered by these documents:

I'm wondering why you do that, given that Sun's implementation is
publicxly available in source.

>When using the UDP version, how does the client recover from lost
>packets?  When the call packet is lost, a simple retransmission is
>enough, however, when a reply packet is lost, a retransmission can
>cause the request to be executed twice.  How does e.g. an NFS client
>handle this if the request is not idempotent (like RENAME)?  Is there
>a way for the client to tell from the failing reply from the second
>try that the first try must have succeeded even though the response
>got lost?

A client cannot know if his request got lost, or the response. Both
result in a timeout. The client will retransmit or give up, depending
on circumstance.

>Note that I need to know how the existing Sun RPC implementation
>handles this situation, not how it could be done in a hypothetical
>system (I know all about Amoeba's RPC, for instance).

If the request is not idempotent, you need to activate the server
cache with svcudp_enablecache(). Note that is an undocumented
function. Get the 4.0 rpcxdr source and look there for details.

>Pointers to sources or documents are welcome!

Sources: see above, docs: RTFS ;-)
-- 
| ...!unido!ukw!lupe  (German EUNet, "bang")     |  Disclaimer:            |
| lupe@ukw.UUCP       (German EUNet, domain)     |  This is an unofficial  |
| suninfo!alanya!lupe (Sun Germany)              |  opinion of Christoph & |
| Res non sunt complicanda praeter necessitatem. |  Imschweiler Consulting |
Technical Details
Message-ID: <1992Dec20.164620.13282@ukw.uucp>
Path: arc1-ca.pugleaf.net!sparky!uunet!zaphod.mps.ohio-state.edu!cs.utexas.edu!sun-barr!news2me.EBay.Sun.COM!seven-up.East.Sun.COM!sungy!stasys!alanya!lupe
References: <8411@charon.cwi.nl>

Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!sparky!uunet!zaphod.mps.ohio-state.edu!cs.utexas.edu!sun-barr!news2me.EBay.Sun.COM!seven-up.East.Sun.COM!sungy!stasys!alanya!lupe
From: lupe@ukw.uucp (Lupe Christoph)
Newsgroups: comp.client-server
Subject: Re: Sun RPC time-out question
Message-ID: <1992Dec20.164620.13282@ukw.uucp>
Date: 20 Dec 92 16:46:20 GMT
References: <8411@charon.cwi.nl>
Sender: news@stasys.sta.sub.org
Organization: cic
Lines: 40